darkstat: fix DNS resolution on uClibc (#12323)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37351 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2013-07-15 20:50:55 +00:00
parent cf48a7d407
commit df799c9bb2
2 changed files with 14 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007-2012 OpenWrt.org
# Copyright (C) 2007-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=darkstat
PKG_VERSION:=3.0.715
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://unix4lyfe.org/darkstat

View File

@ -0,0 +1,12 @@
--- a/dns.c
+++ b/dns.c
@@ -346,9 +346,6 @@ dns_main(void)
reply.addr = ip;
flags = NI_NAMEREQD;
-# ifdef NI_IDN
- flags |= NI_IDN;
-# endif
switch (ip.family) {
case IPv4:
sin.sin_family = AF_INET;