[packages] zaptel: update to v1.2.27, change URLs, cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17957 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a025a13bb1
commit
df8f353edb
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2009 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,26 +8,23 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zaptel
|
PKG_NAME:=zaptel
|
||||||
PKG_VERSION:=1.2.12
|
PKG_VERSION:=1.2.27
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://ftp.digium.com/pub/zaptel/releases/ ftp://ftp.digium.com/pub/zaptel/releases/
|
PKG_SOURCE_URL:=http://downloads.asterisk.org/pub/telephony/zaptel/releases/
|
||||||
PKG_MD5SUM:=99b9f86556b903a32607b2751f920513
|
PKG_MD5SUM:=6e0ccf2a2a805054123b35bf8eb10ae9
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
define Package/zaptel/Default
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
URL:=http://ftp.digium.com/pub/zaptel/releases
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/zaptel-libtonezone
|
define Package/zaptel-libtonezone
|
||||||
$(call Package/zaptel/Default)
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=Zaptel tonezone library.
|
TITLE:=Zaptel tonezone library.
|
||||||
|
URL:=http://downloads.asterisk.org/pub/telephony/zaptel/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
@ -38,18 +35,19 @@ TARGET_CFLAGS += $(FPIC)
|
|||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
HOSTCC="$(HOSTCC)" \
|
HOSTCC="$(HOSTCC)" \
|
||||||
CFLAGS="$(TARGET_CFLAGS) -I. -DBUILDING_TONEZONE" \
|
CFLAGS="$(TARGET_CFLAGS) -I. -DBUILDING_TONEZONE" \
|
||||||
KSRC="$(LINUX_DIR)" \
|
KSRC="$(LINUX_DIR)" \
|
||||||
|
KVERS="$(LINUX_VERSION)" \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
install-tonezone
|
install-tonezone
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
mkdir -p $(1)/usr/include/linux
|
$(INSTALL_DIR) $(1)/usr/include/linux
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/linux/zaptel.h $(1)/usr/include/linux/
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/linux/zaptel.h $(1)/usr/include/linux/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/tonezone.h $(1)/usr/include/
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/tonezone.h $(1)/usr/include/
|
||||||
mkdir -p $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtonezone.so* $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtonezone.so* $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -1,19 +1,19 @@
|
|||||||
--- zaptel-1.2.12.org/Makefile 2006-12-07 00:22:11.000000000 +0100
|
--- a/Makefile
|
||||||
+++ zaptel-1.2.12/Makefile 2006-12-23 00:12:30.000000000 +0100
|
+++ b/Makefile
|
||||||
@@ -357,6 +357,16 @@
|
@@ -501,6 +501,16 @@ install-include: zaptel.h torisa.h
|
||||||
/sbin/update-modules ; \
|
install -d $(DESTDIR)$(INCLUDE_DIR)/linux
|
||||||
fi
|
install -m 644 zaptel.h torisa.h $(DESTDIR)$(INCLUDE_DIR)/linux/
|
||||||
|
|
||||||
+install-tonezone: $(LIBTONEZONE_SO)
|
+install-tonezone: $(LIBTONEZONE_SO)
|
||||||
+ install -D -m 755 $(LIBTONEZONE_SO) $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER)
|
+ install -D -m 755 $(LIBTONEZONE_SO) $(DESTDIR)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER)
|
||||||
+ rm -f $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO)
|
+ rm -f $(DESTDIR)/usr/lib/$(LIBTONEZONE_SO)
|
||||||
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
|
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
|
||||||
+ $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER)
|
+ $(DESTDIR)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER)
|
||||||
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
|
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
|
||||||
+ $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO)
|
+ $(DESTDIR)/usr/lib/$(LIBTONEZONE_SO)
|
||||||
+ install -D -m 644 zaptel.h $(INSTALL_PREFIX)/usr/include/linux/zaptel.h
|
+ install -D -m 644 zaptel.h $(DESTDIR)/usr/include/linux/zaptel.h
|
||||||
+ install -D -m 644 tonezone.h $(INSTALL_PREFIX)/usr/include/tonezone.h
|
+ install -D -m 644 tonezone.h $(DESTDIR)/usr/include/tonezone.h
|
||||||
+
|
+
|
||||||
install-udev: devices
|
install-udev: devices
|
||||||
|
|
||||||
firmware:
|
# FIRMWARE_DIR also implies HOTPLUG_FIRMWARE, unless set manually.
|
||||||
|
Loading…
x
Reference in New Issue
Block a user