openvpn: update to 2.1_rc19 (patch from #5900)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17731 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0c9ca6fd4e
commit
dfa5901ca7
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openvpn
|
PKG_NAME:=openvpn
|
||||||
PKG_VERSION:=2.1_rc18
|
PKG_VERSION:=2.1_rc19
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
|
PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
|
||||||
PKG_MD5SUM:=af330c94da5200df94c4e84798ea39be
|
PKG_MD5SUM:=ba2ee667a8b7606b125b7d32f47ca578
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -59,13 +59,13 @@ define Build/Configure
|
|||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/openvpn/install
|
define Package/openvpn/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/openvpn $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/openvpn $(1)/usr/sbin/
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d/
|
$(INSTALL_DIR) $(1)/etc/init.d/
|
||||||
@ -75,7 +75,7 @@ define Package/openvpn/install
|
|||||||
$(INSTALL_DIR) $(1)/etc/openvpn
|
$(INSTALL_DIR) $(1)/etc/openvpn
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/openvpn-easy-rsa/install
|
define Package/openvpn-easy-rsa/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(CP) $(PKG_BUILD_DIR)/easy-rsa/2.0/{build-*,clean-all,inherit-inter,list-crl,pkitool,revoke-full,sign-req,whichopensslcnf} $(1)/usr/sbin/
|
$(CP) $(PKG_BUILD_DIR)/easy-rsa/2.0/{build-*,clean-all,inherit-inter,list-crl,pkitool,revoke-full,sign-req,whichopensslcnf} $(1)/usr/sbin/
|
||||||
$(INSTALL_DIR) $(1)/etc/easy-rsa
|
$(INSTALL_DIR) $(1)/etc/easy-rsa
|
||||||
|
@ -1,15 +1,18 @@
|
|||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-ca openvpn-2.0.7/easy-rsa/2.0/build-ca
|
--- a/easy-rsa/2.0/build-ca
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-ca 2005-11-02 19:42:38.000000000 +0100
|
+++ b/easy-rsa/2.0/build-ca
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-ca 2006-05-09 17:47:40.000000000 +0200
|
@@ -1,8 +1,8 @@
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
#
|
#
|
||||||
# Build a root certificate
|
# Build a root certificate
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-dh openvpn-2.0.7/easy-rsa/2.0/build-dh
|
#
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-dh 2005-11-02 19:42:39.000000000 +0100
|
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-dh 2006-05-09 17:47:40.000000000 +0200
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
|
-"$EASY_RSA/pkitool" --interact --initca $*
|
||||||
|
+"/usr/sbin/pkitool" --interact --initca $*
|
||||||
|
--- a/easy-rsa/2.0/build-dh
|
||||||
|
+++ b/easy-rsa/2.0/build-dh
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
@ -18,72 +21,95 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-dh openvpn-2.0.7/easy-rsa/2.0/bui
|
|||||||
|
|
||||||
# Build Diffie-Hellman parameters for the server side
|
# Build Diffie-Hellman parameters for the server side
|
||||||
# of an SSL/TLS connection.
|
# of an SSL/TLS connection.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-inter openvpn-2.0.7/easy-rsa/2.0/build-inter
|
--- a/easy-rsa/2.0/build-inter
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-inter 2005-11-02 19:42:39.000000000 +0100
|
+++ b/easy-rsa/2.0/build-inter
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-inter 2006-05-09 17:47:40.000000000 +0200
|
@@ -1,7 +1,7 @@
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Make an intermediate CA certificate/private key pair using a locally generated
|
# Make an intermediate CA certificate/private key pair using a locally generated
|
||||||
# root certificate.
|
# root certificate.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key openvpn-2.0.7/easy-rsa/2.0/build-key
|
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-key 2005-11-02 19:42:39.000000000 +0100
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-key 2006-05-09 17:47:40.000000000 +0200
|
-"$EASY_RSA/pkitool" --interact --inter $*
|
||||||
@@ -1,4 +1,4 @@
|
+"/usr/sbin/pkitool" --interact --inter $*
|
||||||
|
--- a/easy-rsa/2.0/build-key
|
||||||
|
+++ b/easy-rsa/2.0/build-key
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Make a certificate/private key pair using a locally generated
|
# Make a certificate/private key pair using a locally generated
|
||||||
# root certificate.
|
# root certificate.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pass openvpn-2.0.7/easy-rsa/2.0/build-key-pass
|
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pass 2005-11-02 19:42:39.000000000 +0100
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-key-pass 2006-05-09 17:47:40.000000000 +0200
|
-"$EASY_RSA/pkitool" --interact $*
|
||||||
@@ -1,4 +1,4 @@
|
+"/usr/sbin/pkitool" --interact $*
|
||||||
|
--- a/easy-rsa/2.0/build-key-pass
|
||||||
|
+++ b/easy-rsa/2.0/build-key-pass
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Similar to build-key, but protect the private key
|
# Similar to build-key, but protect the private key
|
||||||
# with a password.
|
# with a password.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pkcs12 openvpn-2.0.7/easy-rsa/2.0/build-key-pkcs12
|
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-key-pkcs12 2005-11-02 19:42:39.000000000 +0100
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-key-pkcs12 2006-05-09 17:47:40.000000000 +0200
|
-"$EASY_RSA/pkitool" --interact --pass $*
|
||||||
@@ -1,4 +1,4 @@
|
+"/usr/sbin/pkitool" --interact --pass $*
|
||||||
|
--- a/easy-rsa/2.0/build-key-pkcs12
|
||||||
|
+++ b/easy-rsa/2.0/build-key-pkcs12
|
||||||
|
@@ -1,8 +1,8 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Make a certificate/private key pair using a locally generated
|
# Make a certificate/private key pair using a locally generated
|
||||||
# root certificate and convert it to a PKCS #12 file including the
|
# root certificate and convert it to a PKCS #12 file including the
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-key-server openvpn-2.0.7/easy-rsa/2.0/build-key-server
|
# the CA certificate as well.
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-key-server 2005-11-02 19:42:39.000000000 +0100
|
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-key-server 2006-05-09 17:47:40.000000000 +0200
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
|
-"$EASY_RSA/pkitool" --interact --pkcs12 $*
|
||||||
|
+"/usr/sbin/pkitool" --interact --pkcs12 $*
|
||||||
|
--- a/easy-rsa/2.0/build-key-server
|
||||||
|
+++ b/easy-rsa/2.0/build-key-server
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Make a certificate/private key pair using a locally generated
|
# Make a certificate/private key pair using a locally generated
|
||||||
# root certificate.
|
# root certificate.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-req openvpn-2.0.7/easy-rsa/2.0/build-req
|
@@ -7,4 +7,4 @@
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-req 2005-11-02 19:42:38.000000000 +0100
|
# extension in the openssl.cnf file.
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-req 2006-05-09 17:47:40.000000000 +0200
|
|
||||||
@@ -1,4 +1,4 @@
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
|
-"$EASY_RSA/pkitool" --interact --server $*
|
||||||
|
+"/usr/sbin/pkitool" --interact --server $*
|
||||||
|
--- a/easy-rsa/2.0/build-req
|
||||||
|
+++ b/easy-rsa/2.0/build-req
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Build a certificate signing request and private key. Use this
|
# Build a certificate signing request and private key. Use this
|
||||||
# when your root certificate and key is not available locally.
|
# when your root certificate and key is not available locally.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/build-req-pass openvpn-2.0.7/easy-rsa/2.0/build-req-pass
|
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/build-req-pass 2005-11-02 19:42:39.000000000 +0100
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/build-req-pass 2006-05-09 17:47:40.000000000 +0200
|
-"$EASY_RSA/pkitool" --interact --csr $*
|
||||||
@@ -1,4 +1,4 @@
|
+"/usr/sbin/pkitool" --interact --csr $*
|
||||||
|
--- a/easy-rsa/2.0/build-req-pass
|
||||||
|
+++ b/easy-rsa/2.0/build-req-pass
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Like build-req, but protect your private key
|
# Like build-req, but protect your private key
|
||||||
# with a password.
|
# with a password.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/clean-all openvpn-2.0.7/easy-rsa/2.0/clean-all
|
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/clean-all 2005-11-02 19:42:39.000000000 +0100
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/clean-all 2006-05-09 17:47:40.000000000 +0200
|
-"$EASY_RSA/pkitool" --interact --csr --pass $*
|
||||||
|
+"/usr/sbin/pkitool" --interact --csr --pass $*
|
||||||
|
--- a/easy-rsa/2.0/clean-all
|
||||||
|
+++ b/easy-rsa/2.0/clean-all
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
@ -92,9 +118,8 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/clean-all openvpn-2.0.7/easy-rsa/2.0/cl
|
|||||||
|
|
||||||
# Initialize the $KEY_DIR directory.
|
# Initialize the $KEY_DIR directory.
|
||||||
# Note that this script does a
|
# Note that this script does a
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/inherit-inter openvpn-2.0.7/easy-rsa/2.0/inherit-inter
|
--- a/easy-rsa/2.0/inherit-inter
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/inherit-inter 2005-11-02 19:42:38.000000000 +0100
|
+++ b/easy-rsa/2.0/inherit-inter
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/inherit-inter 2006-05-09 17:47:40.000000000 +0200
|
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
@ -103,9 +128,8 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/inherit-inter openvpn-2.0.7/easy-rsa/2.
|
|||||||
|
|
||||||
# Build a new PKI which is rooted on an intermediate certificate generated
|
# Build a new PKI which is rooted on an intermediate certificate generated
|
||||||
# by ./build-inter or ./pkitool --inter from a parent PKI. The new PKI should
|
# by ./build-inter or ./pkitool --inter from a parent PKI. The new PKI should
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/list-crl openvpn-2.0.7/easy-rsa/2.0/list-crl
|
--- a/easy-rsa/2.0/list-crl
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/list-crl 2005-11-02 19:42:39.000000000 +0100
|
+++ b/easy-rsa/2.0/list-crl
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/list-crl 2006-05-09 17:47:40.000000000 +0200
|
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
@ -114,9 +138,8 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/list-crl openvpn-2.0.7/easy-rsa/2.0/lis
|
|||||||
|
|
||||||
# list revoked certificates
|
# list revoked certificates
|
||||||
|
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/pkitool openvpn-2.0.7/easy-rsa/2.0/pkitool
|
--- a/easy-rsa/2.0/pkitool
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/pkitool 2005-11-02 19:42:38.000000000 +0100
|
+++ b/easy-rsa/2.0/pkitool
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/pkitool 2006-05-09 17:47:40.000000000 +0200
|
|
||||||
@@ -1,5 +1,7 @@
|
@@ -1,5 +1,7 @@
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
|
|
||||||
@ -125,9 +148,8 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/pkitool openvpn-2.0.7/easy-rsa/2.0/pkit
|
|||||||
# OpenVPN -- An application to securely tunnel IP networks
|
# OpenVPN -- An application to securely tunnel IP networks
|
||||||
# over a single TCP/UDP port, with support for SSL/TLS-based
|
# over a single TCP/UDP port, with support for SSL/TLS-based
|
||||||
# session authentication and key exchange,
|
# session authentication and key exchange,
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/revoke-full openvpn-2.0.7/easy-rsa/2.0/revoke-full
|
--- a/easy-rsa/2.0/revoke-full
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/revoke-full 2005-11-02 19:42:39.000000000 +0100
|
+++ b/easy-rsa/2.0/revoke-full
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/revoke-full 2006-05-09 17:47:40.000000000 +0200
|
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
@ -136,18 +158,20 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/revoke-full openvpn-2.0.7/easy-rsa/2.0/
|
|||||||
|
|
||||||
# revoke a certificate, regenerate CRL,
|
# revoke a certificate, regenerate CRL,
|
||||||
# and verify revocation
|
# and verify revocation
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/sign-req openvpn-2.0.7/easy-rsa/2.0/sign-req
|
--- a/easy-rsa/2.0/sign-req
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/sign-req 2005-11-02 19:42:39.000000000 +0100
|
+++ b/easy-rsa/2.0/sign-req
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/sign-req 2006-05-09 17:47:40.000000000 +0200
|
@@ -1,7 +1,7 @@
|
||||||
@@ -1,4 +1,4 @@
|
|
||||||
-#!/bin/bash
|
-#!/bin/bash
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
|
|
||||||
# Sign a certificate signing request (a .csr file)
|
# Sign a certificate signing request (a .csr file)
|
||||||
# with a local root certificate and key.
|
# with a local root certificate and key.
|
||||||
diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/vars openvpn-2.0.7/easy-rsa/2.0/vars
|
|
||||||
--- openvpn-2.0.7.orig/easy-rsa/2.0/vars 2005-11-02 19:42:39.000000000 +0100
|
export EASY_RSA="${EASY_RSA:-.}"
|
||||||
+++ openvpn-2.0.7/easy-rsa/2.0/vars 2006-05-09 17:47:40.000000000 +0200
|
-"$EASY_RSA/pkitool" --interact --sign $*
|
||||||
|
+"/usr/sbin/pkitool" --interact --sign $*
|
||||||
|
--- a/easy-rsa/2.0/vars
|
||||||
|
+++ b/easy-rsa/2.0/vars
|
||||||
@@ -12,7 +12,7 @@
|
@@ -12,7 +12,7 @@
|
||||||
# This variable should point to
|
# This variable should point to
|
||||||
# the top level of the easy-rsa
|
# the top level of the easy-rsa
|
||||||
@ -157,7 +181,7 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/vars openvpn-2.0.7/easy-rsa/2.0/vars
|
|||||||
|
|
||||||
#
|
#
|
||||||
# This variable should point to
|
# This variable should point to
|
||||||
@@ -26,7 +26,7 @@
|
@@ -26,7 +26,7 @@ export GREP="grep"
|
||||||
# This variable should point to
|
# This variable should point to
|
||||||
# the openssl.cnf file included
|
# the openssl.cnf file included
|
||||||
# with easy-rsa.
|
# with easy-rsa.
|
||||||
@ -166,84 +190,3 @@ diff -ur openvpn-2.0.7.orig/easy-rsa/2.0/vars openvpn-2.0.7/easy-rsa/2.0/vars
|
|||||||
|
|
||||||
# Edit this variable to point to
|
# Edit this variable to point to
|
||||||
# your soon-to-be-created key
|
# your soon-to-be-created key
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-ca openvpn-2.0.9/easy-rsa/2.0/build-ca
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-ca 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-ca 2007-06-18 01:21:07.000000000 +0200
|
|
||||||
@@ -5,4 +5,4 @@
|
|
||||||
#
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --initca $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --initca $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-inter openvpn-2.0.9/easy-rsa/2.0/build-inter
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-inter 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-inter 2007-06-18 01:21:19.000000000 +0200
|
|
||||||
@@ -4,4 +4,4 @@
|
|
||||||
# root certificate.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --inter $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --inter $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-key openvpn-2.0.9/easy-rsa/2.0/build-key
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-key 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-key 2007-06-18 01:21:32.000000000 +0200
|
|
||||||
@@ -4,4 +4,4 @@
|
|
||||||
# root certificate.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact $*
|
|
||||||
+"/usr/sbin/pkitool" --interact $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-key-pass openvpn-2.0.9/easy-rsa/2.0/build-key-pass
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-key-pass 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-key-pass 2007-06-18 01:21:45.000000000 +0200
|
|
||||||
@@ -4,4 +4,4 @@
|
|
||||||
# with a password.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --pass $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --pass $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-key-pkcs12 openvpn-2.0.9/easy-rsa/2.0/build-key-pkcs12
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-key-pkcs12 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-key-pkcs12 2007-06-18 01:21:57.000000000 +0200
|
|
||||||
@@ -5,4 +5,4 @@
|
|
||||||
# the CA certificate as well.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --pkcs12 $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --pkcs12 $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-key-server openvpn-2.0.9/easy-rsa/2.0/build-key-server
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-key-server 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-key-server 2007-06-18 01:22:09.000000000 +0200
|
|
||||||
@@ -7,4 +7,4 @@
|
|
||||||
# extension in the openssl.cnf file.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --server $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --server $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-req openvpn-2.0.9/easy-rsa/2.0/build-req
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-req 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-req 2007-06-18 01:22:27.000000000 +0200
|
|
||||||
@@ -4,4 +4,4 @@
|
|
||||||
# when your root certificate and key is not available locally.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --csr $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --csr $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/build-req-pass openvpn-2.0.9/easy-rsa/2.0/build-req-pass
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/build-req-pass 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/build-req-pass 2007-06-18 01:22:38.000000000 +0200
|
|
||||||
@@ -4,4 +4,4 @@
|
|
||||||
# with a password.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --csr --pass $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --csr --pass $*
|
|
||||||
diff -urN openvpn-2.0.9.orig/easy-rsa/2.0/sign-req openvpn-2.0.9/easy-rsa/2.0/sign-req
|
|
||||||
--- openvpn-2.0.9.orig/easy-rsa/2.0/sign-req 2007-06-18 01:20:36.000000000 +0200
|
|
||||||
+++ openvpn-2.0.9/easy-rsa/2.0/sign-req 2007-06-18 01:22:53.000000000 +0200
|
|
||||||
@@ -4,4 +4,4 @@
|
|
||||||
# with a local root certificate and key.
|
|
||||||
|
|
||||||
export EASY_RSA="${EASY_RSA:-.}"
|
|
||||||
-"$EASY_RSA/pkitool" --interact --sign $*
|
|
||||||
+"/usr/sbin/pkitool" --interact --sign $*
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user