libpng: moved to github
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@41469 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f2d8ff0676
commit
dff7c3d54b
@ -1,67 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2013 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=libpng
|
|
||||||
PKG_VERSION:=1.2.50
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
|
||||||
PKG_SOURCE_URL:=@SF/libpng
|
|
||||||
PKG_MD5SUM:=a3e00fccbfe356174ab515b5c00641c7
|
|
||||||
|
|
||||||
PKG_LICENSE:=LIBPNG GPLv2
|
|
||||||
PKC_LICENSE_FILES:=LICENSE contrib/gregbook/COPYING contrib/gregbook/LICENSE
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/libpng
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
DEPENDS:=+zlib
|
|
||||||
TITLE:=A PNG format files handling library
|
|
||||||
URL:=http://www.libpng.org/pub/png/libpng.html
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libpng{,12}-config $(1)/usr/bin/
|
|
||||||
$(SED) \
|
|
||||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
|
||||||
$(1)/usr/bin/libpng{,12}-config
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/png{,conf}.h $(1)/usr/include/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpng12 $(1)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.{a,la,so*} $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpng{,12}.pc $(1)/usr/lib/pkgconfig/
|
|
||||||
$(INSTALL_DIR) $(2)/bin
|
|
||||||
for f in libpng{,12}-config; do \
|
|
||||||
$(LN) ../../usr/bin/$$$$f $(2)/bin/ ; \
|
|
||||||
done
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libpng/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpng{,12}.so.* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call HostBuild))
|
|
||||||
$(eval $(call BuildPackage,libpng))
|
|
@ -1,10 +0,0 @@
|
|||||||
--- a/scripts/libpng-config-body.in
|
|
||||||
+++ b/scripts/libpng-config-body.in
|
|
||||||
@@ -83,6 +83,7 @@ while test $# -gt 0; do
|
|
||||||
|
|
||||||
--static)
|
|
||||||
R_opts=""
|
|
||||||
+ libs=${all_libs}
|
|
||||||
;;
|
|
||||||
|
|
||||||
*)
|
|
Loading…
x
Reference in New Issue
Block a user