[patch-team] update wing to 20110329 - Signed off by Roberto Riggio <roberto.riggio@create-net.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29373 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0fda4e9a14
commit
e0e6ce7dd7
@ -8,9 +8,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=wing
|
PKG_NAME:=wing
|
||||||
PKG_VERSION:=20110709
|
PKG_VERSION:=20111103
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_REV:=6aaea18b8e199781dc600681882cb2648f43ec38
|
PKG_REV:=23e6455a1cfe0877334f0d18068a3fb47425b8a4
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=git://github.com/rriggio/click.git
|
PKG_SOURCE_URL:=git://github.com/rriggio/click.git
|
||||||
@ -24,9 +24,10 @@ include $(INCLUDE_DIR)/package.mk
|
|||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
define Package/wing
|
define Package/wing
|
||||||
TITLE:=Wireless mesh networking toolkit
|
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
|
SUBMENU:=Routing and Redirection
|
||||||
|
TITLE:=Wireless mesh networking toolkit
|
||||||
MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
|
MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
|
||||||
DEPENDS:=+kmod-tun +libpcap +libstdcpp
|
DEPENDS:=+kmod-tun +libpcap +libstdcpp
|
||||||
URL:=http://www.wing-project.org/
|
URL:=http://www.wing-project.org/
|
||||||
@ -44,12 +45,16 @@ CONFIGURE_ARGS += \
|
|||||||
--enable-tools=host \
|
--enable-tools=host \
|
||||||
--enable-userlevel \
|
--enable-userlevel \
|
||||||
--enable-wifi \
|
--enable-wifi \
|
||||||
|
--enable-wing \
|
||||||
|
--enable-diffserv \
|
||||||
--disable-linuxmodule \
|
--disable-linuxmodule \
|
||||||
--disable-dynamic-linking \
|
--disable-dynamic-linking \
|
||||||
|
|
||||||
HOST_CONFIGURE_ARGS += \
|
HOST_CONFIGURE_ARGS += \
|
||||||
--enable-userlevel \
|
--enable-userlevel \
|
||||||
--enable-wifi \
|
--enable-wifi \
|
||||||
|
--enable-wing \
|
||||||
|
--enable-diffserv \
|
||||||
--disable-linuxmodule \
|
--disable-linuxmodule \
|
||||||
|
|
||||||
define Host/Compile
|
define Host/Compile
|
||||||
@ -62,6 +67,7 @@ define Build/Compile
|
|||||||
-f $(PKG_BUILD_DIR)/conf/wing/sample.click \
|
-f $(PKG_BUILD_DIR)/conf/wing/sample.click \
|
||||||
-A --all -E Discard -E Print -E PrintWifi -E Strip -E Null \
|
-A --all -E Discard -E Print -E PrintWifi -E Strip -E Null \
|
||||||
-E InfiniteSource -E RatedSource -E EtherEncap -E UDPIPEncap \
|
-E InfiniteSource -E RatedSource -E EtherEncap -E UDPIPEncap \
|
||||||
|
-E AggregateWingPacketType -E AggregateCounter \
|
||||||
-E RadiotapEncapHT -E SetTXRateHT \
|
-E RadiotapEncapHT -E SetTXRateHT \
|
||||||
-E WINGETTMetric -E WINGETXMetric -E WINGHopCountMetric \
|
-E WINGETTMetric -E WINGETXMetric -E WINGHopCountMetric \
|
||||||
-E ProbeTXRate -E MadwifiRate -E AutoRateFallback -E Minstrel \
|
-E ProbeTXRate -E MadwifiRate -E AutoRateFallback -E Minstrel \
|
||||||
|
@ -1,13 +1,6 @@
|
|||||||
uci delete network.mesh
|
uci delete network.mesh
|
||||||
uci set network.mesh=interface
|
uci set network.mesh=interface
|
||||||
uci set network.mesh.proto=wing
|
uci set network.mesh.proto=wing
|
||||||
uci set network.mesh.rc=minstrel
|
|
||||||
uci set network.mesh.ls=fcfs
|
|
||||||
uci set network.mesh.metric=wcett
|
|
||||||
uci set network.mesh.prefix=6
|
|
||||||
uci set network.mesh.period=10000
|
|
||||||
uci set network.mesh.tau=100000
|
|
||||||
uci set network.mesh.debug=false
|
|
||||||
|
|
||||||
uci add firewall zone
|
uci add firewall zone
|
||||||
uci set firewall.@zone[-1].name="mesh"
|
uci set firewall.@zone[-1].name="mesh"
|
||||||
|
@ -107,7 +107,9 @@ setup_interface_wing() {
|
|||||||
ps | grep /usr/bin/click | grep -v grep | awk '{print $1}' > /var/run/$iface.pid
|
ps | grep /usr/bin/click | grep -v grep | awk '{print $1}' > /var/run/$iface.pid
|
||||||
|
|
||||||
ifconfig "$iface" "$ipaddr" netmask "$netmask"
|
ifconfig "$iface" "$ipaddr" netmask "$netmask"
|
||||||
route add default dev "$iface"
|
route -n | grep -q '^0.0.0.0' || {
|
||||||
|
route add default dev "$iface"
|
||||||
|
}
|
||||||
|
|
||||||
uci_set_state network $config ifname "$iface"
|
uci_set_state network $config ifname "$iface"
|
||||||
uci_set_state network $config ipaddr "$ipaddr"
|
uci_set_state network $config ipaddr "$ipaddr"
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- a/lib/radiotap.c
|
|
||||||
+++ b/lib/radiotap.c
|
|
||||||
@@ -16,6 +16,17 @@
|
|
||||||
#include <click/radiotap_iter.h>
|
|
||||||
#include <click/platform.h>
|
|
||||||
|
|
||||||
+#if !defined(le32toh) || !defined(le16toh)
|
|
||||||
+# if BYTE_ORDER == LITTLE_ENDIAN
|
|
||||||
+# define le32toh(x) (x)
|
|
||||||
+# define le16toh(x) (x)
|
|
||||||
+# else
|
|
||||||
+# include <byteswap.h>
|
|
||||||
+# define le32toh(x) bswap_32(x)
|
|
||||||
+# define le16toh(x) bswap_16(x)
|
|
||||||
+# endif
|
|
||||||
+#endif
|
|
||||||
+
|
|
||||||
/* function prototypes and related defs are in radiotap_iter.h */
|
|
||||||
|
|
||||||
static const struct radiotap_align_size rtap_namespace_sizes[] = {
|
|
Loading…
x
Reference in New Issue
Block a user