Add icmptx IP over ICMP tunneling program
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6159 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
955d22bcec
commit
e24cef5287
43
net/icmptx/Makefile
Normal file
43
net/icmptx/Makefile
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=icmptx
|
||||||
|
PKG_VERSION:=0.01
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://thomer.com/icmptx/
|
||||||
|
PKG_MD5SUM:=f83d1d7789a1b100abcc00d1a56ee95d
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/icmptx
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
TITLE:=allows you to pass IP packets via DNS queries
|
||||||
|
URL:=http://thomer.com/icmptx/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) CC="$(TARGET_CC)"
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/icmptx/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/icmptx $(1)/usr/sbin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,icmptx))
|
24
net/icmptx/patches/01-cross_compile.patch
Normal file
24
net/icmptx/patches/01-cross_compile.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -urN icmptx-0.01/Makefile icmptx-0.01.new/Makefile
|
||||||
|
--- icmptx-0.01/Makefile 2005-12-20 09:09:34.000000000 +0100
|
||||||
|
+++ icmptx-0.01.new/Makefile 2007-01-21 16:48:36.000000000 +0100
|
||||||
|
@@ -3,16 +3,16 @@
|
||||||
|
all: icmptx
|
||||||
|
|
||||||
|
icmptx: it.o icmptx.o tun_dev.o
|
||||||
|
- gcc $(flags) -o icmptx icmptx.o it.o tun_dev.o
|
||||||
|
+ $(CC) -o icmptx icmptx.o it.o tun_dev.o
|
||||||
|
|
||||||
|
it.o: it.c
|
||||||
|
- gcc $(flags) -c it.c
|
||||||
|
+ $(CC) -c it.c
|
||||||
|
|
||||||
|
icmptx.o: icmptx.c
|
||||||
|
- gcc $(flags) -c icmptx.c
|
||||||
|
+ $(CC) -c icmptx.c
|
||||||
|
|
||||||
|
tun_dev.o: tun_dev.c
|
||||||
|
- gcc $(flags) -c tun_dev.c
|
||||||
|
+ $(CC) -c tun_dev.c
|
||||||
|
|
||||||
|
clean:
|
||||||
|
rm -f tun_dev.o it.o icmptx.o icmptx
|
Loading…
x
Reference in New Issue
Block a user