net/freeswitch: Updated to 1.0.6 (which allowed to eliminate patches), fixed network failure on startup, fixed OOM on exit, and moved logging of fs console output to file (on /tmp) instead of to syslog

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20836 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cshore 2010-04-13 10:23:46 +00:00
parent f7b39a13eb
commit e41ad3e30c
11 changed files with 163 additions and 475 deletions

View File

@ -1,5 +1,4 @@
#
# Copyright (C) 2009 OpenWrt.org
# (C) 2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=freeswitch
PKG_VERSION:=1.0.4
PKG_VERSION:=1.0.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://files.freeswitch.org/
PKG_MD5SUM:=86e34bdd8cc027d71772cb0dc51388da
PKG_MD5SUM:=388effee587887a81fe7f411b7350590
PKG_FIXUP:=libtool
@ -21,9 +21,11 @@ FS_MOD_AVAILABLE:= \
alsa \
amr \
amrwb \
bv \
cdr-csv \
celt \
cepstral \
cidlookup \
cluechoo \
commands \
conference \
@ -34,6 +36,8 @@ FS_MOD_AVAILABLE:= \
dialplan-directory \
dialplan-xml \
dingaling \
directory \
distributor \
dptools \
easyroute \
enum \
@ -50,6 +54,7 @@ FS_MOD_AVAILABLE:= \
g723-1 \
g729 \
h26x \
h323 \
iax \
ilbc \
lcr \
@ -59,6 +64,7 @@ FS_MOD_AVAILABLE:= \
logfile \
loopback \
lua \
managed \
memcache \
native-file \
nibblebill \
@ -67,6 +73,7 @@ FS_MOD_AVAILABLE:= \
perl \
pocketsphinx \
portaudio \
portaudio-stream \
python \
radius-cdr \
rss \
@ -77,10 +84,17 @@ FS_MOD_AVAILABLE:= \
say-it \
say-nl \
say-ru \
say-th \
say-zh \
shell-stream \
shout \
silk \
siren \
skypiax \
skinny \
skypopen \
sangoma-codec \
snapshot \
snipe-hunt \
sndfile \
snom \
sofia \
@ -93,9 +107,11 @@ FS_MOD_AVAILABLE:= \
spidermonkey-socket \
spidermonkey-teletone \
spy \
stress \
syslog \
tone-stream \
unimrcp \
valet-parking \
vmd \
voicemail \
voipcodecs \
@ -120,7 +136,7 @@ endef
define Package/freeswitch
$(call Package/freeswitch/Default)
TITLE:=FreeSWITCH open source telephony platform
DEPENDS:=+libopenssl +libreadline +libncurses +libpthread +libstdcpp
DEPENDS:= +libopenssl +libreadline +libncurses +libpthread +libstdcpp
MENU:=1
endef
@ -131,10 +147,11 @@ define Package/freeswitch/description
endef
define Package/freeswitch-default
$(call Package/freeswitch/Default)
TITLE:=FreeSWITCH default config
DEPENDS:=freeswitch \
DEPENDS:= freeswitch \
+freeswitch-mod-commands \
+freeswitch-mod-conference \
+freeswitch-mod-console \
@ -160,7 +177,7 @@ endef
define Package/freeswitch-minimal
$(call Package/freeswitch/Default)
TITLE:=FreeSWITCH minimal config
DEPENDS:=freeswitch \
DEPENDS:= freeswitch \
+freeswitch-mod-commands \
+freeswitch-mod-console \
+freeswitch-mod-curl \
@ -176,21 +193,21 @@ endef
define Package/freeswitch-sounds-en
$(call Package/freeswitch/Default)
TITLE:=FreeSWITCH english sounds
DEPENDS:=freeswitch
DEPENDS:= freeswitch
endef
define Package/freeswitch-sounds-moh
$(call Package/freeswitch/Default)
TITLE:=FreeSWITCH music-on-hold sounds
DEPENDS:=freeswitch
DEPENDS:= freeswitch
endef
define Package/freeswitch-tools
$(call Package/freeswitch/Default)
TITLE:=FreeSWITCH control tools
DEPENDS:=freeswitch
DEPENDS:= freeswitch
endef
@ -217,7 +234,7 @@ ifneq ($(CONFIG_PACKAGE_freeswitch-mod-curl),)
endif
ifneq ($(CONFIG_PACKAGE_freeswitch-mod-flite),)
$(eval $(call Download/files,flite,flite-1.3.99-latest.tar.gz,,downloads/libs/,libs/))
$(eval $(call Download/files,flite,flite-1.3.99.tar.gz,,downloads/libs/,libs/))
endif
ifneq ($(CONFIG_PACKAGE_freeswitch-sounds-en),)
@ -230,6 +247,15 @@ ifneq ($(CONFIG_PACKAGE_freeswitch-sounds-moh),)
MAKE_INSTALL_TARGETS+= moh-install
endif
FS_TARGET_CFLAGS = ${TARGET_CFLAGS} -DLUA_USE_LINUX $(FPIC) -std=gnu99
FS_TARGET_CXXFLAGS = ${TARGET_CXXFLAGS} -DLUA_USE_LINUX $(FPIC)
FS_TARGET_CPPFLAGS = -I. -I./lua ${TARGET_CPPFLAGS}
ifneq ($(CONFIG_USE_EGLIBC),)
ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
TARGET_CFLAGS += -DNO_GETLOGIN
endif
endif
CONFIGURE_ARGS+= \
--prefix="/usr/freeswitch" \
@ -244,24 +270,29 @@ CONFIGURE_ARGS+= \
--with-random="/dev/urandom" \
--without-erlang \
--without-java \
--without-odbc \
--without-mysql \
--without-pgsql \
--without-python \
--disable-zrtp \
CONFIGURE_VARS+= \
config_BUILD_CC="$(HOSTCC)" \
config_BUILD_CFLAGS="$(HOST_CFLAGS)" \
config_TARGET_CC="$(TARGET_CC)" \
config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
config_TARGET_READLINE_INC="$(TARGET_CPPFLAGS)" \
config_TARGET_READLINE_LIBS="$(TARGET_LDFLAGS) -lreadline -lncurses" \
config_TARGET_LIBS="$(TARGET_LDFLAGS) -lpthread" \
CC_FOR_BUILD="$(HOSTCC)" \
CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS) -Wl,-rpath-link=\"$(STAGING_DIR)/usr/lib\"" \
config_TARGET_CC="${TARGET_CC}" \
config_TARGET_CFLAGS="${FS_TARGET_CPPFLAGS} ${FS_TARGET_CFLAGS}" \
config_TARGET_CXX="${TARGET_CXX}" \
config_TARGET_CXXFLAGS="${FS_TARGET_CPPFLAGS} ${FS_TARGET_CXXFLAGS}" \
config_TARGET_CPPFLAGS="${FS_TARGET_CPPFLAGS}" \
config_BUILD_CC="${HOSTCC}" \
config_TARGET_READLINE_INC="${FS_TARGET_CPPFLAGS}" \
config_TARGET_READLINE_LIBS="${TARGET_LDFLAGS} -lreadline -lncurses" \
config_TARGET_LIBS="${TARGET_LDFLAGS} -lpthread" \
CC_FOR_BUILD="${HOSTCC}" \
LDFLAGS_FOR_BUILD="${HOST_LDFLAGS}" \
CC="${TARGET_CC}" \
CXX="${TARGET_CXX}" \
CFLAGS="${FS_TARGET_CPPFLAGS} ${FS_TARGET_CFLAGS}" \
CXXFLAGS="${FS_TARGET_CPPFLAGS} ${FS_TARGET_CXXFLAGS}" \
CPPFLAGS="${FS_TARGET_CPPFLAGS}" \
LDFLAGS="${TARGET_LDFLAGS} -Wl,-rpath-link=\"${STAGING_DIR}/usr/lib\"" \
ac_cv_dev_urandom="yes" \
ac_cv_file_dbd_apr_dbd_mysql_c="no" \
ac_cv_file__dev_random="no" \
@ -270,12 +301,14 @@ CONFIGURE_VARS+= \
ac_cv_func_mmap_fixed_mapped="yes" \
ac_cv_func_pthread_rwlock_init="yes" \
ac_cv_struct_rlimit="yes" \
ac_cv_func_setpgrp_void="yes" \
apr_cv_mutex_recursive="yes" \
apr_cv_process_shared_works="no" \
apr_cv_tcp_nodelay_with_cork="yes" \
apr_cv_type_rwlock_t="yes" \
ac_cv_path_LIBGNUTLS_CONFIG="no" \
define Build/Prepare
$(call Build/Prepare/Default)
$(call Prepare/celt)
@ -286,7 +319,6 @@ $(call Build/Prepare/Default)
endef
define Build/Configure
( cd $(PKG_BUILD_DIR); ./rebootstrap.sh; )
$(call Build/Configure/Default)
$(foreach m,$(FS_MOD_AVAILABLE),
$(if $(CONFIG_PACKAGE_freeswitch-mod-$(m)),
@ -321,6 +353,10 @@ define Package/freeswitch/install
$(INSTALL_DATA) ./files/freeswitch.default $(1)/etc/default/freeswitch
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/freeswitch.init $(1)/etc/init.d/freeswitch
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/freeswitch.hotplug $(1)/etc/hotplug.d/iface/90-freeswitch
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/freeswitch.config $(1)/etc/config/freeswitch
endef
define Package/freeswitch-default/install
@ -356,8 +392,8 @@ endef
define BuildPlugin
define Package/freeswitch-mod-$(1)
$$(call Package/freeswitch/Default)
TITLE:= FS $(2) module
DEPENDS:=freeswitch $$(foreach m,$(4),+freeswitch-mod-$$m) $(5)
TITLE:= FS $(2) module (snapshot)
DEPENDS:= freeswitch $$(foreach m,$(4),+freeswitch-mod-$$m) $(5)
endef
define Package/freeswitch-mod-$(1)/install
@ -383,19 +419,23 @@ $(eval $(call BuildPackage,freeswitch-tools))
$(eval $(call BuildPlugin,alsa,Alsa endpoint,mod_alsa,,+alsa-lib))
$(eval $(call BuildPlugin,amr,GSM-AMR codec,mod_amr,,))
$(eval $(call BuildPlugin,amrwb,GSM-AMRWB,mod_amrwb,,))
$(eval $(call BuildPlugin,bv,codec mod_bv,mod_bv,,))
$(eval $(call BuildPlugin,cdr-csv,CSV-CDR handler,mod_cdr_csv,,))
$(eval $(call BuildPlugin,celt,CELT ultra-low delay codec,mod_celt,,))
$(eval $(call BuildPlugin,celt,CELT ultra-low delay codec,mod_celt,,+libogg))
$(eval $(call BuildPlugin,cepstral,Cepstral interface,mod_cepstral,,@BROKEN)) # needs <swift.h>
$(eval $(call BuildPlugin,cidlookup,applications mod_cidlookup,mod_cidlookup,,))
$(eval $(call BuildPlugin,cluechoo,Framework Demo,mod_cluechoo,,))
$(eval $(call BuildPlugin,commands,API commands,mod_commands,,))
$(eval $(call BuildPlugin,conference,Conference room,mod_conference,,))
$(eval $(call BuildPlugin,console,Console logger,mod_console,,))
$(eval $(call BuildPlugin,curl,HTTP request,mod_curl,,))
$(eval $(call BuildPlugin,curl,HTTP request,mod_curl,,+libcurl))
$(eval $(call BuildPlugin,dahdi-codec,DAHDI codecs,mod_dahdi_codec,,))
$(eval $(call BuildPlugin,dialplan-asterisk,Asterisk dialplan parser,mod_dialplan_asterisk,,))
$(eval $(call BuildPlugin,dialplan-directory,Dialplan-Directory interface,mod_dialplan_directory,,))
$(eval $(call BuildPlugin,dialplan-xml,Dialplan-XML interface,mod_dialplan_xml,,))
$(eval $(call BuildPlugin,dingaling,Jabber interface,mod_dingaling,,))
$(eval $(call BuildPlugin,dingaling,Jabber interface,mod_dingaling,,+libgnutls-openssl))
$(eval $(call BuildPlugin,directory,application mod_directory,mod_directory,,))
$(eval $(call BuildPlugin,distributor,application mod_distributor,mod_distributor,,))
$(eval $(call BuildPlugin,dptools,Dialplan tools,mod_dptools,,))
$(eval $(call BuildPlugin,easyroute,DID routing,mod_easyroute,,))
$(eval $(call BuildPlugin,enum,ENUM routing,mod_enum,,))
@ -404,7 +444,7 @@ $(eval $(call BuildPlugin,esf,Extra SIP Functionality,mod_esf,,))
$(eval $(call BuildPlugin,event-multicast,Multicast event handler,mod_event_multicast,,))
$(eval $(call BuildPlugin,event-socket,Socket event handler,mod_event_socket,,))
$(eval $(call BuildPlugin,expr,Expression evaluation,mod_expr,,))
$(eval $(call BuildPlugin,fax,Fax,mod_fax,,@BROKEN)) # fails in spandsp
$(eval $(call BuildPlugin,fax,Fax,mod_fax,,@BROKEN +libjpeg)) # fails in spandsp
$(eval $(call BuildPlugin,fifo,FIFO,mod_fifo,,))
$(eval $(call BuildPlugin,file-string,File streaming,mod_file_string,,))
$(eval $(call BuildPlugin,flite,Festival TTS,mod_flite,,))
@ -412,7 +452,9 @@ $(eval $(call BuildPlugin,fsv,Video,mod_fsv,,))
$(eval $(call BuildPlugin,g723-1,G.723.1 codec,mod_g723_1,,))
$(eval $(call BuildPlugin,g729,G.729 codec,mod_g729,,))
$(eval $(call BuildPlugin,h26x,H26X linear codec,mod_h26x,,))
$(eval $(call BuildPlugin,h323,h323 endpoint,mod_h323,,@BROKEN)) # missing header files (other packages needed)
$(eval $(call BuildPlugin,iax,IAX2 interface,mod_iax,,))
$(eval $(call BuildPlugin,java,Java language interface,mod_java,,@BROKEN)) # needs java
$(eval $(call BuildPlugin,ilbc,ILBC codec,mod_ilbc,,))
$(eval $(call BuildPlugin,lcr,Least Cost Routing,mod_lcr,,))
$(eval $(call BuildPlugin,ldap,LDAP interface,mod_ldap,,@BROKEN)) # fails in openldap
@ -420,7 +462,8 @@ $(eval $(call BuildPlugin,limit,Resource limitation,mod_limit,,))
$(eval $(call BuildPlugin,local-stream,Local streaming,mod_local_stream,,))
$(eval $(call BuildPlugin,logfile,File logger,mod_logfile,,))
$(eval $(call BuildPlugin,loopback,Loopback endpoint,mod_loopback,,))
$(eval $(call BuildPlugin,lua,Lua language interface,mod_lua,,+libstdcpp)) # needs C++
$(eval $(call BuildPlugin,lua,Lua language interface,mod_lua,,+libstdcpp))
$(eval $(call BuildPlugin,managed,language mod_managed,mod_managed,,@BROKEN)) # needs Mono
$(eval $(call BuildPlugin,memcache,MemCached interface,mod_memcache,,@BROKEN)) # fails in libmemcached
$(eval $(call BuildPlugin,native-file,Native files,mod_native_file,,))
$(eval $(call BuildPlugin,nibblebill,Billing,mod_nibblebill,,))
@ -429,6 +472,7 @@ $(eval $(call BuildPlugin,openzap,Zaptel hardware interface,mod_openzap ozmod_an
$(eval $(call BuildPlugin,perl,Perl language interface,mod_perl,,+perl @BROKEN)) # needs Perl
$(eval $(call BuildPlugin,pocketsphinx,PocketSphinx SR,mod_pocketsphinx,,@BROKEN)) # fails in sphinxbase
$(eval $(call BuildPlugin,portaudio,Local audio endpoint,mod_portaudio,,+alsa-lib))
$(eval $(call BuildPlugin,portaudio-stream,format mod_portaudio_stream,mod_portaudio_stream,,))
$(eval $(call BuildPlugin,python,Python language interface,mod_python,,+python @BROKEN)) # needs Python
$(eval $(call BuildPlugin,radius-cdr,Radius-CDR interface,mod_radius_cdr,,@BROKEN)) # fails in freeradius-client
$(eval $(call BuildPlugin,rss,RRS feeds via TTS,mod_rss,,))
@ -439,10 +483,17 @@ $(eval $(call BuildPlugin,say-fr,French say,mod_say_fr,,))
$(eval $(call BuildPlugin,say-it,Italian say,mod_say_it,,))
$(eval $(call BuildPlugin,say-nl,Dutch say,mod_say_nl,,))
$(eval $(call BuildPlugin,say-ru,Russian say,mod_say_ru,,))
$(eval $(call BuildPlugin,say-th,mod_th say,mod_say_th,,))
$(eval $(call BuildPlugin,say-zh,Chineese say,mod_say_zh,,))
$(eval $(call BuildPlugin,shell-stream,,mod_shell_stream,,))
$(eval $(call BuildPlugin,shout,MP3 and Shoutcast stream,mod_shout,,@BROKEN)) # needs Ogg/Vorbis
$(eval $(call BuildPlugin,siren,G.722.1 codec,mod_siren,,@BROKEN)) # fails in libg722_1
$(eval $(call BuildPlugin,skypiax,Skype compatible endpoint,mod_skypiax,,@BROKEN)) # needs <X11/Xlib.h>
$(eval $(call BuildPlugin,silk,codec mod_silk,mod_silk,,))
$(eval $(call BuildPlugin,siren,G.722.1 codec,mod_siren,,@BROKEN)) # fails in libg722_1 - attempts to execute cross-compiled binary on host
$(eval $(call BuildPlugin,skinny,endpoint mod_skinny,mod_skinny,,))
$(eval $(call BuildPlugin,skypopen,Skype compatible endpoint,mod_skypopen,,@BROKEN)) # needs <X11/Xlib.h>
$(eval $(call BuildPlugin,sangoma-codec,codec sangoma-codec,mod_sangoma_codec,,@BROKEN)) # Untested
$(eval $(call BuildPlugin,snapshot,application mod_snapshot,mod_snapshot,,))
$(eval $(call BuildPlugin,snipe-hunt,application mod_snipe_hunt,mod_snipe_hunt,,))
$(eval $(call BuildPlugin,sndfile,Multi-Format file transcoder,mod_sndfile,,))
$(eval $(call BuildPlugin,snom,SNOM specific features,mod_snom,,))
$(eval $(call BuildPlugin,sofia,SIP,mod_sofia,,))
@ -455,9 +506,11 @@ $(eval $(call BuildPlugin,spidermonkey-odbc,JavaScript ODBC,mod_spidermonkey_odb
$(eval $(call BuildPlugin,spidermonkey-socket,JavaScript socket,mod_spidermonkey_socket,,@BROKEN))
$(eval $(call BuildPlugin,spidermonkey-teletone,JavaScript teletone,mod_spidermonkey_teletone,,@BROKEN))
$(eval $(call BuildPlugin,spy,User spy,mod_spy,,))
$(eval $(call BuildPlugin,stress,application mod_stress,mod_stress,,))
$(eval $(call BuildPlugin,syslog,SysLog logger,mod_syslog,,))
$(eval $(call BuildPlugin,tone-stream,Tone generation stream,mod_tone_stream,,))
$(eval $(call BuildPlugin,unimrcp,MRCP interface,mod_unimrcp,,))
$(eval $(call BuildPlugin,valet-parking,application mod_valet_parking,mod_valet_parking,,))
$(eval $(call BuildPlugin,vmd,VoiceMail beep detection,mod_vmd,,))
$(eval $(call BuildPlugin,voicemail,VoiceMail,mod_voicemail,,))
$(eval $(call BuildPlugin,voipcodecs,VoIP codecs,mod_voipcodecs,,))
@ -466,3 +519,4 @@ $(eval $(call BuildPlugin,xml-curl,XML-Curl gateway,mod_xml_curl,,+libcurl))
$(eval $(call BuildPlugin,xml-ldap,LDAP-XML gateway,mod_xml_ldap,,@BROKEN)) # fails in openldap
$(eval $(call BuildPlugin,xml-rpc,XML-RPC interface,mod_xml_rpc,,))
$(eval $(call BuildPlugin,yaml,YAML dialplans,mod_yaml,,))

View File

@ -0,0 +1,4 @@
config 'global' 'state'
option 'started' '0'

View File

@ -0,0 +1,65 @@
#!/bin/sh
. /etc/functions.sh
LOAD_STATE=1
if [ "$ACTION" = "ifup" ]; then
/etc/init.d/freeswitch enabled && {
local not_all_up="$(sh -c '
. /etc/functions.sh
LOAD_STATE=1
local if_is_down=0
local network_ignore=""
check_if_down () {
local cfg="$1"
local up
local proto
config_get_bool up "$1" up 0
config_get proto "$1" proto
if [ "$proto" != "none" ] && [ "$up" -ne 1 ]; then
local new_down=1
local oIFS="$IFS"
local ignore
IFS=" "
for ignore in $network_ignore; do
[ "$cfg" = "$ignore" ] && new_down=0
done
IFS="$oIFS"
[ "$new_down" = "1" ] && if_is_down=1
fi
}
append_ignore() {
local cfg="$1"
local network
config_get network "$1" network
append network_ignore "$network"
}
LOAD_STATE=1
config_load freeswitch
config_foreach append_ignore network_ignore
config_load network
config_foreach check_if_down interface
echo "$if_is_down"
')"
[ "$not_all_up" = "0" ] && {
local started
{
mkdir -p /tmp/freeswitch
lock /tmp/freeswitch/.start.lck
config_load freeswitch
config_get started "state" started
[ "$started" != "1" ] && {
/etc/init.d/freeswitch start
uci_set_state freeswitch global state started 1
}
lock -u /tmp/freeswitch/.start.lck
} &
}
}
fi

View File

@ -5,11 +5,16 @@ START=90
DEFAULT=/etc/default/freeswitch
OPTIONS=""
boot() {
# Do nothing on boot
exit 0
}
start() {
[ -f $DEFAULT ] && . $DEFAULT
mkdir -p $FS_DIR_DB
mkdir -p $FS_DIR_LOG
$FS_DIR/usr/bin/freeswitch $OPTIONS -c
{ $FS_DIR/usr/bin/freeswitch $OPTIONS -c >$FS_DIR_LOG/console.log ; } &
}
stop() {

View File

@ -1,15 +0,0 @@
--- a/src/mod/endpoints/mod_sofia/sofia.c
+++ b/src/mod/endpoints/mod_sofia/sofia.c
@@ -1066,11 +1066,7 @@ void launch_sofia_profile_thread(sofia_p
static void logger(void *logarg, char const *fmt, va_list ap)
{
- if (fmt && ap) {
- switch_log_vprintf(SWITCH_CHANNEL_LOG_CLEAN, mod_sofia_globals.tracelevel, fmt, ap);
- } else if (fmt && !ap) {
- switch_log_printf(SWITCH_CHANNEL_LOG_CLEAN, mod_sofia_globals.tracelevel, "%s", fmt);
- }
+ switch_log_vprintf(SWITCH_CHANNEL_LOG_CLEAN, mod_sofia_globals.tracelevel, fmt, ap);
}
static su_log_t *sofia_get_logger(const char *name)

View File

@ -1,25 +0,0 @@
--- a/build/config/odbc.m4
+++ b/build/config/odbc.m4
@@ -112,12 +112,13 @@ AC_ARG_WITH(odbc-include,
fi])
if test "X$with_odbc" != "X"; then
- if test "$with_odbc" != "yes"; then
- ac_cv_odbc_where_lib=$with_odbc
+ if test "$with_odbc" != "yes" -o "$with_odbc" != "no"; then
+ ac_cv_odbc_where_lib=$with_odbc/lib
ac_cv_odbc_where_inc=$with_odbc/include
fi
fi
+ if test "$with_odbc" != "no"; then
if test "X$with_odbc_include" != "X"; then
ac_cv_odbc_where_inc=$with_odbc_include
fi
@@ -159,5 +160,6 @@ AC_ARG_WITH(odbc-include,
AC_SUBST(ODBC_LIB_FLAGS)
AC_DEFINE([HAVE_ODBC],[1],[libodbc])
fi
+ fi ## test "$with_odbc" != "no" ##
])

View File

@ -1,22 +0,0 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -196,7 +196,7 @@ fs_cli_LDFLAGS = $(AM_LDFLAGS) -lpthread
fs_ivrd_CFLAGS = $(AM_CFLAGS) -Ilibs/esl/src/include
fs_ivrd_LDFLAGS = $(AM_LDFLAGS) -lpthread $(ESL_LDFLAGS)
freeswitch_CFLAGS = $(AM_CFLAGS) $(CORE_CFLAGS)
-freeswitch_LDFLAGS = $(AM_LDFLAGS) -rpath $(libdir)
+freeswitch_LDFLAGS = $(AM_LDFLAGS) -lpthread -rpath $(libdir)
freeswitch_LDADD = libfreeswitch.la libs/apr/libapr-1.la
if ADD_LIBEDIT
fs_cli_CFLAGS += -DHAVE_EDITLINE -Ilibs/libedit/src
--- a/Makefile.in
+++ b/Makefile.in
@@ -578,7 +578,7 @@ fs_cli_LDFLAGS = $(AM_LDFLAGS) -lpthread
fs_ivrd_CFLAGS = $(AM_CFLAGS) -Ilibs/esl/src/include
fs_ivrd_LDFLAGS = $(AM_LDFLAGS) -lpthread $(ESL_LDFLAGS)
freeswitch_CFLAGS = $(AM_CFLAGS) $(CORE_CFLAGS) $(am__append_2)
-freeswitch_LDFLAGS = $(AM_LDFLAGS) -rpath $(libdir)
+freeswitch_LDFLAGS = $(AM_LDFLAGS) -lpthread -rpath $(libdir)
freeswitch_LDADD = libfreeswitch.la libs/apr/libapr-1.la \
$(am__append_3)
@ADD_LIBEDIT_TRUE@fs_cli_LDADD = libs/libedit/src/.libs/libedit.a

View File

@ -1,11 +0,0 @@
--- a/build/config/libcurl.m4
+++ b/build/config/libcurl.m4
@@ -71,7 +71,7 @@ AC_DEFUN([LIBCURL_CHECK_CONFIG],
if test -d "$_libcurl_with" ; then
LIBCURL_CPPFLAGS="-I$withval/include"
_libcurl_ldflags="-L$withval/lib"
- AC_PATH_PROG([_libcurl_config],["$withval/bin/curl-config"])
+ _libcurl_config="$withval/bin/curl-config"
else
AC_PATH_PROG([_libcurl_config],[curl-config])
fi

View File

@ -1,22 +0,0 @@
--- a/build/modmake.rules.in
+++ b/build/modmake.rules.in
@@ -38,7 +38,7 @@ SOLINK = @SOLINK@
LDFLAGS=@SWITCH_AM_LDFLAGS@ @LDFLAGS@ $(OUR_LDFLAGS)
-ALL_CFLAGS = $(LOCAL_CFLAGS) $(MOD_CFLAGS) @SWITCH_AM_CFLAGS@ @CFLAGS@ -D_GNU_SOURCE $(OUR_CFLAGS)
+ALL_CFLAGS = $(LOCAL_CFLAGS) $(MOD_CFLAGS) @SWITCH_AM_CFLAGS@ @CFLAGS@ @CPPFLAGS@ -D_GNU_SOURCE $(OUR_CFLAGS)
ALL_CXXFLAGS = $(LOCAL_CFLAGS) $(MOD_CFLAGS) @SWITCH_AM_CXXFLAGS@ @CXXFLAGS@ -D_GNU_SOURCE $(OUR_CFLAGS)
COMPILE = $(CC) $(ALL_CFLAGS) $(DEFS)
--- a/libs/portaudio/Makefile.in
+++ b/libs/portaudio/Makefile.in
@@ -16,7 +16,7 @@ bindir = @bindir@
libdir = @libdir@
includedir = @includedir@
CC = @CC@
-CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src/common -I$(top_srcdir)/src/os/unix @CFLAGS@ @DEFS@
+CFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src/common -I$(top_srcdir)/src/os/unix @CFLAGS@ @CPPFLAGS@ @DEFS@
LIBS = @LIBS@
AR = @AR@
RANLIB = @RANLIB@

View File

@ -1,11 +0,0 @@
--- a/libs/openzap/mod_openzap/Makefile.in
+++ b/libs/openzap/mod_openzap/Makefile.in
@@ -15,7 +15,7 @@ $(OZLA): $(OZ_DIR)/.update
local_install:
cd $(OZ_DIR) && $(MAKE) install
- [ -f $(DESTDIR)$(PREFIX)/conf/autoload_configs/openzap.conf.xml ] || cp -f $(OZ_DIR)/conf/openzap.conf.xml $(DESTDIR)$(PREFIX)/conf/autoload_configs
+ [ -f $(DESTDIR)$(sysconfdir)/autoload_configs/openzap.conf.xml ] || cp -f $(OZ_DIR)/conf/openzap.conf.xml $(DESTDIR)$(sysconfdir)/autoload_configs
local_clean:
cd $(OZ_DIR) && $(MAKE) clean

View File

@ -1,334 +0,0 @@
--- a/build/modmake.rules.in
+++ b/build/modmake.rules.in
@@ -3,6 +3,10 @@
switch_builddir=@switch_builddir@
switch_srcdir=@switch_srcdir@
+build=@build@
+host=@host@
+target=$(host)
+
CC=@CC@
CXX=@CXX@
AWK=@AWK@
@@ -29,13 +33,13 @@ DEFS=@DEFS@
PREFIX = @prefix@
MODINSTDIR = @modinstdir@
-DYLD_LIBRARY_PATH=@libdir@:$DYLD_LIBRARY_PATH
-LD_LIBRARY_PATH=@libdir@:$LD_LIBRARY_PATH
OSARCH=`uname -s`
DYNAMIC_LIB_EXTEN = @DYNAMIC_LIB_EXTEN@
LIBTOOL_LIB_EXTEN = @LIBTOOL_LIB_EXTEN@
SOLINK = @SOLINK@
+CFLAGS=@CFLAGS@
+CPPFLAGS=@CPPFLAGS@
LDFLAGS=@SWITCH_AM_LDFLAGS@ @LDFLAGS@ $(OUR_LDFLAGS)
ALL_CFLAGS = $(LOCAL_CFLAGS) $(MOD_CFLAGS) @SWITCH_AM_CFLAGS@ @CFLAGS@ @CPPFLAGS@ -D_GNU_SOURCE $(OUR_CFLAGS)
--- a/src/mod/applications/mod_curl/Makefile
+++ b/src/mod/applications/mod_curl/Makefile
@@ -11,7 +11,9 @@ LOCAL_LIBADD=$(JSONLA)
include $(BASE)/build/modmake.rules
-DEFAULT_ARGS=--prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
$(LOCAL_OBJS): $(LOCAL_SOURCES)
@@ -19,7 +21,7 @@ $(JSON_DIR):
$(GETLIB) $(json-c).tar.gz
$(JSON_DIR)/Makefile: $(JSON_DIR)
- cd $(JSON_DIR) && CFLAGS=$(AM_CFLAGS) CC=$(CC) CXX=$(CXX) ./configure --disable-shared --with-pic CPPFLAGS= LDFLAGS=
+ cd $(JSON_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(TOUCH_TARGET)
$(JSONLA): $(JSON_DIR)/Makefile
--- a/src/mod/asr_tts/mod_flite/Makefile
+++ b/src/mod/asr_tts/mod_flite/Makefile
@@ -13,15 +13,21 @@ LOCAL_LIBADD=$(FLITE_A)
BASE=../../../..
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS+= --without-audio
+DEFAULT_VARS:= CFLAGS="$(subst -std=c99,,$(CFLAGS))" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(FLITE_DIR):
$(GETLIB) $(FLITE)-latest.tar.gz
$(FLITE_DIR)/Makefile: $(FLITE_DIR)
- cd $(FLITE_DIR) && CFLAGS="`echo $(CFLAGS) | sed -e 's:-std=c99::'`" ./configure --without-audio --with-pic --disable-shared
+ cd $(FLITE_DIR) && cp -fp ../../build/config/config.sub .
+ cd $(FLITE_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(TOUCH_TARGET)
$(FLITE_A): $(FLITE_DIR) $(FLITE_DIR)/Makefile
cd $(FLITE_DIR) && $(MAKE)
test -d $(FLITE_LIBDIR) || mkdir $(FLITE_LIBDIR)
- cd $(FLITE_DIR) && FLITE_TMP_LIBDIR=`$(FLITE_DIR)/config.guess | sed "s/-[^-]*//" | sed "s/i[3456]86/i386/"` && cp build/$$FLITE_TMP_LIBDIR/lib/*.a $(FLITE_LIBDIR)
+ cd $(FLITE_DIR) && cp build/*/lib/*.a $(FLITE_LIBDIR)
--- a/src/mod/directories/mod_ldap/Makefile
+++ b/src/mod/directories/mod_ldap/Makefile
@@ -8,15 +8,18 @@ LIBLBERLA=$(LDAP_DIR)/libraries/liblber/
LOCAL_CFLAGS=-DWITH_OPENLDAP -DLDAP_DEPRECATED -I$(LDAP_DIR)/include
-DEFAULT_ARGS=--prefix=$(PREFIX) --disable-shared --with-pic
-
LOCAL_LIBADD=$(LDAPLA) $(LIBLBERLA)
include $(switch_srcdir)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS+= --disable-bdb --disable-hdb --disable-slapd
+DEFAULT_VARS+= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(LDAP_DIR):
$(GETLIB) $(LDAP).tar.gz
- cd $(LDAP_DIR) && ./configure $(DEFAULT_ARGS) --disable-bdb --disable-hdb --disable-slapd
+ cd $(LDAP_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(LDAPLA) $(LIBLBERLA): $(LDAP_DIR)
cd $(LDAP_DIR) && $(MAKE)
--- a/src/mod/codecs/mod_siren/Makefile
+++ b/src/mod/codecs/mod_siren/Makefile
@@ -5,6 +5,10 @@ G722_1_LA=$(G722_1_DIR)/src/.libs/libg72
LOCAL_LIBADD=$(G722_1_LA)
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(G722_1_LA): $(G722_1_DIR)/.update
- cd $(G722_1_DIR) && ./configure --disable-shared --with-pic && $(MAKE)
+ cd $(G722_1_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS) && $(MAKE)
$(TOUCH_TARGET)
--- a/src/mod/languages/mod_yaml/Makefile
+++ b/src/mod/languages/mod_yaml/Makefile
@@ -7,10 +7,15 @@ VERBOSE=1
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS+= --without-audio
+DEFAULT_VARS+= CFLAGS="$(AM_CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
local_depend: $(LIBYAML_A)
$(LIBYAML_A):
- cd $(YAMLLIB) && ./configure $(DEFAULT_ARGS) --disable-shared --with-pic
+ cd $(YAMLLIB) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
cd $(YAMLLIB) && $(MAKE)
yamlclean:
--- a/src/mod/applications/mod_memcache/Makefile
+++ b/src/mod/applications/mod_memcache/Makefile
@@ -12,7 +12,9 @@ LOCAL_LIBADD=$(MEMCACHEDLA)
include $(switch_srcdir)/build/modmake.rules
-DEFAULT_ARGS=--prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
$(LOCAL_OBJS): $(LOCAL_SOURCES)
@@ -20,7 +22,7 @@ $(MEMCACHED_DIR):
$(GETLIB) $(MEMCACHED).tar.gz
$(MEMCACHED_DIR)/Makefile: $(MEMCACHED_DIR)
- cd $(MEMCACHED_DIR) && CFLAGS=$(AM_CFLAGS) CC=$(CC) CXX=$(CXX) ./configure --disable-shared --with-pic CPPFLAGS= LDFLAGS=
+ cd $(MEMCACHED_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(TOUCH_TARGET)
$(MEMCACHEDLA): $(MEMCACHED_DIR)/Makefile
--- a/src/mod/applications/mod_soundtouch/Makefile
+++ b/src/mod/applications/mod_soundtouch/Makefile
@@ -5,13 +5,16 @@ LA=$(DIRECTORY)/source/SoundTouch/.libs/
BASE=../../../..
LOCAL_CFLAGS += -I$(DIRECTORY)/include -DINTEGER_SAMPLES
LOCAL_LIBADD=$(LA)
-DEFAULT_ARGS=--prefix=$(PREFIX) --disable-shared --with-pic
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(DIRECTORY)/Makefile $(DIRECTORY)/config.status:
$(GETLIB) $(VERSION).tar.gz
- cd $(DIRECTORY) && ./configure $(DEFAULT_ARGS) --enable-integer-samples
+ cd $(DIRECTORY) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS) --enable-integer-samples
$(TOUCH_TARGET)
$(LA): $(DIRECTORY)/Makefile $(DIRECTORY)/config.status
--- a/src/mod/asr_tts/mod_pocketsphinx/Makefile
+++ b/src/mod/asr_tts/mod_pocketsphinx/Makefile
@@ -12,13 +12,19 @@ SPHINXMODEL=communicator_semi_6000_20080
LOCAL_CFLAGS=-I$(SPHINXBASE_DIR)/include -I$(POCKETSPHINX_DIR)/include
LOCAL_LIBADD=$(SPHINXBASE_LA) $(SPHINXBASE_LA2) $(POCKETSPHINX_LA)
BASE=../../../..
+
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS+= --without-python
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(SPHINXBASE_DIR):
$(GETLIB) $(SPHINXBASE)-latest.tar.gz
$(SPHINXBASE_DIR)/buildstamp: $(SPHINXBASE_DIR)
- test -f $(SPHINXBASE_DIR)/Makefile || (cd $(SPHINXBASE_DIR) && ./configure --with-pic --without-python --disable-shared CFLAGS=)
+ test -f $(SPHINXBASE_DIR)/Makefile || (cd $(SPHINXBASE_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS))
test -f $(SPHINXBASE_DIR)/buildstamp || (touch $(SPHINXBASE_DIR)/buildstamp)
$(SPHINXBASE_LA): $(SPHINXBASE_DIR)/buildstamp
@@ -29,7 +35,7 @@ $(POCKETSPHINX_DIR):
$(GETLIB) $(POCKETSPHINX)-latest.tar.gz
$(POCKETSPHINX_DIR)/Makefile: $(POCKETSPHINX_DIR)
- cd $(POCKETSPHINX_DIR) && ./configure --with-pic --without-python --disable-shared --with-sphinxbase=$(SPHINXBASE_DIR) CFLAGS=
+ cd $(POCKETSPHINX_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS) --with-sphinxbase=$(SPHINXBASE_DIR)
$(TOUCH_TARGET)
$(POCKETSPHINX_DIR)/buildstamp: $(POCKETSPHINX_DIR)/Makefile
--- a/src/mod/codecs/mod_celt/Makefile
+++ b/src/mod/codecs/mod_celt/Makefile
@@ -8,11 +8,16 @@ CELT_LA=$(CELT_DIR)/libcelt/.libs/libcel
LOCAL_LIBADD=$(CELT_LA)
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS+= --without-ogg
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(CELT_DIR):
$(GETLIB) $(CELT).tar.gz
$(CELT_DIR)/Makefile: $(CELT_DIR)
- cd $(CELT_DIR) && CFLAGS=$(AM_CFLAGS) ./configure --disable-shared --with-pic
+ cd $(CELT_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(CELT_LA): $(CELT_DIR)/Makefile
cd $(CELT_DIR) && $(MAKE)
--- a/src/mod/event_handlers/mod_radius_cdr/Makefile
+++ b/src/mod/event_handlers/mod_radius_cdr/Makefile
@@ -10,11 +10,15 @@ LOCAL_LIBADD=$(RADCLIENT_LA)
BASE=../../../..
include $(BASE)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(RADCLIENT_DIR):
$(GETLIB) $(RADCLIENT).tar.gz
$(RADCLIENT_DIR)/Makefile: $(RADCLIENT_DIR)
- cd $(RADCLIENT_DIR) && ./configure --disable-shared --with-pic
+ cd $(RADCLIENT_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(TOUCH_TARGET)
$(RADCLIENT_LA): $(RADCLIENT_DIR)/Makefile
--- a/src/mod/event_handlers/mod_zeroconf/Makefile
+++ b/src/mod/event_handlers/mod_zeroconf/Makefile
@@ -7,13 +7,15 @@ HOWLLA=$(HOWL_DIR)/src/lib/howl/libhowl.
LOCAL_CFLAGS=-I$(HOWL_DIR)/include
LOCAL_LIBADD=$(HOWLLA)
-DEFAULT_ARGS=--prefix=$(PREFIX) --disable-shared --with-pic
-
include $(switch_srcdir)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(HOWL_DIR):
$(GETLIB) $(HOWL).tar.gz
- cd $(HOWL_DIR) && ./configure $(DEFAULT_ARGS)
+ cd $(HOWL_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(HOWLLA): $(HOWL_DIR)
cd $(HOWL_DIR) && $(MAKE)
--- a/src/mod/formats/mod_shout/Makefile
+++ b/src/mod/formats/mod_shout/Makefile
@@ -22,7 +22,9 @@ LOCAL_SOURCES=$(MP3SOURCES)
include $(switch_srcdir)/build/modmake.rules
-DEFAULT_ARGS=--prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic
+DEFAULT_VARS:= CFLAGS="$(CFLAGS)" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
$(LOCAL_OBJS): $(LOCAL_SOURCES)
@@ -30,7 +32,7 @@ $(MPG123_DIR):
$(GETLIB) $(MPG123).tar.gz
$(MPG123_DIR)/Makefile: $(MPG123_DIR)
- cd $(MPG123_DIR) && CFLAGS=$(AM_CFLAGS) CC=$(CC) CXX=$(CXX) ./configure --disable-shared --with-pic CPPFLAGS= LDFLAGS=
+ cd $(MPG123_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(TOUCH_TARGET)
$(MPG123LA): $(MPG123_DIR)/Makefile
@@ -41,7 +43,7 @@ $(LAME_DIR):
$(GETLIB) $(LAME).tar.gz
$(LAME_DIR)/Makefile: $(LAME_DIR)
- cd $(LAME_DIR) && CC=$(CC) CXX=$(CXX) ./configure $(DEFAULT_ARGS) --disable-decoder CPPFLAGS= LDFLAGS=
+ cd $(LAME_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS) --disable-decoder
$(TOUCH_TARGET)
$(LAMELA): $(LAME_DIR)/Makefile
@@ -52,7 +54,7 @@ $(SHOUT_DIR):
$(GETLIB) $(SHOUT).tar.gz
$(SHOUT_DIR)/Makefile: $(SHOUT_DIR)
- cd $(SHOUT_DIR) && CC=$(CC) CXX=$(CXX) ./configure $(DEFAULT_ARGS) --without-speex --without-vorbis --without-ogg CPPFLAGS= LDFLAGS=
+ cd $(SHOUT_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS) --without-speex --without-vorbis --without-ogg
$(TOUCH_TARGET)
$(SHOUTLA): $(SHOUT_DIR)/Makefile
--- a/src/mod/xml_int/mod_xml_ldap/Makefile
+++ b/src/mod/xml_int/mod_xml_ldap/Makefile
@@ -9,16 +9,18 @@ LIBLUTILA=$(LDAP_DIR)/libraries/liblutil
LOCAL_CFLAGS=-DWITH_OPENLDAP -DLDAP_DEPRECATED -I$(LDAP_DIR)/include
-DEFAULT_ARGS= --prefix=$(PREFIX) --disable-shared --with-pic --disable-slapd
-DEFAULT_ARGS+= --disable-slurpd --disable-relay --disable-bdb --disable-hdb
-
LOCAL_LIBADD=$(LDAPLA) $(LIBLBERLA) $(LIBLUTILA)
include $(switch_srcdir)/build/modmake.rules
+DEFAULT_ARGS:= --build=$(build) --host=$(host) --target=$(target)
+DEFAULT_ARGS+= --prefix=$(PREFIX) --disable-shared --with-pic --disable-slapd
+DEFAULT_ARGS+= --disable-slurpd --disable-relay --disable-bdb --disable-hdb
+DEFAULT_VARS:= CFLAGS="$(subst -std=c99,,$(CFLAGS))" CPPFLAGS="$(CPPFLAGS)" LDFLAGS="$(LDFLAGS)" CC="$(CC)" CXX="$(CXX)"
+
$(LDAP_DIR):
$(GETLIB) $(LDAP).tar.gz
- cd $(LDAP_DIR) && CFLAGS="`echo $(CFLAGS) | sed -e 's:-std=c99::'`" ./configure $(DEFAULT_ARGS)
+ cd $(LDAP_DIR) && $(DEFAULT_VARS) ./configure $(DEFAULT_ARGS)
$(LIBLUTILA) $(LDAPLA) $(LIBLBERLA): $(LDAP_DIR)
cd $(LDAP_DIR) && $(MAKE)