add zaptel-libtonezone (closes: #1095), thanks to zandbelt
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5936 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7df340fae6
commit
e60625e31a
70
libs/zaptel/Makefile
Normal file
70
libs/zaptel/Makefile
Normal file
@ -0,0 +1,70 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=zaptel
|
||||
PKG_VERSION:=1.2.12
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.digium.com/pub/zaptel/releases/ ftp://ftp.digium.com/pub/zaptel/releases/
|
||||
PKG_MD5SUM:=99b9f86556b903a32607b2751f920513
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/zaptel/Default
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
URL:=http://ftp.digium.com/pub/zaptel/releases
|
||||
endef
|
||||
|
||||
define Package/zaptel-libtonezone
|
||||
$(call Package/zaptel/Default)
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Zaptel tonezone library.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
HOSTCC="$(HOSTCC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I. -DBUILDING_TONEZONE" \
|
||||
KSRC="$(LINUX_DIR)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install-tonezone
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include/linux
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/linux/zaptel.h $(STAGING_DIR)/usr/include/linux/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/tonezone.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtonezone.so* $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf $(STAGING_DIR)/usr/include/linux/zaptel.h
|
||||
rm -rf $(STAGING_DIR)/usr/include/tonezone.h
|
||||
rm -rf $(STAGING_DIR)/usr/lib/libtonezone.so*
|
||||
endef
|
||||
|
||||
define Package/zaptel-libtonezone/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtonezone.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,zaptel-libtonezone))
|
19
libs/zaptel/patches/110-Makefile-tonezone_install.patch
Normal file
19
libs/zaptel/patches/110-Makefile-tonezone_install.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- zaptel-1.2.12.org/Makefile 2006-12-07 00:22:11.000000000 +0100
|
||||
+++ zaptel-1.2.12/Makefile 2006-12-23 00:12:30.000000000 +0100
|
||||
@@ -357,6 +357,16 @@
|
||||
/sbin/update-modules ; \
|
||||
fi
|
||||
|
||||
+install-tonezone: $(LIBTONEZONE_SO)
|
||||
+ install -D -m 755 $(LIBTONEZONE_SO) $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER)
|
||||
+ rm -f $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO)
|
||||
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
|
||||
+ $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER)
|
||||
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
|
||||
+ $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO)
|
||||
+ install -D -m 644 zaptel.h $(INSTALL_PREFIX)/usr/include/linux/zaptel.h
|
||||
+ install -D -m 644 tonezone.h $(INSTALL_PREFIX)/usr/include/tonezone.h
|
||||
+
|
||||
install-udev: devices
|
||||
|
||||
firmware:
|
Loading…
x
Reference in New Issue
Block a user