added argtables, signed off by michu-at-neophobdotcom
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9981 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
dc1e7e2f83
commit
e693c69445
56
sound/scmpc/Makefile
Normal file
56
sound/scmpc/Makefile
Normal file
@ -0,0 +1,56 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id: Makefile 9349 2007-10-18 18:46:37Z blogic $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=scmpc
|
||||||
|
PKG_VERSION:=0.2.2
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://download.berlios.de/scmpc
|
||||||
|
PKG_MD5SUM:=f42482e4dbf398df92a36d5610b403e5
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/scmpc
|
||||||
|
SECTION:=sound
|
||||||
|
CATEGORY:=Sound
|
||||||
|
TITLE:=A MPD client which submits your tracks to Last.Fm
|
||||||
|
DEPENDS:=+curl +libdaemon +argtable +confuse
|
||||||
|
URL:=http://scmpc.berlios.de/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/scmpc/description
|
||||||
|
scmpc is a multithreaded, robust client for MPD to submit tracks to Audioscrobbler (Last.fm).
|
||||||
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
--disable-rpath \
|
||||||
|
--without-libiconv-prefix \
|
||||||
|
--without-libintl-prefix \
|
||||||
|
|
||||||
|
MAKE_FLAGS += \
|
||||||
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
|
$(1) \
|
||||||
|
|
||||||
|
define Package/scmpc/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/src/scmpc $(1)/usr/bin/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(INSTALL_BIN) ./files/scmpc.init $(1)/etc/init.d/scmpc
|
||||||
|
$(INSTALL_DIR) $(1)/etc
|
||||||
|
$(CP) $(PKG_BUILD_DIR)/examples/scmpc.conf $(1)/etc
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,scmpc))
|
12
sound/scmpc/files/scmpc.init
Normal file
12
sound/scmpc/files/scmpc.init
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
#!/bin/sh /etc/rc.common
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
START=94
|
||||||
|
|
||||||
|
start() {
|
||||||
|
mkdir -p /var/lib/scmpc
|
||||||
|
/usr/bin/scmpc
|
||||||
|
}
|
||||||
|
|
||||||
|
stop() {
|
||||||
|
killall scmpc
|
||||||
|
}
|
11
sound/scmpc/patches/100-Rules.patch
Normal file
11
sound/scmpc/patches/100-Rules.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- scmpc-0.2.2/src/Rules.mkorig 2007-10-31 23:32:48.000000000 +0100
|
||||||
|
+++ scmpc-0.2.2/src/Rules.mk 2007-10-31 23:19:00.000000000 +0100
|
||||||
|
@@ -16,7 +16,7 @@
|
||||||
|
-include $(DEPENDS)
|
||||||
|
|
||||||
|
DEFINES := -DHAVE_CONFIG_H -D_GNU_SOURCE
|
||||||
|
-INCLUDES := -I$(src_d) -I$(src_b)
|
||||||
|
+INCLUDES := -I$(src_d) -I$(src_b) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
|
||||||
|
LDLIBS := $(LIBS)
|
||||||
|
|
||||||
|
CLEAN += $(OBJS) $(PROGRAM)
|
Loading…
x
Reference in New Issue
Block a user