Upgrade bind to 9.3.2-P1, no shared libraries because those are broken in the bind package itself, (#853)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5166 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-10-16 20:22:31 +00:00
parent 70afdf4962
commit e6a87a593f
3 changed files with 42 additions and 42 deletions

View File

@ -9,20 +9,17 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bind
PKG_VERSION:=9.3.1
PKG_RELEASE:=7
PKG_BUILDDEP:=openssl
PKG_VERSION:=9.3.2-P1
PKG_RELEASE:=8
PKG_MD5SUM:=a0b86647ef6a2d5f1e759112d08e2229
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/bind9/9.3.1/
PKG_MD5SUM:=9ff3204eea27184ea0722f37e43fc95d
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_BUILDDEP:=libopenssl
include $(INCLUDE_DIR)/package.mk
define Package/bind
@ -92,12 +89,15 @@ define Package/bind-dig
endef
define Package/Build/Configure
$(call Build/Configure/Default,--enable-shared \
--enable-static \
--enable-ipv6 \
--with-randomdev=/dev/urandom \
--disable-threads \
--with-openssl=$(STAGING_DIR)/usr/
$(call Build/Configure/Default,\
--enable-shared \
--enable-static \
--enable-ipv6 \
--with-randomdev=/dev/urandom \
--disable-threads \
--with-openssl=$(STAGING_DIR)/usr/ \
--with-libtool \
--with-gnu-ld \
)
endef

View File

@ -1,7 +1,6 @@
diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
--- bind-9.3.1/configure 2004-12-09 05:09:03.000000000 +0100
+++ bind-9.3.1.new/configure 2006-07-31 14:24:19.000000000 +0200
@@ -4750,7 +4750,7 @@
--- bind-9.3.2-P1/configure 2005-10-21 01:57:38.000000000 +0200
+++ bind-9.3.2-P1.new/configure 2006-10-16 21:43:12.000000000 +0200
@@ -4816,7 +4816,7 @@
use_openssl="auto"
fi;
@ -10,26 +9,28 @@ diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
if test "$use_openssl" = "auto"
then
for d in $openssldirs
@@ -5289,6 +5289,7 @@
if eval "test \"\${$as_ac_File+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
@@ -5357,8 +5357,7 @@
else
+cross_compiling=no
test "$cross_compiling" = yes &&
{ { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
@@ -23675,175 +23676,6 @@
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+echo "$as_me: error: cannot check for file existence when cross compiling" >&2;} }
if test -r "$devrandom"; then
eval "$as_ac_File=yes"
else
@@ -23747,176 +23746,6 @@
# which provides some (all?) of the desired functions.
#
-echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
-echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6
-if test "$cross_compiling" = yes; then
- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
- echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
-echo "${ECHO_T}assuming inet_ntop needed" >&6
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
-else
- cat >conftest.$ac_ext <<_ACEOF
-/* confdefs.h. */
@ -191,13 +192,13 @@ diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
-
-
-
-
#
# Look for a 4.4BSD-style sa_len member in struct sockaddr.
diff -urN bind-9.3.1/configure.in bind-9.3.1.new/configure.in
--- bind-9.3.1/configure.in 2004-12-09 05:07:10.000000000 +0100
+++ bind-9.3.1.new/configure.in 2006-07-31 14:16:55.000000000 +0200
@@ -362,7 +362,7 @@
#
--- bind-9.3.2-P1/configure.in 2005-10-21 01:47:25.000000000 +0200
+++ bind-9.3.2-P1.new/configure.in 2006-10-16 21:36:09.000000000 +0200
@@ -363,7 +363,7 @@
(Required for DNSSEC)],
use_openssl="$withval", use_openssl="auto")
@ -206,10 +207,9 @@ diff -urN bind-9.3.1/configure.in bind-9.3.1.new/configure.in
if test "$use_openssl" = "auto"
then
for d in $openssldirs
diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
--- bind-9.3.1/lib/bind/configure 2004-12-09 05:09:03.000000000 +0100
+++ bind-9.3.1.new/lib/bind/configure 2006-07-31 14:24:19.000000000 +0200
@@ -5289,6 +5289,7 @@
--- bind-9.3.2-P1/lib/bind/configure 2005-10-14 03:44:50.000000000 +0200
+++ bind-9.3.2-P1.new/lib/bind/configure 2006-10-16 21:46:45.000000000 +0200
@@ -4461,6 +4461,7 @@
if eval "test \"\${$as_ac_File+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@ -217,4 +217,3 @@ diff -urN bind-9.3.1/configure bind-9.3.1.new/configure
test "$cross_compiling" = yes &&
{ { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}

View File

@ -1,11 +1,12 @@
--- bind-9.3.1/lib/dns/Makefile.in.old Sun Oct 15 01:27:40 2006
+++ bind-9.3.1/lib/dns/Makefile.in Sun Oct 15 01:28:15 2006
diff -urN bind-9.3.2-P1/lib/dns/Makefile.in bind-9.3.2-P1.new/lib/dns/Makefile.in
--- bind-9.3.2-P1/lib/dns/Makefile.in 2004-12-09 05:07:15.000000000 +0100
+++ bind-9.3.2-P1.new/lib/dns/Makefile.in 2006-10-16 21:38:46.000000000 +0200
@@ -156,7 +156,7 @@
./gen -s ${srcdir} > code.h
gen: gen.c
- ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
+ ${CC} ${ALL_CFLAGS} -o $@ ${srcdir}/gen.c
+ ${CC} ${ALL_CFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
rbtdb64.@O@: rbtdb.c