[Packages] multimedia/gphoto2: Update to 2.4.0

git-svn-id: svn://svn.openwrt.org/openwrt/packages@10527 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2008-02-26 19:24:37 +00:00
parent 869bc7bc1e
commit e766864f15
2 changed files with 22 additions and 31 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2006 OpenWrt.org # Copyright (C) 2006-2008 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -9,15 +9,14 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=gphoto2 PKG_NAME:=gphoto2
PKG_VERSION:=2.2.0 PKG_VERSION:=2.4.0
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/gphoto PKG_SOURCE_URL:=@SF/gphoto
PKG_MD5SUM:=f5c1f83185db598b4ca52889964a5e84 PKG_MD5SUM:=5fd1f711ca806adb687b33c55964d898
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) PKG_FIXUP = libtool
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -30,33 +29,24 @@ define Package/gphoto2
endef endef
define Package/gphoto2/description define Package/gphoto2/description
For downloading and controlling digital cameras For downloading and controlling digital cameras
endef endef
define Build/Configure CONFIGURE_ARGS += \
$(call Build/Configure/Default, \ --without-libiconv-prefix \
--without-libiconv-prefix \ --without-libintl-prefix \
--without-libintl-prefix \
, \
LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
POPT_LIBS="$$$$LDFLAGS -lpopt" \
)
endef
define Build/Compile CONFIGURE_VARS += \
$(MAKE) -C $(PKG_BUILD_DIR) \ LIBGPHOTO2_CFLAGS="$$$$CFLAGS -I$(STAGING_DIR)/usr/include/gphoto2 $$$$CPPFLAGS" \
DESTDIR="$(PKG_INSTALL_DIR)" \ LIBGPHOTO2_LIBS="$$$$LDFLAGS -lgphoto2 -lgphoto2_port -lltdl" \
all install LIBEXIF_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
endef LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
POPT_CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
POPT_LIBS="$$$$LDFLAGS -lpopt" \
define Package/gphoto2/install define Package/gphoto2/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gphoto2 $(1)/usr/bin/ $(INSTALL_BIN) $(PKG_BUILD_DIR)/gphoto2/$(PKG_NAME) $(1)/usr/bin/
endef endef
$(eval $(call BuildPackage,gphoto2)) $(eval $(call BuildPackage,gphoto2))

View File

@ -1,9 +1,10 @@
diff -ru gphoto2-2.2.0/gphoto2/foreach.c gphoto2-2.2.0-patched/gphoto2/foreach.c Index: gphoto2-2.4.0/gphoto2/foreach.c
--- gphoto2-2.2.0/gphoto2/foreach.c 2006-06-15 23:03:47.000000000 -0700 ===================================================================
+++ gphoto2-2.2.0-patched/gphoto2/foreach.c 2007-01-03 00:33:21.000000000 -0800 --- gphoto2-2.4.0.orig/gphoto2/foreach.c 2008-02-26 19:59:37.000000000 +0100
+++ gphoto2-2.4.0/gphoto2/foreach.c 2008-02-26 19:59:38.000000000 +0100
@@ -31,6 +31,8 @@ @@ -31,6 +31,8 @@
#include <gphoto2-port-log.h> #include <gphoto2/gphoto2-port-log.h>
+#define GP_DEBUG (void) +#define GP_DEBUG (void)
+ +