smcroute: moved to routing-feed

git-svn-id: svn://svn.openwrt.org/openwrt/packages@43192 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2014-11-06 06:15:03 +00:00
parent dc5cd91dba
commit e840bf9361
4 changed files with 0 additions and 84 deletions

View File

@ -1,50 +0,0 @@
#
# Copyright (C) 2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=smcroute
PKG_VERSION:=0.92
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://www.cschill.de/smcroute
PKG_MD5SUM:=2b50e7166606ec90e09682399e69c4a6
include $(INCLUDE_DIR)/package.mk
define Package/smcroute
SECTION:=net
CATEGORY:=Network
SUBMENU:=Routing and Redirection
TITLE:=Static multicast routing daemon
URL:=http://www.cschill.de/smcroute/
endef
define Package/smcroute/description
SMCRoute is a command line tool to manipulate the multicast routes of the Linux kernel.
endef
ifeq ($(HOST_OS),FreeBSD)
TARGET_CFLAGS += -fno-builtin-log
TARGET_LDFLAGS += -fno-builtin-log
endif
define Build/Compile
$(MAKE) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" -C $(PKG_BUILD_DIR)/src all
endef
define Package/smcroute/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_DIR) $(1)/etc/init.d/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/smcroute $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mcsender $(1)/usr/bin/
$(INSTALL_BIN) ./files/smcroute.init $(1)/etc/init.d/smcroute
endef
$(eval $(call BuildPackage,smcroute))

View File

@ -1,11 +0,0 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006-2010 OpenWrt.org
START=50
start() {
smcroute -d
}
stop() {
smcroute -k
}

View File

@ -1,11 +0,0 @@
--- a/src/ipc.c 2002-07-07 19:38:49.000000000 +0200
+++ b/src/ipc.c 2010-10-01 21:44:26.000000000 +0200
@@ -24,7 +24,7 @@
#include "mclab.h"
-#define SOCKET_PATH "/var/lib/smcroute"
+#define SOCKET_PATH "/tmp/smcroute"
// server's listen socket
static int ListenSock;

View File

@ -1,12 +0,0 @@
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,9 +1,6 @@
BINDIR=../bin
-# CFLAGS=-g
-CFLAGS=-O
-
default : build.h smcroute
all : smcroute mcsender