[packages] babeld: patch minor bug until next release

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26159 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
kerneis 2011-03-14 13:47:25 +00:00
parent e15130579b
commit e85c881d17
2 changed files with 19 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=babeld
PKG_VERSION:=1.1.0
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/

View File

@ -0,0 +1,18 @@
Sat Mar 5 19:13:54 CET 2011 Gabriel Kerneis <kerneis@pps.jussieu.fr>
* Fix unique id in local_notify_route
diff -rN -u old-babeld/local.c new-babeld/local.c
--- old-babeld/local.c 2011-03-14 14:37:03.000000000 +0100
+++ new-babeld/local.c 2011-03-14 14:37:03.000000000 +0100
@@ -197,11 +197,10 @@
return;
rc = snprintf(buf, 512,
- "%s route %s-%s-%lx prefix %s installed %s "
+ "%s route %s-%lx prefix %s installed %s "
"id %s metric %d refmetric %d via %s if %s\n",
local_kind(kind),
format_prefix(route->src->prefix, route->src->plen),
- format_eui64(route->src->id),
(unsigned long)route->neigh,
format_prefix(route->src->prefix, route->src->plen),
route->installed ? "yes" : "no",