bridge-utils: moved to github
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@46330 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b753983af2
commit
e897dab63f
@ -1,51 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2013 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
|
||||||
|
|
||||||
PKG_NAME:=bridge-utils
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
PKG_SOURCE_URL:=@SF/bridge
|
|
||||||
PKG_VERSION:=1.5
|
|
||||||
PKG_MD5SUM:=ec7b381160b340648dede58c31bb2238
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/bridge
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Base system
|
|
||||||
TITLE:=Ethernet bridging configuration utility
|
|
||||||
URL:=http://bridge.sourceforge.net/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/bridge/description
|
|
||||||
Manage ethernet bridging: a way to connect networks together to
|
|
||||||
form a larger network.
|
|
||||||
endef
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--with-linux-headers="$(LINUX_DIR)" \
|
|
||||||
|
|
||||||
define Build/Prepare
|
|
||||||
$(call Build/Prepare/Default)
|
|
||||||
( cd $(PKG_BUILD_DIR) ; \
|
|
||||||
[ -f ./configure ] || { \
|
|
||||||
ln -sf configure.in configure.ac ; \
|
|
||||||
autoconf ; \
|
|
||||||
} \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/bridge/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,bridge))
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/libbridge/Makefile.in
|
|
||||||
+++ b/libbridge/Makefile.in
|
|
||||||
@@ -5,7 +5,7 @@ AR=ar
|
|
||||||
RANLIB=@RANLIB@
|
|
||||||
|
|
||||||
CC=@CC@
|
|
||||||
-CFLAGS = -Wall -g $(KERNEL_HEADERS)
|
|
||||||
+CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
|
|
||||||
|
|
||||||
prefix=@prefix@
|
|
||||||
exec_prefix=@exec_prefix@
|
|
@ -1,10 +0,0 @@
|
|||||||
--- a/libbridge/libbridge.h
|
|
||||||
+++ b/libbridge/libbridge.h
|
|
||||||
@@ -20,6 +20,7 @@
|
|
||||||
#define _LIBBRIDGE_H
|
|
||||||
|
|
||||||
#include <sys/socket.h>
|
|
||||||
+#include <netinet/in.h>
|
|
||||||
#include <linux/if.h>
|
|
||||||
#include <linux/if_bridge.h>
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user