minidlna: bump version to 1.0.25

Version bump minidlna to 1.0.25 and add an additional patch.
Patch is accepted upstream, but not yet released.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@35658 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2013-02-18 10:04:17 +00:00
parent de79b12ca9
commit e91c46c25c
2 changed files with 14 additions and 3 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2010-2012 OpenWrt.org # Copyright (C) 2010-2013 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=minidlna PKG_NAME:=minidlna
PKG_VERSION:=1.0.24 PKG_VERSION:=1.0.25
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_src.tar.gz PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_src.tar.gz
PKG_SOURCE_URL:=@SF/minidlna PKG_SOURCE_URL:=@SF/minidlna
PKG_MD5SUM:=be9b4c91e3fcde592dc3f9828098ca0f PKG_MD5SUM:=d966256baf2f9b068b9de871ab5dade5
PKG_BUILD_PARALLEL:=0 PKG_BUILD_PARALLEL:=0
PKG_BUILD_DEPENDS:=util-linux PKG_BUILD_DEPENDS:=util-linux

View File

@ -0,0 +1,11 @@
--- a/metadata.c 2012-08-27 23:00:06.997932249 +0100
+++ b/metadata.c 2012-08-27 23:10:07.716582960 +0100
@@ -110,7 +110,7 @@ lav_open(AVFormatContext **ctx, const ch
static inline void
lav_close(AVFormatContext *ctx)
{
-#if LIBAVFORMAT_VERSION_INT >= ((53<<16)+(2<<8)+0)
+#if LIBAVFORMAT_VERSION_INT >= ((53<<16)+(17<<8)+0)
avformat_close_input(&ctx);
#else
av_close_input_file(ctx);