[packages/] remove packages which got moved to the telephony feed

- libs/opal
 - libs/openh323
 - libs/ptlib
 - libs/pwlib

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Signed-off-by: Mirko Vogt <mirko@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37025 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2013-06-24 12:25:43 +00:00
parent 3d627def9b
commit e95b58b0b6
9 changed files with 0 additions and 499 deletions

View File

@ -1,69 +0,0 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=opal
PKG_VERSION:=3.2.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.bz2
PKG_SOURCE_URL:=@SF/opalvoip
PKG_MD5SUM:=405ba3b03ec706b6e6f873de340937e2
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/libopal
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+ptlib +libstdcpp
TITLE:=Open Phone Abstraction Library
URL:=http://www.opalvoip.org/
endef
define Package/libopal/description
Open Phone Abstraction Library, implementation of the ITU H.323
teleconferencing protocol, and successor of the openh323 library. It
supports not only the H.323 protocol but also SIP and IAX2.
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-audio \
--disable-video \
--enable-sip \
--enable-h323 \
--disable-iax \
--disable-h224 \
--disable-h450 \
--disable-h460 \
--disable-ivr \
--disable-rfc4175 \
--disable-versioncheck \
--disable-theora \
--enable-localgsm
CONFIGURE_VARS += \
PTLIBDIR="$(BUILD_DIR)/ptlib" \
PTLIBPLUGINDIR="$(BUILD_DIR)/ptlib/plugins/ptlib/"
CXXFLAGS="$(TARGET_CFLAGS)" \
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)" \
CCFLAGS="$(TARGET_CFLAGS)" \
PTLIBDIR="$(BUILD_DIR)/ptlib" \
PTLIBPLUGINDIR="$(BUILD_DIR)/ptlib/plugins/ptlib/" \
optnoshared
define Build/InstallDev
ln -sf $(PKG_NAME)_$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
endef
$(eval $(call BuildPackage,libopal))

View File

@ -1,25 +0,0 @@
diff --git a/plugins/video/common/trace.cxx b/plugins/video/common/trace.cxx
index 7262478..de641af 100644
--- a/plugins/video/common/trace.cxx
+++ b/plugins/video/common/trace.cxx
@@ -30,6 +30,7 @@
/*****************************************************************************/
#include "trace.h"
+#include <cstring>
#ifdef __MACOSX__
#include <libgen.h>
diff --git a/plugins/video/H.263-ffmpeg/h263ffmpeg.cxx b/plugins/video/H.263-ffmpeg/h263ffmpeg.cxx
index 4a17b2c..a2f051c 100644
--- a/plugins/video/H.263-ffmpeg/h263ffmpeg.cxx
+++ b/plugins/video/H.263-ffmpeg/h263ffmpeg.cxx
@@ -54,6 +54,8 @@
#define _CRT_NONSTDC_NO_WARNINGS
#define _CRT_SECURE_NO_DEPRECATE
#include <codec/opalplugin.h>
+#include <cstdio>
+#include <climits>
#include <stdlib.h>
#ifdef _WIN32

View File

@ -1,49 +0,0 @@
#
# Copyright (C) 2006-2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=openh323
PKG_VERSION:=cvs-20051230
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://trash.uid0.hu/openwrt/
PKG_MD5SUM:=ba1ffd45016f533bec2bb1539b78e43a
PKG_BUILD_DEPENDS:=pwlib
include $(INCLUDE_DIR)/package.mk
define Package/libopenh323
SECTION:=libs
CATEGORY:=Libraries
TITLE:=OpenH323 library
URL:=http://openh323.sourceforge.net/
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-minsize \
--enable-audio \
--disable-video \
--enable-localspeex \
CONFIGURE_VARS += \
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
CCFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
optnoshared
define Build/InstallDev
ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
endef
$(eval $(call BuildPackage,libopenh323))

View File

@ -1,122 +0,0 @@
--- openh323-cvs-20051230.orig/configure 2005-08-30 03:12:38.000000000 +0200
+++ openh323-cvs-20051230/configure 2005-12-30 11:29:57.000000000 +0100
@@ -3080,10 +3080,10 @@
if eval "test \"\${$as_ac_File+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "${PWLIBDIR}/version.h"; then
eval "$as_ac_File=yes"
else
@@ -3104,10 +3104,10 @@
if eval "test \"\${$as_ac_File+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "${OPENH323DIR}/../pwlib/version.h"; then
eval "$as_ac_File=yes"
else
@@ -3129,10 +3129,10 @@
if eval "test \"\${$as_ac_File+set}\" = set"; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "${HOME}/pwlib/include/ptlib.h"; then
eval "$as_ac_File=yes"
else
@@ -3153,10 +3153,10 @@
if test "${ac_cv_file__usr_local_include_ptlib_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "/usr/local/include/ptlib.h"; then
ac_cv_file__usr_local_include_ptlib_h=yes
else
@@ -3215,10 +3215,10 @@
if test "${ac_cv_file__usr_include_ptlib_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "/usr/include/ptlib.h"; then
ac_cv_file__usr_include_ptlib_h=yes
else
@@ -3985,10 +3985,10 @@
if test "${ac_cv_file__usr_local_include_ffmpeg_avcodec_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "/usr/local/include/ffmpeg/avcodec.h"; then
ac_cv_file__usr_local_include_ffmpeg_avcodec_h=yes
else
@@ -4193,10 +4193,10 @@
if test "${ac_cv_file__usr_local_lib_libvich263_so+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "/usr/local/lib/libvich263.so"; then
ac_cv_file__usr_local_lib_libvich263_so=yes
else
@@ -4219,10 +4219,10 @@
if test "${ac_cv_file__usr_local_include_vich263_encoder_h263_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
- test "$cross_compiling" = yes &&
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
- { (exit 1); exit 1; }; }
+# test "$cross_compiling" = yes &&
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+# { (exit 1); exit 1; }; }
if test -r "/usr/local/include/vich263/encoder-h263.h"; then
ac_cv_file__usr_local_include_vich263_encoder_h263_h=yes
else

View File

@ -1,107 +0,0 @@
#
# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=ptlib
PKG_VERSION:=2.10.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/opalvoip
PKG_MD5SUM:=
include $(INCLUDE_DIR)/package.mk
define Package/ptlib
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libexpat
TITLE:=Portable Tools library
URL:=http://www.opalvoip.org/
endef
define Package/ptlib/description
PTLib is a moderately large class library that has its genesis many years ago as
PWLib (portable Windows Library), a method to product applications to run on both
Microsoft Windows and Unix X-Windows systems. It also was to have a Macintosh port
as well but that never eventuated. The parts of the library relating to GUI
functions have long been removed as other class libraries such as wxWidgets were
much more advanced.
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-minsize \
--enable-opal \
--enable-internalregex \
--enable-audio \
--disable-alsa \
--disable-asn \
--disable-avc \
--enable-configfile \
--disable-dc \
--disable-dtmf \
--enable-expat \
--disable-ftp \
--disable-http \
--disable-httpsvc \
--disable-jabber \
--disable-odbc \
--disable-openldap \
--disable-openssl \
--disable-oss \
--disable-pipechan \
--disable-plugins \
--disable-pop3smtp \
--disable-remconn \
--enable-resolver \
--enable-qos \
--disable-sasl \
--disable-sdl \
--disable-serial \
--disable-shm-video \
--disable-snmp \
--disable-soap \
--disable-socks \
--enable-stun \
--disable-telnet \
--disable-tts \
--disable-v4l \
--disable-v4l2 \
--disable-bsdvideo \
--disable-video \
--disable-vxml \
--enable-wavfile \
--disable-xmlrpc \
CONFIGURE_VARS += \
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
CONFIGURE_CMD = ./configure
define Build/Configure/Default
(cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/$(strip $(3)); \
if [ -x $(CONFIGURE_CMD) ]; then \
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/$(3)/ && \
$(CONFIGURE_VARS) \
$(2) \
$(CONFIGURE_CMD) \
$(CONFIGURE_ARGS) \
$(1); \
fi; \
)
endef
MAKE_FLAGS += optnoshared
define Build/InstallDev
ln -sf $(PKG_NAME)_$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
$(SED) 's|//\(#include <ptlib/sound.h>\)|\1|' $(PKG_BUILD_DIR)/include/ptlib.h
endef
$(eval $(call BuildPackage,ptlib))

View File

@ -1,12 +0,0 @@
diff -urN ptlib-2.10.9/src/ptclib/socks.cxx ptlib-2.10.9.new/src/ptclib/socks.cxx
--- ptlib-2.10.9/src/ptclib/socks.cxx 2012-11-26 11:44:52.000000000 +0100
+++ ptlib-2.10.9.new/src/ptclib/socks.cxx 2012-12-11 15:55:41.320940496 +0100
@@ -34,6 +34,8 @@
#include <ptclib/socks.h>
+#include <algorithm>
+
#define new PNEW
#define SOCKS_VERSION_4 ((BYTE)4)

View File

@ -1,14 +0,0 @@
diff -Naur ptlib-2.10.4.orig/src/ptclib/pdns.cxx ptlib-2.10.4/src/ptclib/pdns.cxx
--- ptlib-2.10.4.orig/src/ptclib/pdns.cxx 2012-03-12 13:34:10.000000000 -0400
+++ ptlib-2.10.4/src/ptclib/pdns.cxx 2012-03-12 13:35:05.000000000 -0400
@@ -37,6 +37,10 @@
#include <ptclib/url.h>
#include <ptlib/ipsock.h>
+#if defined(__UCLIBC__)
+ #undef P_HAS_RES_NINIT
+#endif
+
#define new PNEW
#define USE_RESOLVER_CACHING 1

View File

@ -1,90 +0,0 @@
#
# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=pwlib
PKG_VERSION:=1.11.1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://peternixon.net/pub/voxgratia
PKG_MD5SUM:=e1102dfd2608e3a117a2e016d0db53e3
PKG_BUILD_DIR:=$(BUILD_DIR)/pwlib-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/pwlib
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Portable Windows library
URL:=http://www.voxgratia.org/
endef
define Package/pwlib/description
PWLib is a moderately large class library that was created as a method to
produce applications that run on both Microsoft Windows and the X Window
System.
endef
TARGET_CFLAGS += $(FPIC) -fpermissive
CONFIGURE_ARGS += \
--enable-minsize \
--enable-openh323 \
--enable-opal \
--disable-internalregex \
--disable-plugins \
--enable-audio \
--disable-alsa \
--enable-asn \
--disable-avc \
--disable-dc \
--disable-dtmf \
--disable-expat \
--disable-ftp \
--enable-http \
--disable-httpsvc \
--disable-jabber \
--disable-openldap \
--disable-openssl \
--disable-oss \
--disable-pipechan \
--disable-pop3smtp \
--disable-remconn \
--disable-resolver \
--disable-qos \
--disable-sasl \
--disable-sdl \
--disable-serial \
--disable-shm-video \
--disable-snmp \
--disable-soap \
--disable-socks \
--enable-stun \
--disable-telnet \
--disable-tts \
--disable-v4l \
--disable-v4l2 \
--disable-bsdvideo \
--disable-video \
--disable-vxml \
--disable-wavfile \
--disable-xmlrpc \
CONFIGURE_VARS += \
STDCXXFLAGS="$(TARGET_CFLAGS) -fno-builtin" \
MAKE_FLAGS += optnoshared
define Build/InstallDev
ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
$(SED) 's|//\(#include <ptlib/sound.h>\)|\1|' $(PKG_BUILD_DIR)/include/ptlib.h
endef
$(eval $(call BuildPackage,pwlib))

View File

@ -1,11 +0,0 @@
--- pwlib-cvs-20051227/make/lib.mak.orig 2005-09-25 12:51:23.000000000 +0200
+++ pwlib-cvs-20051227/make/lib.mak 2005-12-30 01:18:21.000000000 +0100
@@ -201,7 +201,7 @@
LDSOOPTS += -Wl,--kill-at
else
ifneq ($(OSTYPE),Darwin)
- LDSOOPTS += -Wl,-soname,$(LIB_SONAME)
+ LDSOOPTS += -soname,$(LIB_SONAME)
endif
endif
LD = $(CPLUS)