[packages] httping: update to v1.4.0 (#6461)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19072 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9fd41809a1
commit
e98802e5e5
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2009 OpenWrt.org
|
# Copyright (C) 2006-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=httping
|
PKG_NAME:=httping
|
||||||
PKG_VERSION:=1.3.1
|
PKG_VERSION:=1.4.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
|
PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
|
||||||
PKG_MD5SUM:=fb742d577d3e7a8ea75cf97f7eb802f2
|
PKG_MD5SUM:=d2bd46b12c6f2bcb5ec27bb44afd95b0
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -31,15 +33,12 @@ define Package/httping/description
|
|||||||
transmission across the network also takes time!
|
transmission across the network also takes time!
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
MAKE_FLAGS += \
|
||||||
$(call Build/Compile/Default, \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
|
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/httping/install
|
define Package/httping/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/httping $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/httping $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,httping))
|
$(eval $(call BuildPackage,httping))
|
||||||
|
@ -4,8 +4,8 @@
|
|||||||
|
|
||||||
WFLAGS=-Wall -W
|
WFLAGS=-Wall -W
|
||||||
OFLAGS=-O2
|
OFLAGS=-O2
|
||||||
-CFLAGS=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
|
-CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
|
||||||
+CFLAGS=$(EXTRA_CFLAGS) $(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
|
+CFLAGS+=$(EXTRA_CFLAGS) $(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
|
||||||
|
|
||||||
PACKAGE=$(TARGET)-$(VERSION)
|
PACKAGE=$(TARGET)-$(VERSION)
|
||||||
PREFIX=/usr
|
PREFIX=/usr
|
||||||
|
@ -4,12 +4,12 @@
|
|||||||
#include "utils.h"
|
#include "utils.h"
|
||||||
#include "error.h"
|
#include "error.h"
|
||||||
|
|
||||||
+#define VERSION "1.3.1"
|
+#define VERSION "1.4.0"
|
||||||
+
|
+
|
||||||
static volatile int stop = 0;
|
static volatile int stop = 0;
|
||||||
|
|
||||||
int quiet = 0;
|
int quiet = 0;
|
||||||
@@ -50,7 +52,7 @@ char last_error[ERROR_BUFFER_SIZE];
|
@@ -51,7 +53,7 @@ char last_error[ERROR_BUFFER_SIZE];
|
||||||
|
|
||||||
void version(void)
|
void version(void)
|
||||||
{
|
{
|
||||||
@ -18,7 +18,7 @@
|
|||||||
#ifndef NO_SSL
|
#ifndef NO_SSL
|
||||||
fprintf(stderr, "SSL support included\n");
|
fprintf(stderr, "SSL support included\n");
|
||||||
#endif
|
#endif
|
||||||
@@ -449,7 +451,7 @@ int main(int argc, char *argv[])
|
@@ -524,7 +526,7 @@ int main(int argc, char *argv[])
|
||||||
if (useragent)
|
if (useragent)
|
||||||
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
||||||
else
|
else
|
||||||
|
Loading…
x
Reference in New Issue
Block a user