[packages] libart: update to 2.3.21

git-svn-id: svn://svn.openwrt.org/openwrt/packages@21022 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-04-19 08:09:03 +00:00
parent 2f1b9e4e34
commit e9f9d08dcf
2 changed files with 16 additions and 38 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,20 +8,20 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libart
PKG_VERSION:=2.3.20
PKG_RELEASE:=3
PKG_VERSION:=2.3.21
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)_lgpl/2.3
PKG_MD5SUM:=d0ce67f2ebcef1e51a83136c69242a73
PKG_MD5SUM:=08559ff3c67fd95d57b0c5e91a6b4302
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_lgpl-$(PKG_VERSION)
PKG_FIXUP:=libtool
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
PKG_INSTALL=1
define Package/libart
SECTION:=libs
CATEGORY:=Libraries
@ -31,27 +31,20 @@ endef
define Package/libart/description
A library of functions for 2D graphics supporting a superset of the
PostScript imaging model, designed to be integrated with graphics, artwork,
and illustration programs. It is written in optimized C, and is fully
compatible with C++. With a small footprint of 10,000 lines of code, it is
especially suitable for embedded applications.
PostScript imaging model, designed to be integrated with graphics,
artwork, and illustration programs. It is written in optimized C, and
is fully compatible with C++. With a small footprint of 10,000 lines of
code, it is especially suitable for embedded applications.
endef
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
TARGET_CFLAGS += $(FPIC)
define Build/Configure
$(call Build/Configure/Default, \
--enable-shared \
--enable-static \
)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) HOSTCC="$(HOSTCC)"
endef
define Build/InstallDev
$(INSTALL_DIR) $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
$(INSTALL_DIR) $(2)/bin $(1)/usr/include $(1)/usr/lib/pkgconfig
$(INSTALL_BIN) \
$(PKG_INSTALL_DIR)/usr/bin/libart2-config \
$(2)/bin/

View File

@ -1,15 +0,0 @@
diff -urN libart_lgpl-2.3.19/Makefile.in libart_lgpl-2.3.19.new/Makefile.in
--- libart_lgpl-2.3.19/Makefile.in 2007-02-28 14:00:24.000000000 +0100
+++ libart_lgpl-2.3.19.new/Makefile.in 2007-12-29 02:01:55.000000000 +0100
@@ -474,9 +474,9 @@
echo " rm -f $$p $$f"; \
rm -f $$p $$f ; \
done
-gen_art_config$(EXEEXT): $(gen_art_config_OBJECTS) $(gen_art_config_DEPENDENCIES)
+gen_art_config$(EXEEXT):
@rm -f gen_art_config$(EXEEXT)
- $(LINK) $(gen_art_config_OBJECTS) $(gen_art_config_LDADD) $(LIBS)
+ $(HOSTCC) -I. -DLIBART_COMPILATION -DHAVE_CONFIG_H -o $@ gen_art_config.c
testart$(EXEEXT): $(testart_OBJECTS) $(testart_DEPENDENCIES)
@rm -f testart$(EXEEXT)
$(testart_LINK) $(testart_OBJECTS) $(testart_LDADD) $(LIBS)