[packages] php5: update to 5.3.9

Refresh patches accordingly.



git-svn-id: svn://svn.openwrt.org/openwrt/packages@29752 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mhei 2012-01-14 23:00:00 +00:00
parent ad1b9813d0
commit eb8d4c7326
5 changed files with 25690 additions and 20430 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2011 OpenWrt.org
# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=php
PKG_VERSION:=5.3.8
PKG_RELEASE:=9
PKG_VERSION:=5.3.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.php.net/distributions/
PKG_MD5SUM:=704cd414a0565d905e1074ffdc1fadfb
PKG_MD5SUM:=dd3288ed5c08cd61ac5bf619cb357521
PKG_FIXUP:=libtool no-autoreconf
PKG_BUILD_PARALLEL:=1

View File

@ -1,8 +1,8 @@
--- a/ext/standard/php_crypt_r.c
+++ b/ext/standard/php_crypt_r.c
@@ -97,6 +97,8 @@ void _crypt_extended_init_r(void)
#elif (defined(__GNUC__) && !defined(__hpux) && (__GNUC__ > 4 || \
(__GNUC__ == 4 && (__GNUC_MINOR__ > 1 || (__GNUC_MINOR__ == 1 && __GNUC_PATCHLEVEL__ > 1)))))
@@ -96,6 +96,8 @@ void _crypt_extended_init_r(void)
InterlockedIncrement(&initialized);
#elif defined(HAVE_SYNC_FETCH_AND_ADD)
__sync_fetch_and_add(&initialized, 1);
+#elif (defined(__GNUC__) && (__GNUC__ == 3))
+ initialized = 1;

View File

@ -7,7 +7,7 @@ Description: Silence warnings about using the default system timezone info
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=571762
--- a/ext/date/php_date.c
+++ b/ext/date/php_date.c
@@ -878,7 +878,7 @@ static char* guess_timezone(const timeli
@@ -886,7 +886,7 @@ static char* guess_timezone(const timeli
tzid = "UTC";
}
@ -52,7 +52,7 @@ Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=571762
-UTC
--- a/ext/date/tests/date_default_timezone_set-1.phpt
+++ b/ext/date/tests/date_default_timezone_set-1.phpt
@@ -18,9 +18,6 @@ date.timezone=
@@ -22,9 +22,6 @@ date.timezone=
echo date(DATE_ISO8601, $date4), "\n";
?>
--EXPECTF--

File diff suppressed because it is too large Load Diff

View File

@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -16067,7 +16067,7 @@ fi
@@ -16357,7 +16357,7 @@ fi
ac_libs=$LIBS
LIBS="$LIBS -ldl"
if test "$cross_compiling" = yes; then
@ -8,4 +8,4 @@
+ found=$found
else
cat > conftest.$ac_ext <<EOF
#line 16074 "configure"
#line 16364 "configure"