port glib to buildroot-ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4227 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2006-07-23 11:48:57 +00:00
parent 52292e247c
commit ecc3646461
5 changed files with 19377 additions and 0 deletions

126
libs/glib/Makefile Normal file
View File

@ -0,0 +1,126 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=glib
PKG_VERSION:=1.2.10
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.gtk.org/pub/gtk/v1.2 \
http://ftp.gwdg.de/pub/misc/grafik/gimp/gtk/v1.2/ \
http://ftp.esat.net/mirrors/ftp.gimp.org/pub/gtk/v1.2/ \
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/gtk/v1.2/
PKG_MD5SUM:=6fe30dad87c77b91b632def29dd69ef9
PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/libglib1
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libpthread
TITLE:=The GLib library of C routines
DESCRIPTION:=The GLib library of C routines.\\\
GLib is a library containing many useful C routines for things such \\\
as trees, hashes, and lists.
URL:=http://www.gtk.org/
endef
define Build/Configure
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
glib_cv_sizeof_gmutex=24 \
ac_cv_sizeof_char=1 \
ac_cv_sizeof_short=2 \
ac_cv_sizeof_int=4 \
ac_cv_sizeof_long=4 \
ac_cv_sizeof_long_long=8 \
ac_cv_sizeof_void_p=4 \
glib_cv_prog_cc_ansi_proto="no" \
glib_cv_has__inline="yes" \
glib_cv_has__inline__="yes" \
glib_cv_hasinline="yes" \
glib_cv_sane_realloc="yes" \
glib_cv_va_copy="no" \
glib_cv___va_copy="yes" \
glib_cv_va_val_copy="yes" \
glib_cv_rtldglobal_broken="no" \
glib_cv_uscore="no" \
ac_cv_func_getpwuid_r="yes" \
glib_cv_func_pthread_mutex_trylock_posix="yes" \
glib_cv_func_pthread_cond_timedwait_posix="yes" \
glib_cv_sizeof_gmutex="24" \
glib_cv_byte_contents_gmutex="0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0" \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--enable-shared=yes \
--enable-static=yes \
);
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
install
endef
define Package/libglib1/install
install -m0755 -d $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libg{lib,module,thread}-1.2.so.* $(1)/usr/lib/
endef
define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/glib-config $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/glib-1.2 $(STAGING_DIR)/usr/include/
$(CP) $(PKG_BUILD_DIR)/glibconfig-sysdefs.h $(STAGING_DIR)/usr/include/glib-1.2/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libg{lib,module,thread}.{a,so} $(STAGING_DIR)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libg{lib,module,thread}-*.so.* $(STAGING_DIR)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/glib $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/g{lib,module,thread}.pc $(STAGING_DIR)/usr/lib/pkgconfig/
endef
define Build/UninstallDev
rm -rf \
$(STAGING_DIR)/usr/bin/glib-config \
$(STAGING_DIR)/usr/include/glib-1.2 \
$(STAGING_DIR)/usr/lib/libg{lib,module,thread}.{a,so} \
$(STAGING_DIR)/usr/lib/libg{lib,module,thread}-*.so.* \
$(STAGING_DIR)/usr/lib/glib \
$(STAGING_DIR)/usr/lib/pkgconfig/g{lib,module,thread}.pc
endef
$(eval $(call BuildPackage,libglib1))

18988
libs/glib/patches/01-debian-9 Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,210 @@
diff -urN glib-1.2.10.old/configure glib-1.2.10/configure
--- glib-1.2.10.old/configure 2005-04-03 01:09:18.000000000 +0200
+++ glib-1.2.10/configure 2005-04-03 01:09:37.000000000 +0200
@@ -6025,7 +6025,7 @@
glib_save_LIBS=$LIBS
LIBS="$LIBS -lm"
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6032 "configure"
@@ -6043,7 +6043,7 @@
glib_save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -std1"
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6050 "configure"
@@ -6390,7 +6390,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6397 "configure"
@@ -6430,7 +6430,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6437 "configure"
@@ -6470,7 +6470,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6477 "configure"
@@ -6510,7 +6510,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6517 "configure"
@@ -6550,7 +6550,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6557 "configure"
@@ -6590,7 +6590,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6597 "configure"
@@ -6708,7 +6708,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6715 "configure"
@@ -6749,7 +6749,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6756 "configure"
@@ -6790,7 +6790,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6797 "configure"
@@ -6876,7 +6876,7 @@
rm -f conftest*
if test $ac_cv_c_bigendian = unknown; then
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 6883 "configure"
@@ -7767,7 +7767,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7774 "configure"
@@ -7809,7 +7809,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7816 "configure"
@@ -7854,7 +7854,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7861 "configure"
@@ -7899,7 +7899,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 7906 "configure"
@@ -8254,7 +8254,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 8261 "configure"
@@ -8306,7 +8306,7 @@
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 8313 "configure"
@@ -9137,7 +9137,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9144 "configure"
@@ -9237,7 +9237,7 @@
echo "configure:9238: checking whether pthread_mutex_trylock is posix like" >&5
# DCE Threads return 1 as success, posix 0. what a mess.
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9244 "configure"
@@ -9267,7 +9267,7 @@
echo "configure:9268: checking whether pthread_cond_timedwait is posix like" >&5
# DCE Threads return -1 as failure, posix ETIMEDOUT.
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9274 "configure"
@@ -9332,7 +9332,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9339 "configure"
@@ -9452,7 +9452,7 @@
done
echo "return 0; }" >>confrun.c
if test "$cross_compiling" = yes; then
- { echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
+ { echo "configure: error: can not run test program while cross compiling" 1>&2; }
else
cat > conftest.$ac_ext <<EOF
#line 9459 "configure"

View File

@ -0,0 +1,31 @@
diff -urN glib-1.2.10.old/glib.h glib-1.2.10/glib.h
--- glib-1.2.10.old/glib.h 2001-02-27 04:44:38.000000000 +0100
+++ glib-1.2.10/glib.h 2005-04-03 01:43:17.000000000 +0200
@@ -63,6 +63,7 @@
* exist. The prototype looks like the above, give or take a const,
* or size_t.
*/
+#include <glibconfig-sysdefs.h>
#include <glibconfig.h>
/* include varargs functions for assertment macros
diff -urN glib-1.2.10.old/configure glib-1.2.10/configure
--- glib-1.2.10.old/configure 2005-04-03 01:43:49.000000000 +0200
+++ glib-1.2.10/configure 2005-04-03 01:45:47.000000000 +0200
@@ -575,16 +575,6 @@
# Save this value here, since automake will set cflags later
cflags_set=${CFLAGS+set}
-# we rewrite this file
-rm -f glibconfig-sysdefs.h
-
-
-
-
-
-
-
-
# libtool versioning
LT_RELEASE=$GLIB_MAJOR_VERSION.$GLIB_MINOR_VERSION

View File

@ -0,0 +1,22 @@
Submitted By: Uwe Düffert (lfs at uwe-dueffert dot de)
Date: 2004-05-15
Initial Package Version: 1.2.10
Origin: self-created, http://www.uwe-dueffert.de/lfs/ownpatches/glib-1.2.10-gcc34-1.patch
Upstream Status: not reported
Description: fix compilation of glib1 with gcc34
$LastChangedBy$
$Date$
diff -Naur glib-1.2.10.orig/gstrfuncs.c glib-1.2.10/gstrfuncs.c
--- glib-1.2.10.orig/gstrfuncs.c 2004-05-15 13:40:03.556092792 +0000
+++ glib-1.2.10/gstrfuncs.c 2004-05-15 13:40:36.712052320 +0000
@@ -47,6 +47,8 @@
* inteferes with g_strsignal() on some OSes
*/
+#define G_GNUC_PRETTY_FUNCTION
+
typedef union _GDoubleIEEE754 GDoubleIEEE754;
#define G_IEEE754_DOUBLE_BIAS (1023)
/* multiply with base2 exponent to get base10 exponent (nomal numbers) */