[Packages] libs/gnutls: Update to 2.2.3 (#3421)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11081 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7e85e6fd56
commit
ed4ecdcf2c
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# Copyright (C) 2005-2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,16 +9,15 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gnutls
|
||||
PKG_VERSION:=2.0.0
|
||||
PKG_VERSION:=2.2.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://josefsson.org/gnutls/releases/ \
|
||||
http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
|
||||
PKG_SOURCE_URL:=http://www.mirrors.wiretapped.net/security/network-security/gnutls/ \
|
||||
ftp://ftp.gnutls.org/pub/gnutls/ \
|
||||
ftp://ftp.gnupg.org/gcrypt/alpha/gnutls/ \
|
||||
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/
|
||||
PKG_MD5SUM:=181b2ff554a83e6cf85505ea16699d39
|
||||
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ \
|
||||
http://josefsson.org/gnutls/releases/
|
||||
PKG_MD5SUM:=71d9b7ec32a2a67854940a8848c2b229
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
@ -71,7 +70,7 @@ endef
|
||||
define Package/libgnutls
|
||||
$(call Package/gnutls/Default)
|
||||
TITLE+= (library)
|
||||
DEPENDS+= +libgcrypt +libgpg-error
|
||||
DEPENDS+= +zlib +libtasn1 +libgcrypt +libgpg-error
|
||||
endef
|
||||
|
||||
define Package/libgnutls/description
|
||||
@ -103,36 +102,17 @@ $(call Package/gnutls/Default/description)
|
||||
This package contains the GnuTLS OpenSSL compatibility layer shared library.
|
||||
endef
|
||||
|
||||
|
||||
# XXX: configure will disable any of theese if they're present regardless of
|
||||
# the "--enable" prefix
|
||||
# --enable-anon-authentication \
|
||||
# --enable-openpgp-authentication \
|
||||
# --enable-psk-authentication \
|
||||
# --enable-srp-authentication \
|
||||
# --enable-tls-authorization \
|
||||
#
|
||||
# and the following prevents the library from building so it's ommited
|
||||
# --disable-tls-authorization
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-anon-authentication \
|
||||
--disable-openpgp-authentication \
|
||||
--disable-psk-authentication \
|
||||
--disable-srp-authentication \
|
||||
--with-included-libtasn1 \
|
||||
--with-included-libcfg \
|
||||
--without-included-opencdk \
|
||||
--with-libgcrypt \
|
||||
--with-libgcrypt-prefix="$(STAGING_DIR)/usr" \
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
--without-libopencdk-prefix \
|
||||
--with-libreadline-prefix="$(STAGING_DIR)/usr" \
|
||||
--without-lzo \
|
||||
--without-zlib \
|
||||
--with-libz-prefix="$(STAGING_DIR)/usr" \
|
||||
--with-libtasn1-prefix="$(STAGING_DIR)/usr" \
|
||||
--without-lzo
|
||||
|
||||
# XXX: AM_CFLAGS duplicates with CFLAGS
|
||||
MAKE_ARGS:= \
|
||||
|
@ -1,14 +1,13 @@
|
||||
Index: gnutls-2.0.0/Makefile.in
|
||||
Index: gnutls-2.2.3/Makefile.in
|
||||
===================================================================
|
||||
--- gnutls-2.0.0.orig/Makefile.in 2007-09-07 21:59:37.000000000 +0200
|
||||
+++ gnutls-2.0.0/Makefile.in 2007-09-07 22:00:00.000000000 +0200
|
||||
@@ -498,8 +498,7 @@
|
||||
--- gnutls-2.2.3.orig/Makefile.in 2008-05-08 21:18:29.000000000 +0200
|
||||
+++ gnutls-2.2.3/Makefile.in 2008-05-08 21:18:29.000000000 +0200
|
||||
@@ -537,7 +537,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
|
||||
-SUBDIRS = lgl gl includes lib libextra src $(am__append_1) doc tests \
|
||||
- po
|
||||
+SUBDIRS = lgl gl includes lib libextra src $(am__append_1)
|
||||
-SUBDIRS = lgl gl includes lib libextra src doc tests po \
|
||||
+SUBDIRS = lgl gl includes lib libextra src \
|
||||
$(am__append_1)
|
||||
ACLOCAL_AMFLAGS = -I m4 -I gl/m4 -I lgl/m4
|
||||
tag = $(PACKAGE)_`echo $(VERSION) | sed 's/\./_/g'`
|
||||
all: config.h
|
||||
|
@ -1,21 +1,20 @@
|
||||
diff -ruN gnutls-2.0.0-old/libextra/gnutls_extra.c gnutls-2.0.0-new/libextra/gnutls_extra.c
|
||||
--- gnutls-2.0.0-old/libextra/gnutls_extra.c 2007-05-26 20:43:24.000000000 +0200
|
||||
+++ gnutls-2.0.0-new/libextra/gnutls_extra.c 2007-09-09 13:36:21.000000000 +0200
|
||||
@@ -140,6 +140,8 @@
|
||||
Index: gnutls-2.2.3/libextra/gnutls_extra.c
|
||||
===================================================================
|
||||
--- gnutls-2.2.3.orig/libextra/gnutls_extra.c 2008-05-08 21:18:29.000000000 +0200
|
||||
+++ gnutls-2.2.3/libextra/gnutls_extra.c 2008-05-08 21:18:29.000000000 +0200
|
||||
@@ -137,6 +137,7 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
+#ifdef ENABLE_OPENPGP
|
||||
+
|
||||
/* Register the openpgp functions. This is because some
|
||||
* of them are defined to be NULL in the main library.
|
||||
*/
|
||||
@@ -155,6 +157,8 @@
|
||||
gnutls_openpgp_key_deinit,
|
||||
@@ -152,6 +153,7 @@
|
||||
gnutls_openpgp_crt_deinit,
|
||||
gnutls_openpgp_keyring_deinit,
|
||||
gnutls_openpgp_privkey_deinit);
|
||||
+#endif
|
||||
|
||||
+#endif /* ENABLE_OPENPGP */
|
||||
+
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user