[package] update aprx to 2.00 r421 (#7803)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22761 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-08-22 16:36:30 +00:00
parent 76955d7a1e
commit ed6091f2ae
2 changed files with 12 additions and 11 deletions

View File

@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=aprx
PKG_REV:=121
PKG_VERSION:=0.99_r$(PKG_REV)
PKG_REV:=421
PKG_VERSION:=2.00_r$(PKG_REV)
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@ -35,7 +35,7 @@ endef
CONFIGURE_ARGS += \
--with-embedded \
define Package/aprx/install
define Package/aprx/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/aprx.init $(1)/etc/init.d/aprx
$(INSTALL_DIR) $(1)/etc

View File

@ -1,18 +1,19 @@
diff -ruN aprx-0.22.svn115.orig/Makefile.in aprx-0.22.svn115/Makefile.in
--- aprx-0.22.svn115.orig/Makefile.in 2008-07-06 17:28:27.000000000 -0400
+++ aprx-0.22.svn115/Makefile.in 2008-07-06 17:29:42.000000000 -0400
@@ -25,7 +25,8 @@
CFLAGS= @CFLAGS@ $(DEFS)
diff -ruN aprx-2.00_r421.orig/Makefile.in aprx-2.00_r421/Makefile.in
--- aprx-2.00_r421.orig/Makefile.in 2010-06-19 15:13:47.000000000 +0000
+++ aprx-2.00_r421/Makefile.in 2010-08-22 00:14:35.000000000 +0000
@@ -27,8 +27,9 @@
CFLAGS= @CFLAGS@
# Linker and flags
-LD= @LD@
+LD= @CC@
LDFLAGS= @LDFLAGS@
LDFLAGS= @LDFLAGS@ $(PROF)
+datarootdir = @datarootdir@
INSTALL= $(srcdir)/install-sh
@@ -75,10 +75,10 @@
all: $(PROGAPRX) $(PROGSTAT) man aprx.conf
INSTALL_PROGRAM=$(INSTALL) -m 755
@@ -89,10 +90,10 @@
$(PROGAPRX): $(OBJSAPRX) VERSION Makefile
- $(LD) $(LDFLAGS) -o $@ $(OBJSAPRX) $(LIBS)