Add ssldump

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13628 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-12-14 17:10:36 +00:00
parent e86dc1cec2
commit ed9e74add2
2 changed files with 78 additions and 0 deletions

55
utils/ssldump/Makefile Normal file
View File

@ -0,0 +1,55 @@
#
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
include $(TOPDIR)/rules.mk
PKG_NAME:=ssldump
PKG_VERSION:=0.9b3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.rtfm.com/ssldump/
PKG_MD5SUM:=
include $(INCLUDE_DIR)/package.mk
define Package/ssldump
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libopenssl +libpcap
TITLE:=a SSLv3/TLS network protocol analyzer
URL:=http://www.rtfm.com/ssldump/
endef
define Package/ssldump/description
ssldump is an SSLv3/TLS network protocol analyzer. It identifies TCP connections on the chosen network interface
and attempts to interpret them as SSLv3/TLS traffic. When it identifies SSLv3/TLS traffic, it decodes the records
and displays them in a textual form to stdout. If provided with the appropriate keying material, it will also decrypt
the connections and display the application data traffic.
endef
CONFIGURE_ARGS += \
--enable-static \
--enable-shared \
--with-openssl-inc="$(STAGING_DIR)/usr/include" \
--with-openssl-lib="$(STAGING_DIR)/usr/lib" \
--with-pcap-inc="$(STAGING_DIR)/usr/include" \
--with-pcap-lib="$(STAGING_DIR)/usr/lib" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all
endef
define Package/ssldump/install
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ssldump $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,ssldump))

View File

@ -0,0 +1,23 @@
diff -urN ssldump-0.9b3/base/pcap-snoop.c ssldump-0.9b3.new/base/pcap-snoop.c
--- ssldump-0.9b3/base/pcap-snoop.c 2002-09-09 23:02:58.000000000 +0200
+++ ssldump-0.9b3.new/base/pcap-snoop.c 2008-12-14 18:43:48.000000000 +0100
@@ -49,7 +49,7 @@
#include <pcap.h>
#include <unistd.h>
-#include <net/bpf.h>
+#include <pcap-bpf.h>
#ifndef _WIN32
#include <sys/param.h>
#endif
diff -urN ssldump-0.9b3/ssl/ssldecode.c ssldump-0.9b3.new/ssl/ssldecode.c
--- ssldump-0.9b3/ssl/ssldecode.c 2002-08-17 03:33:17.000000000 +0200
+++ ssldump-0.9b3.new/ssl/ssldecode.c 2008-12-14 18:44:11.000000000 +0100
@@ -52,6 +52,7 @@
#include <openssl/hmac.h>
#include <openssl/evp.h>
#include <openssl/x509v3.h>
+#include <openssl/md5.h>
#endif
#include "ssldecode.h"
#include "ssl_rec.h"