Port vpnc to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4562 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6f5f687918
commit
edec4e9ef2
55
net/vpnc/Makefile
Normal file
55
net/vpnc/Makefile
Normal file
@ -0,0 +1,55 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vpnc
|
||||
PKG_VERSION:=0.3.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
|
||||
PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/vpnc
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libgpg-error +libgcrypt
|
||||
TITLE:=VPN client for Cisco 3000
|
||||
DESCRIPTION:=Client for cisco3000 VPN Concentrator
|
||||
URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
|
||||
endef
|
||||
|
||||
define Package/vpnc/conffiles
|
||||
/etc/vpnc/vpnc.conf
|
||||
/etc/vpnc/vpnc-script
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,CC="$(TARGET_CC)" \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
OS="Linux" \
|
||||
STAGING_DIR="$(STAGING_DIR)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
PREFIX=/usr \
|
||||
all install)
|
||||
endef
|
||||
|
||||
define Package/vpnc/install
|
||||
install -d -m0755 $(1)
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,vpnc))
|
44
net/vpnc/patches/01-cross.patch
Normal file
44
net/vpnc/patches/01-cross.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff -Nur vpnc-0.3.3/Makefile vpnc-0.3.3.patched/Makefile
|
||||
--- vpnc-0.3.3/Makefile 2005-05-01 22:30:35.000000000 +0200
|
||||
+++ vpnc-0.3.3.patched/Makefile 2005-12-23 23:43:55.222055250 +0100
|
||||
@@ -17,31 +17,32 @@
|
||||
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
||||
|
||||
DESTDIR=
|
||||
-PREFIX=/usr/local
|
||||
+PREFIX=/usr
|
||||
ETCDIR=/etc/vpnc
|
||||
SBINDIR=$(PREFIX)/sbin
|
||||
MANDIR=$(PREFIX)/share/man
|
||||
|
||||
CC=gcc
|
||||
-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
||||
-LDFLAGS=-g $(shell libgcrypt-config --libs)
|
||||
+CFLAGS=-W -Wall -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"'
|
||||
+LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lgcrypt -lgpg-error
|
||||
|
||||
-ifeq ($(shell uname -s), Linux)
|
||||
+OS=$(shell uname -s)
|
||||
+ifeq ($(OS), Linux)
|
||||
SYSDEP=sysdep-linux.o
|
||||
endif
|
||||
-ifeq ($(shell uname -s), FreeBSD)
|
||||
+ifeq ($(OS), FreeBSD)
|
||||
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN
|
||||
SYSDEP=sysdep-bsd.o
|
||||
endif
|
||||
-ifeq ($(shell uname -s), NetBSD)
|
||||
+ifeq ($(OS), NetBSD)
|
||||
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN
|
||||
SYSDEP=sysdep-bsd.o
|
||||
endif
|
||||
-ifeq ($(shell uname -s), OpenBSD)
|
||||
+ifeq ($(OS), OpenBSD)
|
||||
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN -DNEED_IPLEN_FIX -DNEW_TUN
|
||||
SYSDEP=sysdep-bsd.o
|
||||
endif
|
||||
-ifeq ($(shell uname -s), SunOS)
|
||||
+ifeq ($(OS), SunOS)
|
||||
CFLAGS += -DNEED_IPLEN_FIX
|
||||
LDFLAGS += -lnsl -lresolv -lsocket
|
||||
SYSDEP=sysdep-svr4.o
|
Loading…
x
Reference in New Issue
Block a user