[Packages] multimedia/palantir: Update to 2.7 (#3314)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10767 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f0760916ee
commit
edf40da236
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,27 +9,26 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=palantir
|
||||
PKG_VERSION:=2.6
|
||||
PKG_VERSION:=2.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
|
||||
PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_MD5SUM:=3a5b1fb340857f6d8e357bf39b77583e
|
||||
|
||||
PKG_BUILD_DEPENDS:=libjpeg
|
||||
|
||||
define Package/palantir
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
DEPENDS:=+libjpeg +libpthread
|
||||
TITLE:=A multichannel interactive streaming solution
|
||||
URL:=http://www.fastpath.it/products/palantir/
|
||||
endef
|
||||
|
||||
define Package/palantir/description
|
||||
Palantir is a Linux-based streaming system designed to transmit live
|
||||
video, audio and data over a TCP/IP network, as well as to control
|
||||
Palantir is a Linux-based streaming system designed to transmit live
|
||||
video, audio and data over a TCP/IP network, as well as to control
|
||||
remote devices.
|
||||
endef
|
||||
|
||||
|
@ -1,19 +1,8 @@
|
||||
diff -ruN palantir-2.6-old/server/Makefile palantir-2.6-new/server/Makefile
|
||||
--- palantir-2.6-old/server/Makefile 2005-09-02 14:33:50.000000000 +0200
|
||||
+++ palantir-2.6-new/server/Makefile 2006-10-27 23:53:10.000000000 +0200
|
||||
@@ -47,7 +47,7 @@
|
||||
.PHONY : tools man
|
||||
|
||||
|
||||
-CFLAGS= -Wall -D_REENTRANT -O3 -g
|
||||
+CFLAGS= -Wall -D_REENTRANT $(COPTS)
|
||||
CC= gcc
|
||||
libjpeg= -ljpeg
|
||||
|
||||
diff -ruN palantir-2.6-old/server/libgsm/Makefile palantir-2.6-new/server/libgsm/Makefile
|
||||
--- palantir-2.6-old/server/libgsm/Makefile 2005-08-14 00:16:27.000000000 +0200
|
||||
+++ palantir-2.6-new/server/libgsm/Makefile 2006-10-27 23:53:44.000000000 +0200
|
||||
@@ -51,7 +51,7 @@
|
||||
Index: palantir-2.7/server/libgsm/Makefile
|
||||
===================================================================
|
||||
--- palantir-2.7.orig/server/libgsm/Makefile 2008-04-07 22:35:39.000000000 +0200
|
||||
+++ palantir-2.7/server/libgsm/Makefile 2008-04-07 22:35:39.000000000 +0200
|
||||
@@ -53,7 +53,7 @@
|
||||
endif
|
||||
|
||||
CC += -ansi -pedantic
|
||||
@ -22,3 +11,16 @@ diff -ruN palantir-2.6-old/server/libgsm/Makefile palantir-2.6-new/server/libgsm
|
||||
|
||||
LD = $(CC)
|
||||
|
||||
Index: palantir-2.7/server/Makefile
|
||||
===================================================================
|
||||
--- palantir-2.7.orig/server/Makefile 2008-04-07 22:35:39.000000000 +0200
|
||||
+++ palantir-2.7/server/Makefile 2008-04-07 22:35:39.000000000 +0200
|
||||
@@ -47,7 +47,7 @@
|
||||
.PHONY : tools man
|
||||
|
||||
|
||||
-CFLAGS= -Wall -D_REENTRANT -O2 -g
|
||||
+CFLAGS= -Wall -D_REENTRANT $(COPTS)
|
||||
# -O3
|
||||
CC= gcc
|
||||
libjpeg= -ljpeg
|
||||
|
Loading…
x
Reference in New Issue
Block a user