dhcpcd: update to 6.1.0
DHCPv6 and other features see: http://roy.marples.name/projects/dhcpcd/wiki/DhcpcdHistory -update download location -install default dhcpcd hooks script and example hooks v2: -add CFLAGS to configure test configure test failed silently on OMAP because of missing CFLAGS (-mfloat-abi=hard) with ../arm-openwrt-linux-uclibcgnueabi/bin/ld: error: _getifaddrs uses VFP register arguments Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40726 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0f909ece6b
commit
ee7b071f1d
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2007-2010 OpenWrt.org
|
# Copyright (C) 2007-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dhcpcd
|
PKG_NAME:=dhcpcd
|
||||||
PKG_VERSION:=3.0.17
|
PKG_VERSION:=6.1.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://download.berlios.de/dhcpcd/
|
PKG_SOURCE_URL:=ftp://roy.marples.name/pub/dhcpcd
|
||||||
PKG_MD5SUM:=e9100e53f64ca1f9fb0d392c3a623738
|
PKG_MD5SUM:=6070040c57492925af9ac6aed980de2a
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
@ -24,6 +24,7 @@ define Package/dhcpcd
|
|||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
SUBMENU:=IP Addresses and Names
|
SUBMENU:=IP Addresses and Names
|
||||||
TITLE:=DHCP client for automatically configuring IPv4 networking
|
TITLE:=DHCP client for automatically configuring IPv4 networking
|
||||||
|
DEPENDS:=+librt
|
||||||
URL:=http://roy.marples.name/projects/dhcpcd
|
URL:=http://roy.marples.name/projects/dhcpcd
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -33,8 +34,11 @@ define Package/dhcpcd/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/dhcpcd/install
|
define Package/dhcpcd/install
|
||||||
$(INSTALL_DIR) $(1)/sbin
|
$(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/etc/dhcpcd.enter-hook
|
||||||
$(CP) $(PKG_INSTALL_DIR)/sbin/* $(1)/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcpcd $(1)/sbin/
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/dhcpcd-run-hooks $(1)/sbin/
|
||||||
|
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/dhcpcd.conf $(1)/etc/dhcpcd.conf
|
||||||
|
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/usr/lib/dhcpcd-hooks/* $(1)/etc/dhcpcd.enter-hook/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,dhcpcd))
|
$(eval $(call BuildPackage,dhcpcd))
|
||||||
|
@ -0,0 +1,11 @@
|
|||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -369,7 +369,7 @@ int main(void) {
|
||||||
|
return getifaddrs(&ifap);
|
||||||
|
}
|
||||||
|
EOF
|
||||||
|
-if $XCC _getifaddrs.c -o _getifaddrs 2>/dev/null; then
|
||||||
|
+if $XCC $CFLAGS _getifaddrs.c -o _getifaddrs 2>/dev/null; then
|
||||||
|
echo "yes"
|
||||||
|
else
|
||||||
|
echo "no"
|
@ -1,11 +0,0 @@
|
|||||||
--- dhcpcd-3.0.17/pathnames.h.orig 2007-05-31 15:28:04.000000000 -0700
|
|
||||||
+++ dhcpcd-3.0.17/pathnames.h 2007-05-31 15:28:16.000000000 -0700
|
|
||||||
@@ -48,7 +48,7 @@
|
|
||||||
#define STATEDIR "/var"
|
|
||||||
#define PIDFILE STATEDIR "/run/" PACKAGE "-%s.pid"
|
|
||||||
|
|
||||||
-#define CONFIGDIR STATEDIR "/lib/" PACKAGE
|
|
||||||
+#define CONFIGDIR STATEDIR "/run/" PACKAGE
|
|
||||||
#define INFOFILE CONFIGDIR "/" PACKAGE "-%s.info"
|
|
||||||
|
|
||||||
#endif
|
|
Loading…
x
Reference in New Issue
Block a user