[packages] miniupnpc: update to 1.7

git-svn-id: svn://svn.openwrt.org/openwrt/packages@34745 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2012-12-18 03:36:00 +00:00
parent 6fd8bbc861
commit eec616d493
3 changed files with 9 additions and 8 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2010-2011 OpenWrt.org # Copyright (C) 2010-2012 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpc PKG_NAME:=miniupnpc
PKG_VERSION:=1.6 PKG_VERSION:=1.7
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE_URL:=http://miniupnp.free.fr/files PKG_SOURCE_URL:=http://miniupnp.free.fr/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_MD5SUM:=88055f2d4a061cfd4cfe25a9eae22f67 PKG_MD5SUM:=297bee441b56af87c6622fc4002179fd
PKG_INSTALL:=1 PKG_INSTALL:=1
@ -43,6 +43,7 @@ endef
TARGET_CFLAGS += $(FPIC) TARGET_CFLAGS += $(FPIC)
MAKE_FLAGS += \ MAKE_FLAGS += \
OS="Linux" \
PREFIX="$(PKG_INSTALL_DIR)" PREFIX="$(PKG_INSTALL_DIR)"
define Build/InstallDev define Build/InstallDev

View File

@ -1,6 +1,6 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -107,8 +107,8 @@ installpythonmodule: pythonmodule @@ -129,8 +129,8 @@ installpythonmodule: pythonmodule
python setup.py install python setup.py install
validateminixml: minixmlvalid validateminixml: minixmlvalid
@ -10,4 +10,4 @@
+# ./minixmlvalid +# ./minixmlvalid
touch $@ touch $@
clean: validateminiwget: testminiwget minihttptestserver testminiwget.sh

View File

@ -1,11 +1,11 @@
--- a/upnpcommands.c --- a/upnpcommands.c
+++ b/upnpcommands.c +++ b/upnpcommands.c
@@ -351,7 +351,7 @@ UPNP_AddPortMapping(const char * control @@ -367,7 +367,7 @@ UPNP_AddPortMapping(const char * control
AddPortMappingArgs[5].elt = "NewEnabled"; AddPortMappingArgs[5].elt = "NewEnabled";
AddPortMappingArgs[5].val = "1"; AddPortMappingArgs[5].val = "1";
AddPortMappingArgs[6].elt = "NewPortMappingDescription"; AddPortMappingArgs[6].elt = "NewPortMappingDescription";
- AddPortMappingArgs[6].val = desc?desc:"libminiupnpc"; - AddPortMappingArgs[6].val = desc?desc:"libminiupnpc";
+ AddPortMappingArgs[6].val = desc?desc:"miniupnpc"; + AddPortMappingArgs[6].val = desc?desc:"miniupnpc";
AddPortMappingArgs[7].elt = "NewLeaseDuration"; AddPortMappingArgs[7].elt = "NewLeaseDuration";
AddPortMappingArgs[7].val = "0"; AddPortMappingArgs[7].val = leaseDuration?leaseDuration:"0";
if(simpleUPnPcommand(-1, controlURL, servicetype, "AddPortMapping", AddPortMappingArgs, buffer, &bufsize) < 0) { if(!(buffer = simpleUPnPcommand(-1, controlURL, servicetype,