nginx: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41305 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
12d13023f7
commit
ef0d7fcc74
@ -1,161 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2010-2012 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
menu "Configuration"
|
|
||||||
depends on PACKAGE_nginx
|
|
||||||
|
|
||||||
config NGINX_STUB_STATUS
|
|
||||||
bool
|
|
||||||
prompt "Enable stub status module"
|
|
||||||
help
|
|
||||||
Enable the stub status module which gives some status from the server.
|
|
||||||
|
|
||||||
config NGINX_FLV
|
|
||||||
bool
|
|
||||||
prompt "Enable FLV module"
|
|
||||||
help
|
|
||||||
Provides the ability to seek within FLV (Flash) files using time-based offsets.
|
|
||||||
|
|
||||||
config NGINX_SSL
|
|
||||||
bool
|
|
||||||
prompt "Enable SSL module"
|
|
||||||
help
|
|
||||||
Enable HTTPS/SSL support.
|
|
||||||
|
|
||||||
config NGINX_DAV
|
|
||||||
bool
|
|
||||||
prompt "Enable WebDAV module"
|
|
||||||
help
|
|
||||||
Enable the HTTP and WebDAV methods PUT, DELETE, MKCOL, COPY and MOVE.
|
|
||||||
|
|
||||||
config NGINX_LUA
|
|
||||||
bool
|
|
||||||
prompt "Enable LUA module"
|
|
||||||
help
|
|
||||||
Enable support for LUA scripts.
|
|
||||||
|
|
||||||
config NGINX_PCRE
|
|
||||||
bool
|
|
||||||
prompt "Enable PCRE library usage"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_CACHE
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP cache"
|
|
||||||
|
|
||||||
config NGINX_HTTP_CHARSET
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP charset module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_GZIP
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP gzip module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_SSI
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP ssi module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_USERID
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP userid module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_ACCESS
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP access module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_AUTH_BASIC
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP auth basic"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_AUTOINDEX
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP autoindex module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_GEO
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP geo module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_MAP
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP map module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_SPLIT_CLIENTS
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP split clients"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_REFERER
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP referer module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_REWRITE
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP rewrite module"
|
|
||||||
select NGINX_PCRE
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_PROXY
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP proxy module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_FASTCGI
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP fastcgi module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_UWSGI
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP uwsgi module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_SCGI
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP scgi module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_MEMCACHED
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP memcached module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_LIMIT_CONN
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP limit conn"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_LIMIT_REQ
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP limit req"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_EMPTY_GIF
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP empty gif"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_BROWSER
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP browser module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
config NGINX_HTTP_UPSTREAM_IP_HASH
|
|
||||||
bool
|
|
||||||
prompt "Enable HTTP IP hash module"
|
|
||||||
default y
|
|
||||||
|
|
||||||
endmenu
|
|
@ -1,221 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2009-2012 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=nginx
|
|
||||||
PKG_VERSION:=1.4.4
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://nginx.org/download/
|
|
||||||
PKG_MD5SUM:=5dfaba1cbeae9087f3949860a02caa9f
|
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
PKG_CONFIG_DEPENDS := \
|
|
||||||
CONFIG_NGINX_STUB_STATUS \
|
|
||||||
CONFIG_NGINX_FLV \
|
|
||||||
CONFIG_NGINX_SSL \
|
|
||||||
CONFIG_NGINX_DAV \
|
|
||||||
CONFIG_NGINX_LUA \
|
|
||||||
CONFIG_NGINX_PCRE \
|
|
||||||
CONFIG_NGINX_HTTP_CACHE \
|
|
||||||
CONFIG_NGINX_HTTP_CHARSET \
|
|
||||||
CONFIG_NGINX_HTTP_GZIP \
|
|
||||||
CONFIG_NGINX_HTTP_SSI \
|
|
||||||
CONFIG_NGINX_HTTP_USERID \
|
|
||||||
CONFIG_NGINX_HTTP_ACCESS \
|
|
||||||
CONFIG_NGINX_HTTP_AUTH_BASIC \
|
|
||||||
CONFIG_NGINX_HTTP_AUTOINDEX \
|
|
||||||
CONFIG_NGINX_HTTP_GEO \
|
|
||||||
CONFIG_NGINX_HTTP_MAP \
|
|
||||||
CONFIG_NGINX_HTTP_SPLIT_CLIENTS \
|
|
||||||
CONFIG_NGINX_HTTP_REFERER \
|
|
||||||
CONFIG_NGINX_HTTP_REWRITE \
|
|
||||||
CONFIG_NGINX_HTTP_PROXY \
|
|
||||||
CONFIG_NGINX_HTTP_FASTCGI \
|
|
||||||
CONFIG_NGINX_HTTP_UWSGI \
|
|
||||||
CONFIG_NGINX_HTTP_SCGI \
|
|
||||||
CONFIG_NGINX_HTTP_MEMCACHED \
|
|
||||||
CONFIG_NGINX_HTTP_LIMIT_CONN \
|
|
||||||
CONFIG_NGINX_HTTP_LIMIT_REQ \
|
|
||||||
CONFIG_NGINX_HTTP_EMPTY_GIF \
|
|
||||||
CONFIG_NGINX_HTTP_BROWSER \
|
|
||||||
CONFIG_NGINX_HTTP_UPSTREAM_IP_HASH
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/nginx
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
SUBMENU:=Web Servers/Proxies
|
|
||||||
TITLE:=Nginx web server
|
|
||||||
URL:=http://nginx.org/
|
|
||||||
DEPENDS:=+NGINX_PCRE:libpcre +(NGINX_SSL||NGINX_HTTP_CACHE||NGINX_HTTP_AUTH_BASIC):libopenssl +NGINX_HTTP_GZIP:zlib +libpthread +NGINX_LUA:liblua
|
|
||||||
MENU:=1
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/nginx/description
|
|
||||||
nginx is an HTTP and reverse proxy server, as well as a mail proxy server,
|
|
||||||
written by Igor Sysoev.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/nginx/config
|
|
||||||
source "$(SOURCE)/Config.in"
|
|
||||||
endef
|
|
||||||
|
|
||||||
config_files=nginx.conf mime.types fastcgi_params koi-utf koi-win win-utf
|
|
||||||
|
|
||||||
define Package/nginx/conffiles
|
|
||||||
/etc/nginx/
|
|
||||||
endef
|
|
||||||
|
|
||||||
ADDITIONAL_MODULES:=
|
|
||||||
|
|
||||||
ifeq ($(CONFIG_IPV6),y)
|
|
||||||
ADDITIONAL_MODULES += --with-ipv6
|
|
||||||
endif
|
|
||||||
ifeq ($(CONFIG_NGINX_STUB_STATUS),y)
|
|
||||||
ADDITIONAL_MODULES += --with-http_stub_status_module
|
|
||||||
endif
|
|
||||||
ifeq ($(CONFIG_NGINX_FLV),y)
|
|
||||||
ADDITIONAL_MODULES += --with-http_flv_module
|
|
||||||
endif
|
|
||||||
ifeq ($(CONFIG_NGINX_SSL),y)
|
|
||||||
ADDITIONAL_MODULES += --with-http_ssl_module
|
|
||||||
endif
|
|
||||||
ifeq ($(CONFIG_NGINX_DAV),y)
|
|
||||||
ADDITIONAL_MODULES += --with-http_dav_module
|
|
||||||
endif
|
|
||||||
ifeq ($(CONFIG_NGINX_LUA),y)
|
|
||||||
ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/lua-nginx
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_CACHE),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http-cache
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_PCRE),y)
|
|
||||||
ADDITIONAL_MODULES += --without-pcre
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_CHARSET),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_charset_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_GZIP),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_gzip_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_SSI),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_ssi_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_USERID),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_userid_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_ACCESS),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_access_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_AUTH_BASIC),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_auth_basic_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_AUTOINDEX),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_autoindex_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_GEO),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_geo_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_MAP),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_map_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_SPLIT_CLIENTS),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_split_clients_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_REFERER),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_referer_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_REWRITE),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_rewrite_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_PROXY),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_proxy_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_FASTCGI),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_fastcgi_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_UWSGI),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_uwsgi_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_SCGI),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_scgi_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_MEMCACHED),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_memcached_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_LIMIT_CONN),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_limit_conn_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_LIMIT_REQ),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_limit_req_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_EMPTY_GIF),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_empty_gif_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_BROWSER),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_browser_module
|
|
||||||
endif
|
|
||||||
ifneq ($(CONFIG_NGINX_HTTP_UPSTREAM_IP_HASH),y)
|
|
||||||
ADDITIONAL_MODULES += --without-http_upstream_ip_hash_module
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
# TODO: fix --crossbuild
|
|
||||||
(cd $(PKG_BUILD_DIR) ;\
|
|
||||||
$(if $(CONFIG_NGINX_LUA),LUA_INC=$(STAGING_DIR)/usr/include LUA_LIB=$(STAGING_DIR)/usr/lib) \
|
|
||||||
./configure \
|
|
||||||
--crossbuild=Linux::$(ARCH) \
|
|
||||||
--prefix=/usr \
|
|
||||||
--conf-path=/etc/nginx/nginx.conf \
|
|
||||||
--error-log-path=/var/log/nginx/error.log \
|
|
||||||
--pid-path=/var/run/nginx.pid \
|
|
||||||
--lock-path=/var/lock/nginx.lock \
|
|
||||||
--http-log-path=/var/log/nginx/access.log \
|
|
||||||
--http-client-body-temp-path=/var/lib/nginx/body \
|
|
||||||
--http-proxy-temp-path=/var/lib/nginx/proxy \
|
|
||||||
--http-fastcgi-temp-path=/var/lib/nginx/fastcgi \
|
|
||||||
--with-cc="$(TARGET_CC)" \
|
|
||||||
--with-cc-opt="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
|
|
||||||
--with-ld-opt="$(TARGET_LDFLAGS)" \
|
|
||||||
$(ADDITIONAL_MODULES) )
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/nginx/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/nginx $(1)/usr/sbin/
|
|
||||||
$(INSTALL_DIR) $(1)/etc/nginx
|
|
||||||
$(INSTALL_DATA) $(addprefix $(PKG_INSTALL_DIR)/etc/nginx/,$(config_files)) $(1)/etc/nginx/
|
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
|
||||||
$(INSTALL_BIN) ./files/nginx.init $(1)/etc/init.d/nginx
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Prepare
|
|
||||||
$(call Build/Prepare/Default)
|
|
||||||
$(if $(CONFIG_NGINX_LUA),$(call Prepare/lua-nginx))
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Download/lua-nginx
|
|
||||||
VERSION:=7c0948a08e8449f7a9ffbc35244954e6aaddac5b
|
|
||||||
SUBDIR:=lua-nginx
|
|
||||||
FILE:=lua-nginx-module-$(PKG_VERSION)-$$(VERSION).tar.gz
|
|
||||||
URL:=https://github.com/chaoslawful/lua-nginx-module.git
|
|
||||||
PROTO:=git
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Prepare/lua-nginx
|
|
||||||
$(eval $(call Download,lua-nginx))
|
|
||||||
gzip -dc $(DL_DIR)/$(FILE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
|
|
||||||
$(call PatchDir,$(PKG_BUILD_DIR),./patches-lua-nginx)
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,nginx))
|
|
@ -1,24 +0,0 @@
|
|||||||
#!/bin/sh /etc/rc.common
|
|
||||||
# Copyright (C) 2009-2012 OpenWrt.org
|
|
||||||
|
|
||||||
START=50
|
|
||||||
NGINX_BIN=/usr/sbin/nginx
|
|
||||||
|
|
||||||
start() {
|
|
||||||
mkdir -p /var/log/nginx
|
|
||||||
mkdir -p /var/lib/nginx
|
|
||||||
$NGINX_BIN
|
|
||||||
}
|
|
||||||
|
|
||||||
stop() {
|
|
||||||
$NGINX_BIN -s stop
|
|
||||||
}
|
|
||||||
|
|
||||||
reload() {
|
|
||||||
$NGINX_BIN -s reload
|
|
||||||
}
|
|
||||||
|
|
||||||
shutdown() {
|
|
||||||
$NGINX_BIN -s quit
|
|
||||||
}
|
|
||||||
|
|
@ -1,21 +0,0 @@
|
|||||||
--- a/lua-nginx/config
|
|
||||||
+++ b/lua-nginx/config
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
ngx_feature="Lua library"
|
|
||||||
-ngx_feature_libs="-llua -lm"
|
|
||||||
+ngx_feature_libs="-llua -lm -ldl"
|
|
||||||
ngx_feature_name=
|
|
||||||
ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <lauxlib.h>"
|
|
||||||
@@ -47,9 +47,9 @@ else
|
|
||||||
ngx_feature="Lua library in $LUA_LIB and $LUA_INC (specified by the LUA_LIB and LUA_INC env)"
|
|
||||||
ngx_feature_path="$LUA_INC"
|
|
||||||
if [ $NGX_RPATH = YES ]; then
|
|
||||||
- ngx_feature_libs="-R$LUA_LIB -L$LUA_LIB -llua -lm"
|
|
||||||
+ ngx_feature_libs="-R$LUA_LIB -L$LUA_LIB -llua -lm -ldl"
|
|
||||||
else
|
|
||||||
- ngx_feature_libs="-L$LUA_LIB -llua -lm"
|
|
||||||
+ ngx_feature_libs="-L$LUA_LIB -llua -lm -ldl"
|
|
||||||
fi
|
|
||||||
|
|
||||||
. auto/feature
|
|
@ -1,107 +0,0 @@
|
|||||||
--- a/auto/cc/name
|
|
||||||
+++ b/auto/cc/name
|
|
||||||
@@ -7,7 +7,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
|
|
||||||
|
|
||||||
ngx_feature="C compiler"
|
|
||||||
ngx_feature_name=
|
|
||||||
- ngx_feature_run=yes
|
|
||||||
+ ngx_feature_run=
|
|
||||||
ngx_feature_incs=
|
|
||||||
ngx_feature_path=
|
|
||||||
ngx_feature_libs=
|
|
||||||
--- a/auto/cc/conf
|
|
||||||
+++ b/auto/cc/conf
|
|
||||||
@@ -155,7 +155,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
|
|
||||||
else
|
|
||||||
ngx_feature="C99 variadic macros"
|
|
||||||
ngx_feature_name="NGX_HAVE_C99_VARIADIC_MACROS"
|
|
||||||
- ngx_feature_run=yes
|
|
||||||
+ ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <stdio.h>
|
|
||||||
#define var(dummy, ...) sprintf(__VA_ARGS__)"
|
|
||||||
ngx_feature_path=
|
|
||||||
@@ -169,7 +169,7 @@ if [ "$NGX_PLATFORM" != win32 ]; then
|
|
||||||
|
|
||||||
ngx_feature="gcc variadic macros"
|
|
||||||
ngx_feature_name="NGX_HAVE_GCC_VARIADIC_MACROS"
|
|
||||||
- ngx_feature_run=yes
|
|
||||||
+ ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <stdio.h>
|
|
||||||
#define var(dummy, args...) sprintf(args)"
|
|
||||||
ngx_feature_path=
|
|
||||||
--- a/auto/os/linux
|
|
||||||
+++ b/auto/os/linux
|
|
||||||
@@ -48,7 +48,7 @@ fi
|
|
||||||
|
|
||||||
ngx_feature="epoll"
|
|
||||||
ngx_feature_name="NGX_HAVE_EPOLL"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/epoll.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
ngx_feature_libs=
|
|
||||||
@@ -73,7 +73,7 @@ fi
|
|
||||||
CC_AUX_FLAGS="$cc_aux_flags -D_GNU_SOURCE"
|
|
||||||
ngx_feature="sendfile()"
|
|
||||||
ngx_feature_name="NGX_HAVE_SENDFILE"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/sendfile.h>
|
|
||||||
#include <errno.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
@@ -94,7 +94,7 @@ fi
|
|
||||||
CC_AUX_FLAGS="$cc_aux_flags -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64"
|
|
||||||
ngx_feature="sendfile64()"
|
|
||||||
ngx_feature_name="NGX_HAVE_SENDFILE64"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/sendfile.h>
|
|
||||||
#include <errno.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
@@ -112,7 +112,7 @@ ngx_include="sys/prctl.h"; . auto/includ
|
|
||||||
|
|
||||||
ngx_feature="prctl(PR_SET_DUMPABLE)"
|
|
||||||
ngx_feature_name="NGX_HAVE_PR_SET_DUMPABLE"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/prctl.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
ngx_feature_libs=
|
|
||||||
--- a/auto/unix
|
|
||||||
+++ b/auto/unix
|
|
||||||
@@ -618,7 +618,7 @@ ngx_feature_test="void *p; p = memalign(
|
|
||||||
|
|
||||||
ngx_feature="mmap(MAP_ANON|MAP_SHARED)"
|
|
||||||
ngx_feature_name="NGX_HAVE_MAP_ANON"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/mman.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
ngx_feature_libs=
|
|
||||||
@@ -631,7 +631,7 @@ ngx_feature_test="void *p;
|
|
||||||
|
|
||||||
ngx_feature='mmap("/dev/zero", MAP_SHARED)'
|
|
||||||
ngx_feature_name="NGX_HAVE_MAP_DEVZERO"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/mman.h>
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#include <fcntl.h>"
|
|
||||||
@@ -646,7 +646,7 @@ ngx_feature_test='void *p; int fd;
|
|
||||||
|
|
||||||
ngx_feature="System V shared memory"
|
|
||||||
ngx_feature_name="NGX_HAVE_SYSVSHM"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <sys/ipc.h>
|
|
||||||
#include <sys/shm.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
@@ -660,7 +660,7 @@ ngx_feature_test="int id;
|
|
||||||
|
|
||||||
ngx_feature="POSIX semaphores"
|
|
||||||
ngx_feature_name="NGX_HAVE_POSIX_SEM"
|
|
||||||
-ngx_feature_run=yes
|
|
||||||
+ngx_feature_run=no
|
|
||||||
ngx_feature_incs="#include <semaphore.h>"
|
|
||||||
ngx_feature_path=
|
|
||||||
ngx_feature_libs=
|
|
@ -1,26 +0,0 @@
|
|||||||
--- a/auto/types/sizeof
|
|
||||||
+++ b/auto/types/sizeof
|
|
||||||
@@ -25,8 +25,13 @@ $NGX_INCLUDE_UNISTD_H
|
|
||||||
$NGX_INCLUDE_INTTYPES_H
|
|
||||||
$NGX_INCLUDE_AUTO_CONFIG_H
|
|
||||||
|
|
||||||
+char object_code_block[] = {
|
|
||||||
+ '\n', 'e', '4', 'V', 'A',
|
|
||||||
+ '0', 'x', ('0' + sizeof($ngx_type)),
|
|
||||||
+ 'Y', '3', 'p', 'M', '\n'
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
int main() {
|
|
||||||
- printf("%d", (int) sizeof($ngx_type));
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -40,7 +45,7 @@ eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&
|
|
||||||
|
|
||||||
|
|
||||||
if [ -x $NGX_AUTOTEST ]; then
|
|
||||||
- ngx_size=`$NGX_AUTOTEST`
|
|
||||||
+ ngx_size=`sed -ne 's/^e4VA0x\(.\)Y3pM$/\1/p' < $NGX_AUTOTEST`
|
|
||||||
echo " $ngx_size bytes"
|
|
||||||
fi
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
--- a/src/os/unix/ngx_errno.c
|
|
||||||
+++ b/src/os/unix/ngx_errno.c
|
|
||||||
@@ -8,6 +8,9 @@
|
|
||||||
#include <ngx_config.h>
|
|
||||||
#include <ngx_core.h>
|
|
||||||
|
|
||||||
+#ifndef NGX_SYS_NERR
|
|
||||||
+#define NGX_SYS_NERR 128
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
/*
|
|
||||||
* The strerror() messages are copied because:
|
|
@ -1,18 +0,0 @@
|
|||||||
--- a/conf/nginx.conf
|
|
||||||
+++ b/conf/nginx.conf
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
|
|
||||||
-#user nobody;
|
|
||||||
+user nobody nogroup;
|
|
||||||
worker_processes 1;
|
|
||||||
|
|
||||||
#error_log logs/error.log;
|
|
||||||
@@ -16,7 +16,7 @@ events {
|
|
||||||
|
|
||||||
http {
|
|
||||||
include mime.types;
|
|
||||||
- default_type application/octet-stream;
|
|
||||||
+ #default_type application/octet-stream;
|
|
||||||
|
|
||||||
#log_format main '$remote_addr - $remote_user [$time_local] "$request" '
|
|
||||||
# '$status $body_bytes_sent "$http_referer" '
|
|
@ -1,33 +0,0 @@
|
|||||||
--- a/auto/endianness
|
|
||||||
+++ b/auto/endianness
|
|
||||||
@@ -21,7 +21,7 @@ int main() {
|
|
||||||
|
|
||||||
END
|
|
||||||
|
|
||||||
-ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS \
|
|
||||||
+ngx_test="$CC $NGX_CC_OPT $CC_TEST_FLAGS $CC_AUX_FLAGS \
|
|
||||||
-o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_LD_OPT $ngx_feature_libs"
|
|
||||||
|
|
||||||
eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1"
|
|
||||||
--- a/auto/feature
|
|
||||||
+++ b/auto/feature
|
|
||||||
@@ -39,7 +39,7 @@ int main() {
|
|
||||||
END
|
|
||||||
|
|
||||||
|
|
||||||
-ngx_test="$CC $CC_TEST_FLAGS $CC_AUX_FLAGS $ngx_feature_inc_path \
|
|
||||||
+ngx_test="$CC $NGX_CC_OPT $CC_TEST_FLAGS $CC_AUX_FLAGS $ngx_feature_inc_path \
|
|
||||||
-o $NGX_AUTOTEST $NGX_AUTOTEST.c $NGX_TEST_LD_OPT $ngx_feature_libs"
|
|
||||||
|
|
||||||
ngx_feature_inc_path=
|
|
||||||
--- a/auto/include
|
|
||||||
+++ b/auto/include
|
|
||||||
@@ -27,7 +27,7 @@ int main() {
|
|
||||||
END
|
|
||||||
|
|
||||||
|
|
||||||
-ngx_test="$CC -o $NGX_AUTOTEST $NGX_AUTOTEST.c"
|
|
||||||
+ngx_test="$CC $NGX_CC_OPT -o $NGX_AUTOTEST $NGX_AUTOTEST.c"
|
|
||||||
|
|
||||||
eval "$ngx_test >> $NGX_AUTOCONF_ERR 2>&1"
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user