[Packages] net/dansguardian: Fix compilation
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10530 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
962ac1f115
commit
ef94e80ccb
@ -4,7 +4,7 @@
|
|||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
# $Id: $
|
# $Id$
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
@ -14,16 +14,15 @@ PKG_RELEASE:=1
|
|||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Beta
|
PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Beta
|
||||||
PKG_MD5SUM:=
|
PKG_MD5SUM:=7877ee4d34df6ac538e6522755cedaf6
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_FIXUP = libtool
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/dansguardian
|
define Package/dansguardian
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
DEPENDS:=+libpthread +uclibcxx
|
DEPENDS:=+libpthread +uclibcxx +zlib
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
TITLE:=DansGuardian
|
TITLE:=DansGuardian
|
||||||
URL:=http://dansguardian.org
|
URL:=http://dansguardian.org
|
||||||
@ -40,13 +39,13 @@ CONFIGURE_VARS += \
|
|||||||
LDFLAGS="$$$$LDFLAGS" \
|
LDFLAGS="$$$$LDFLAGS" \
|
||||||
LIBS="-nodefaultlibs -luClibc++ -lpthread" \
|
LIBS="-nodefaultlibs -luClibc++ -lpthread" \
|
||||||
|
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(call Build/Configure/Default,\
|
$(call Build/Configure/Default,\
|
||||||
--disable-clamav \
|
--disable-clamav \
|
||||||
--with-sysconfsubdir=dansguardian \
|
--with-sysconfsubdir=dansguardian \
|
||||||
--with-proxyuser=root \
|
--with-proxyuser=root \
|
||||||
--with-proxygroup=root \
|
--with-proxygroup=root \
|
||||||
|
--disable-pcre \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -1,5 +1,7 @@
|
|||||||
--- dansguardian-2.9.9.2/configure 2007-11-13 17:17:03.000000000 +0100
|
Index: dansguardian-2.9.9.2/configure
|
||||||
+++ dansguardian-2.9.9.2.new/configure 2008-02-21 11:15:07.000000000 +0100
|
===================================================================
|
||||||
|
--- dansguardian-2.9.9.2.orig/configure 2008-02-27 17:52:06.000000000 +0100
|
||||||
|
+++ dansguardian-2.9.9.2/configure 2008-02-27 17:52:06.000000000 +0100
|
||||||
@@ -799,7 +799,7 @@
|
@@ -799,7 +799,7 @@
|
||||||
sharedstatedir='${prefix}/com'
|
sharedstatedir='${prefix}/com'
|
||||||
localstatedir='${prefix}/var'
|
localstatedir='${prefix}/var'
|
||||||
|
Loading…
x
Reference in New Issue
Block a user