[packages] libnids: update to 1.24
Signed-off-by: Peter Wagner <tripolar@gmx.at> git-svn-id: svn://svn.openwrt.org/openwrt/packages@38708 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
57805c0015
commit
f159ae4c02
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libnids
|
||||
PKG_VERSION:=1.18
|
||||
PKG_VERSION:=1.24
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.packetfactory.net/projects/libnids/dist/
|
||||
PKG_MD5SUM:=9ee6dcdfac97bae6fe611aa27d2594a5
|
||||
PKG_SOURCE_URL:=@SF/libnids
|
||||
PKG_MD5SUM:=72d37c79c85615ffe158aa524d649610
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -22,7 +22,7 @@ define Package/libnids
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libnet0
|
||||
TITLE:=A network intrusion detection library
|
||||
URL:=http://www.packetfactory.net/projects/libnids/
|
||||
URL:=http://libnids.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/libnids/description
|
||||
@ -36,6 +36,7 @@ define Build/Configure
|
||||
--enable-static \
|
||||
--with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
|
||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--disable-libglib \
|
||||
, \
|
||||
CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
|
||||
)
|
||||
|
@ -1,10 +1,9 @@
|
||||
diff -ruN libnids-1.18-orig/src/checksum.c libnids-1.18/src/checksum.c
|
||||
--- libnids-1.18-orig/src/checksum.c 2003-09-20 22:40:44.000000000 +0200
|
||||
+++ libnids-1.18/src/checksum.c 2005-08-09 23:55:00.000000000 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
#include <netinet/tcp.h>
|
||||
#include <netinet/udp.h>
|
||||
|
||||
--- a/src/checksum.c
|
||||
+++ b/src/checksum.c
|
||||
@@ -25,7 +25,7 @@ static int dontchksum(unsigned int ip)
|
||||
return 0;
|
||||
}
|
||||
|
||||
-#if ( __i386__ || __i386 )
|
||||
+#if 0
|
||||
// all asm procedures are copied from Linux 2.0.36 and 2.2.10 kernels
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -Nur libnids-1.18/configure libnids-1.18.patched/configure
|
||||
--- libnids-1.18/configure 2003-10-15 01:40:09.000000000 +0200
|
||||
+++ libnids-1.18.patched/configure 2005-06-09 12:37:42.000000000 +0200
|
||||
@@ -3253,7 +3253,7 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -3640,7 +3640,7 @@ presetting ac_cv_c_bigendian=no (or yes)
|
||||
esac
|
||||
|
||||
|
||||
@ -10,7 +9,7 @@ diff -Nur libnids-1.18/configure libnids-1.18.patched/configure
|
||||
|
||||
for ac_func in gettimeofday
|
||||
do
|
||||
@@ -3489,17 +3489,21 @@
|
||||
@@ -3917,17 +3917,21 @@ if test "${with_libpcap+set}" = set; the
|
||||
echo "${ECHO_T}no" >&6
|
||||
;;
|
||||
*)
|
||||
@ -38,7 +37,7 @@ diff -Nur libnids-1.18/configure libnids-1.18.patched/configure
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
@@ -3605,10 +3609,10 @@
|
||||
@@ -4399,10 +4403,10 @@ echo "${ECHO_T}no" >&6
|
||||
*)
|
||||
echo "$as_me:$LINENO: result: $withval" >&5
|
||||
echo "${ECHO_T}$withval" >&6
|
||||
@ -51,12 +50,12 @@ diff -Nur libnids-1.18/configure libnids-1.18.patched/configure
|
||||
LNETLIB="-L$withval/lib -lnet"
|
||||
elif test -f $withval/include/libnet.h -a -f $withval/src/libnet.a; then
|
||||
owd=`pwd`
|
||||
@@ -3861,7 +3865,7 @@
|
||||
else
|
||||
@@ -4684,7 +4688,7 @@ else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
cat conftest.$ac_ext >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
|
||||
-HAVE_BSD_UDPHDR=0
|
||||
+HAVE_BSD_UDPHDR=1
|
||||
fi
|
||||
rm -f conftest.$ac_objext conftest.$ac_ext
|
||||
rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user