Update shell-fm to 0.5 (#3614)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11956 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6671244b63
commit
f245b79cc0
@ -9,15 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shell-fm
|
||||
PKG_VERSION:=0.2
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://nex.scrapping.cc/shell-fm/downloads
|
||||
PKG_MD5SUM:=6ebbcf1af241a92a1237547fc39ca728
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
PKG_SOURCE_URL:=http://nex.scrapping.cc/code/shell-fm/downloads/
|
||||
PKG_MD5SUM:=a257283b0f7e9173ee1073b88e57c5f6
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -39,19 +36,20 @@ define Package/shell-fm/conffiles
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(PKG_BUILD_DIR)/reconfig
|
||||
$(call Build/Configure/Default, --disable-ao)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -I./include/ -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lmad -lao" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/shell-fm/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/shell-fm $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/shell-fm $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_DATA) ./files/shell-fm.rc $(1)/etc/shell-fm.rc
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
|
12
sound/shell-fm/patches/001-cross_compile.patch
Normal file
12
sound/shell-fm/patches/001-cross_compile.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN shell-fm-0.5/source/Makefile shell-fm-0.5.new/source/Makefile
|
||||
--- shell-fm-0.5/source/Makefile 2008-04-10 22:27:28.000000000 +0200
|
||||
+++ shell-fm-0.5.new/source/Makefile 2008-07-26 21:00:48.000000000 +0200
|
||||
@@ -9,7 +9,7 @@
|
||||
.PHONY: clean
|
||||
|
||||
shell-fm : $(OBJECT)
|
||||
- gcc -o $(BINARY) $(CFLAGS) $(OBJECT) $(shell pkg-config mad --libs) $(LDFLAGS)
|
||||
+ $(CC) -o $(BINARY) $(CFLAGS) $(OBJECT) $(shell pkg-config mad --libs) $(LDFLAGS)
|
||||
|
||||
clean :
|
||||
rm -f $(OBJECT) $(BINARY)
|
13
sound/shell-fm/patches/002-wifcontinued.patch
Normal file
13
sound/shell-fm/patches/002-wifcontinued.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- shell-fm-0.5/source/main.c 2008-04-10 22:27:28.000000000 +0200
|
||||
+++ shell-fm-0.5.new/source/main.c 2008-07-27 13:50:43.000000000 +0200
|
||||
@@ -33,6 +33,10 @@
|
||||
#define PATH_MAX 4096
|
||||
#endif
|
||||
|
||||
+#ifndef WIFCONTINUED
|
||||
+#define WIFCONTINUED(wstat) (0)
|
||||
+#endif
|
||||
+
|
||||
unsigned flags = RTP;
|
||||
time_t changeTime = 0, pausetime = 0;
|
||||
char * nextstation = NULL;
|
Loading…
x
Reference in New Issue
Block a user