libgd: moved to github
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@41468 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e54a90bc86
commit
f2d8ff0676
@ -1,77 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=gd
|
|
||||||
PKG_VERSION:=2.0.35
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=http://www.libgd.org/releases
|
|
||||||
PKG_MD5SUM:=6c6c3dbb7bf079e0bb5fbbfd3bb8a71c
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/libgd
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
DEPENDS:=+libjpeg +libpng
|
|
||||||
TITLE:=The GD graphics library
|
|
||||||
URL:=http://www.libgd.org/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libgd/description
|
|
||||||
GD is an open source code library for the dynamic creation of images by
|
|
||||||
programmers. GD creates PNG, JPEG and GIF images, among other formats.
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--disable-rpath \
|
|
||||||
--without-x \
|
|
||||||
--without-fontconfig \
|
|
||||||
--without-freetype \
|
|
||||||
--with-jpeg=$(STAGING_DIR)/usr \
|
|
||||||
--with-png=$(STAGING_DIR)/usr \
|
|
||||||
--without-xpm \
|
|
||||||
--without-iconv
|
|
||||||
|
|
||||||
CONFIGURE_VARS += \
|
|
||||||
LIBPNG12_CONFIG="$(STAGING_DIR)/host/bin/libpng12-config" \
|
|
||||||
ac_cv_header_iconv_h=no
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/gdlib-config $(1)/usr/bin/
|
|
||||||
$(SED) \
|
|
||||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
|
||||||
$(1)/usr/bin/gdlib-config
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/entities.h $(1)/usr/include/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/gd{,_io,cache,fontg,fontl,fontmb,fonts,fontt,fx}.h \
|
|
||||||
$(1)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.{a,la,so*} $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(2)/bin
|
|
||||||
$(LN) ../../usr/bin/gdlib-config $(2)/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libgd/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgd.so.* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libgd))
|
|
@ -1,30 +0,0 @@
|
|||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -61,7 +61,7 @@ fi
|
|
||||||
AC_HEADER_STDC
|
|
||||||
AC_CHECK_HEADERS([errno.h limits.h stddef.h stdlib.h string.h unistd.h])
|
|
||||||
|
|
||||||
-AM_ICONV
|
|
||||||
+m4_pattern_allow([AM_ICONV])
|
|
||||||
# if test -n "$LIBICONV" ; then
|
|
||||||
# LIBS="$LIBS $LIBICONV"
|
|
||||||
# fi
|
|
||||||
@@ -353,14 +353,14 @@ if test "$withval" != no; then
|
|
||||||
AC_PATH_PROG([LIBPNG12_CONFIG], [libpng12-config])
|
|
||||||
AC_PATH_PROG([LIBPNG_CONFIG], [libpng-config])
|
|
||||||
if test -n "$LIBPNG12_CONFIG"; then
|
|
||||||
- libpng_CPPFLAGS=`libpng12-config --cflags`
|
|
||||||
+ libpng_CPPFLAGS=`$LIBPNG12_CONFIG --cflags`
|
|
||||||
# should be --ldopts, but it's currently broken
|
|
||||||
- libpng_LDFLAGS=`libpng12-config --ldflags`
|
|
||||||
+ libpng_LDFLAGS=`$LIBPNG12_CONFIG --ldflags`
|
|
||||||
libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[[^ ]][[^ ]]*//g'`
|
|
||||||
elif test -n "$LIBPNG_CONFIG"; then
|
|
||||||
- libpng_CPPFLAGS=`libpng-config --cflags`
|
|
||||||
+ libpng_CPPFLAGS=`$LIBPNG_CONFIG --cflags`
|
|
||||||
# should be --ldopts, but it's currently broken
|
|
||||||
- libpng_LDFLAGS=`libpng-config --ldflags`
|
|
||||||
+ libpng_LDFLAGS=`$LIBPNG_CONFIG --ldflags`
|
|
||||||
libpng_LDFLAGS=`echo " $libpng_LDFLAGS" | sed 's/ -l[[^ ]][[^ ]]*//g'`
|
|
||||||
elif test -d "$withval"; then
|
|
||||||
libpng_CPPFLAGS="-I$withval/include"
|
|
@ -1,20 +0,0 @@
|
|||||||
--- a/config/gdlib-config.in
|
|
||||||
+++ b/config/gdlib-config.in
|
|
||||||
@@ -71,7 +71,7 @@ while test $# -gt 0; do
|
|
||||||
echo @LDFLAGS@
|
|
||||||
;;
|
|
||||||
--libs)
|
|
||||||
- echo @LIBS@ @LIBICONV@
|
|
||||||
+ echo @LIBS@
|
|
||||||
;;
|
|
||||||
--cflags|--includes)
|
|
||||||
echo -I@includedir@
|
|
||||||
@@ -84,7 +84,7 @@ while test $# -gt 0; do
|
|
||||||
echo "includedir: $includedir"
|
|
||||||
echo "cflags: -I@includedir@"
|
|
||||||
echo "ldflags: @LDFLAGS@"
|
|
||||||
- echo "libs: @LIBS@ @LIBICONV@"
|
|
||||||
+ echo "libs: @LIBS@"
|
|
||||||
echo "libdir: $libdir"
|
|
||||||
echo "features: @FEATURES@"
|
|
||||||
;;
|
|
Loading…
x
Reference in New Issue
Block a user