[packages] liboil: update to 0.3.17
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21023 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e9f9d08dcf
commit
f2ea40cd9b
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2007-2009 OpenWrt.org
|
# Copyright (C) 2007-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,14 +8,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=liboil
|
PKG_NAME:=liboil
|
||||||
PKG_VERSION:=0.3.16
|
PKG_VERSION:=0.3.17
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
|
PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
|
||||||
PKG_MD5SUM:=febb1d9f9bc4c440fcf622dc90f8b6b7
|
PKG_MD5SUM:=47dc734f82faeb2964d97771cfd2e701
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -35,20 +36,16 @@ define Package/liboil/description
|
|||||||
provided by modern CPUs (Altivec, MMX, SSE, etc.).
|
provided by modern CPUs (Altivec, MMX, SSE, etc.).
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--enable-shared \
|
--enable-shared \
|
||||||
--enable-static \
|
--enable-static \
|
||||||
|
|
||||||
|
TARGET_CFLAGS += $(FPIC)
|
||||||
|
|
||||||
# XXX: VFP_CFLAGS is set to '-mfpu=vfp' on arm by configure, but that breaks
|
# XXX: VFP_CFLAGS is set to '-mfpu=vfp' on arm by configure, but that breaks
|
||||||
# final linking stages, so override it until we find why
|
# final linking stages, so override it until we find why
|
||||||
define Build/Compile
|
MAKE_FLAGS += \
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
VFP_CFLAGS="" \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
VFP_CFLAGS="" \
|
|
||||||
all install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
$(INSTALL_DIR) $(1)/usr/include
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -270,7 +270,7 @@ sys_symbol_underscore = @sys_symbol_unde
|
@@ -278,7 +278,7 @@ top_build_prefix = @top_build_prefix@
|
||||||
sysconfdir = @sysconfdir@
|
top_builddir = @top_builddir@
|
||||||
target_alias = @target_alias@
|
top_srcdir = @top_srcdir@
|
||||||
AUTOMAKE_OPTIONS = foreign
|
AUTOMAKE_OPTIONS = foreign
|
||||||
-SUBDIRS = liboil testsuite examples doc
|
-SUBDIRS = liboil testsuite examples doc
|
||||||
+SUBDIRS = liboil testsuite
|
+SUBDIRS = liboil testsuite
|
||||||
|
Loading…
x
Reference in New Issue
Block a user