newt: fix compile errors caused by using the wrong ar util
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32424 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0bdf4156da
commit
f3032f48de
@ -51,6 +51,8 @@ CONFIGURE_ARGS += \
|
|||||||
--without-tcl \
|
--without-tcl \
|
||||||
--without-gpm-support
|
--without-gpm-support
|
||||||
|
|
||||||
|
MAKE_FLAGS += AR="$(TARGET_CROSS)ar"
|
||||||
|
|
||||||
define Package/libnewt/install
|
define Package/libnewt/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_BUILD_DIR)/libnewt.so* $(1)/usr/lib/
|
$(CP) $(PKG_BUILD_DIR)/libnewt.so* $(1)/usr/lib/
|
||||||
|
@ -1,15 +1,16 @@
|
|||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -4,7 +4,7 @@ LIBTCL = -ltcl8.4
|
@@ -4,7 +4,8 @@ LIBTCL = -ltcl8.4
|
||||||
CC = @CC@
|
CC = @CC@
|
||||||
CPP = @CPP@
|
CPP = @CPP@
|
||||||
CFLAGS = @CFLAGS@
|
CFLAGS = @CFLAGS@
|
||||||
-CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@
|
-CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@
|
||||||
|
+AR ?= ar
|
||||||
+CPPFLAGS = -D_GNU_SOURCE @CPPFLAGS@
|
+CPPFLAGS = -D_GNU_SOURCE @CPPFLAGS@
|
||||||
|
|
||||||
SHLIBFLAGS= -Wl,--version-script,newt.0.52.ver
|
SHLIBFLAGS= -Wl,--version-script,newt.0.52.ver
|
||||||
VERSION = @VERSION@
|
VERSION = @VERSION@
|
||||||
@@ -53,19 +53,19 @@ endif
|
@@ -53,19 +54,19 @@ endif
|
||||||
all: $(TARGET) _snackmodule.so
|
all: $(TARGET) _snackmodule.so
|
||||||
|
|
||||||
test: test.o $(LIBNEWT)
|
test: test.o $(LIBNEWT)
|
||||||
@ -34,7 +35,7 @@
|
|||||||
|
|
||||||
_snackmodule.so: snackmodule.c $(LIBNEWTSH)
|
_snackmodule.so: snackmodule.c $(LIBNEWTSH)
|
||||||
for ver in $(PYTHONVERS) ; do \
|
for ver in $(PYTHONVERS) ; do \
|
||||||
@@ -76,7 +76,7 @@ _snackmodule.so: snackmodule.c $(LIBNE
|
@@ -76,13 +77,13 @@ _snackmodule.so: snackmodule.c $(LIBNE
|
||||||
touch $@
|
touch $@
|
||||||
|
|
||||||
whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
|
whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
|
||||||
@ -43,7 +44,14 @@
|
|||||||
|
|
||||||
whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
|
whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
|
||||||
$(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lpopt
|
$(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lpopt
|
||||||
@@ -102,12 +102,12 @@ $(SHAREDDIR):
|
|
||||||
|
$(LIBNEWT): $(LIBOBJS)
|
||||||
|
- ar rv $@ $^
|
||||||
|
+ $(AR) rv $@ $^
|
||||||
|
|
||||||
|
newt.o $(SHAREDDIR)/newt.o: newt.c Makefile
|
||||||
|
|
||||||
|
@@ -102,12 +103,12 @@ $(SHAREDDIR):
|
||||||
sharedlib: $(LIBNEWTSH)
|
sharedlib: $(LIBNEWTSH)
|
||||||
|
|
||||||
$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
|
$(LIBNEWTSH): $(SHAREDDIR) $(SHAREDOBJS)
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -50,7 +50,7 @@ else
|
@@ -51,7 +51,7 @@ else
|
||||||
TARGET=depend $(PROGS)
|
TARGET=depend $(PROGS)
|
||||||
endif
|
endif
|
||||||
|
|
||||||
@ -9,7 +9,7 @@
|
|||||||
|
|
||||||
test: test.o $(LIBNEWT)
|
test: test.o $(LIBNEWT)
|
||||||
$(CC) $(CFLAGS) -g -o test test.o $(LIBNEWT) $(LIBS)
|
$(CC) $(CFLAGS) -g -o test test.o $(LIBNEWT) $(LIBS)
|
||||||
@@ -67,14 +67,6 @@ showchars: showchars.o $(LIBNEWT)
|
@@ -68,14 +68,6 @@ showchars: showchars.o $(LIBNEWT)
|
||||||
showkey: showkey.o $(LIBNEWT)
|
showkey: showkey.o $(LIBNEWT)
|
||||||
$(CC) $(CFLAGS) -g -o showkey showkey.o $(LIBNEWT) $(LIBS)
|
$(CC) $(CFLAGS) -g -o showkey showkey.o $(LIBNEWT) $(LIBS)
|
||||||
|
|
||||||
@ -24,7 +24,7 @@
|
|||||||
whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
|
whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
|
||||||
$(CC) $(CFLAGS) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
|
$(CC) $(CFLAGS) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
|
||||||
|
|
||||||
@@ -121,17 +113,12 @@ install: $(LIBNEWT) install-sh whiptail
|
@@ -122,17 +114,12 @@ install: $(LIBNEWT) install-sh whiptail
|
||||||
make -C po datadir=$(instroot)/$(datadir) install
|
make -C po datadir=$(instroot)/$(datadir) install
|
||||||
install -m 644 -D libnewt.pc $(instroot)/$(pkgconfigdir)/libnewt.pc
|
install -m 644 -D libnewt.pc $(instroot)/$(pkgconfigdir)/libnewt.pc
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user