[packages] psmisc: update to 22.13
* drop obsolete patch * add killall preinst/postrm * use better upstream url * use PKG_INSTALL git-svn-id: svn://svn.openwrt.org/openwrt/packages@24881 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d532b9c507
commit
f32faa0672
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,14 +8,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=psmisc
|
PKG_NAME:=psmisc
|
||||||
PKG_VERSION:=22.12
|
PKG_VERSION:=22.13
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/psmisc
|
PKG_SOURCE_URL:=@SF/psmisc
|
||||||
PKG_MD5SUM:=16c83a351c292cfc845b27d6395e05fb
|
PKG_MD5SUM:=e2c339e6b65b730042084023784a729e
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -24,7 +25,7 @@ define Package/psmisc
|
|||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
DEPENDS:=+libncurses
|
DEPENDS:=+libncurses
|
||||||
TITLE:=proc utilities
|
TITLE:=proc utilities
|
||||||
URL:=http://sourceforge.net/projects/psmisc/
|
URL:=http://psmisc.sourceforge.net/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/psmisc/description
|
define Package/psmisc/description
|
||||||
@ -37,13 +38,25 @@ MAKE_FLAGS += \
|
|||||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||||
|
|
||||||
|
define Package/psmisc/preinst
|
||||||
|
#!/bin/sh
|
||||||
|
if [ -e $${IPKG_INSTROOT}/usr/bin/killall ]; then
|
||||||
|
rm $${IPKG_INSTROOT}/usr/bin/killall;
|
||||||
|
fi
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/psmisc/install
|
define Package/psmisc/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fuser $(1)/usr/sbin/
|
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/killall $(1)/usr/sbin
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/pstree $(1)/usr/bin
|
$(INSTALL_BIN) \
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/prtstat $(1)/usr/bin
|
$(PKG_INSTALL_DIR)/usr/bin/{fuser,killall,prtstat,pstree} \
|
||||||
|
$(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/psmisc/postrm
|
||||||
|
#!/bin/sh
|
||||||
|
ln -sf ../../bin/busybox $${IPKG_INSTROOT}/usr/bin/killall
|
||||||
|
$${IPKG_INSTROOT}/usr/bin/killall 2>&1 | grep 'applet not found' > /dev/null 2>&1 && rm $${IPKG_INSTROOT}/usr/bin/killall
|
||||||
|
exit 0
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,psmisc))
|
$(eval $(call BuildPackage,psmisc))
|
||||||
|
@ -1,55 +0,0 @@
|
|||||||
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
dnl Process this file with autoconf to produce a configure script.
|
|
||||||
AC_PREREQ(2.61)
|
|
||||||
-AC_INIT([psmisc],[22.12])
|
|
||||||
+AC_INIT([psmisc],[22.12])
|
|
||||||
AC_CONFIG_SRCDIR([src/comm.h])
|
|
||||||
AC_CONFIG_HEADER([config.h])
|
|
||||||
AC_CONFIG_AUX_DIR([config])
|
|
||||||
@@ -56,6 +56,12 @@ AC_TYPE_PID_T
|
|
||||||
AC_TYPE_SIZE_T
|
|
||||||
AC_CHECK_MEMBERS([struct stat.st_rdev])
|
|
||||||
AC_TYPE_UID_T
|
|
||||||
+
|
|
||||||
+dnl Check for language stuff
|
|
||||||
+AM_GNU_GETTEXT([external])
|
|
||||||
+AM_GNU_GETTEXT_VERSION([0.16.1])
|
|
||||||
+
|
|
||||||
+dnl Must be after the gettext stuff as it sets build_cpu
|
|
||||||
AC_CHECK_MEMBERS([struct user_regs_struct.orig_eax,
|
|
||||||
struct user_regs_struct.eax,
|
|
||||||
struct user_regs_struct.ebx,
|
|
||||||
@@ -66,11 +72,13 @@ AC_CHECK_MEMBERS([struct user_regs_struct.orig_eax,
|
|
||||||
struct user_regs_struct.rdi,
|
|
||||||
struct user_regs_struct.rsi,
|
|
||||||
struct user_regs_struct.rdx], [],[],
|
|
||||||
- [#include <sys/user.h>])
|
|
||||||
+ [#include <bits/types.h>
|
|
||||||
+ #include <sys/user.h>])
|
|
||||||
AC_CHECK_MEMBERS([struct pt_regs.orig_gpr3,
|
|
||||||
struct pt_regs.gpr], [],[], [#include <linux/ptrace.h>])
|
|
||||||
AC_CHECK_MEMBERS([struct pt_regs.uregs],[],[], [#include <asm/ptrace.h>])
|
|
||||||
-AC_CHECK_MEMBERS([struct pt_regs.regs],[],[], [#include <asm/ptrace.h>])
|
|
||||||
+AC_CHECK_MEMBERS([struct pt_regs.regs,
|
|
||||||
+ struct pt_regs.cp0_status],[],[], [#include <asm/ptrace.h>])
|
|
||||||
|
|
||||||
AM_CONDITIONAL(WANT_PEEKFD_I386,
|
|
||||||
test $ac_cv_member_struct_user_regs_struct_orig_eax = yes &&
|
|
||||||
@@ -90,11 +98,9 @@ AM_CONDITIONAL(WANT_PEEKFD_PPC,
|
|
||||||
AM_CONDITIONAL(WANT_PEEKFD_ARM,
|
|
||||||
test $ac_cv_member_struct_pt_regs_uregs = yes)
|
|
||||||
AM_CONDITIONAL(WANT_PEEKFD_MIPS,
|
|
||||||
- test $ac_cv_member_struct_pt_regs_regs = yes)
|
|
||||||
-
|
|
||||||
-dnl Check for language stuff
|
|
||||||
-AM_GNU_GETTEXT([external])
|
|
||||||
-AM_GNU_GETTEXT_VERSION([0.16.1])
|
|
||||||
+ test $build_cpu = mipsel &&
|
|
||||||
+ test $ac_cv_member_struct_pt_regs_regs = yes &&
|
|
||||||
+ test $ac_cv_member_struct_pt_regs_cp0_status = yes)
|
|
||||||
|
|
||||||
dnl Checks for library functions.
|
|
||||||
AC_FUNC_CLOSEDIR_VOID
|
|
Loading…
x
Reference in New Issue
Block a user