Update bahamut to 1.8.4 (#3609)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11716 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cdcfafdf93
commit
f371fc8e5d
@ -9,9 +9,9 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bahamut
|
||||
PKG_VERSION:=1.8.3
|
||||
PKG_VERSION:=1.8.4
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=2e782fe99656433ca24f6a9832d9aad5
|
||||
PKG_MD5SUM:=6b9a805f4408f3887e75a9d14c69ab93
|
||||
|
||||
PKG_SOURCE_URL:=http://bahamut.dal.net/download/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-release.tar.gz
|
||||
|
@ -1,19 +1,5 @@
|
||||
diff -urN bahamut-1.8.3/configure bahamut-1.8.3.new/configure
|
||||
--- bahamut-1.8.3/configure 2004-09-28 08:44:22.000000000 +0200
|
||||
+++ bahamut-1.8.3.new/configure 2006-04-02 19:37:57.000000000 +0200
|
||||
@@ -6197,8 +6197,7 @@
|
||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&5
|
||||
echo "$as_me: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+See \`config.log' for more details." >&2;} }
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
diff -urN bahamut-1.8.3/Makefile.in bahamut-1.8.3.new/Makefile.in
|
||||
--- bahamut-1.8.3/Makefile.in 2004-08-10 03:27:03.000000000 +0200
|
||||
+++ bahamut-1.8.3.new/Makefile.in 2006-04-02 21:57:43.000000000 +0200
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -23,8 +23,8 @@
|
||||
ENGINE=@SENGINE@
|
||||
|
||||
@ -25,9 +11,20 @@ diff -urN bahamut-1.8.3/Makefile.in bahamut-1.8.3.new/Makefile.in
|
||||
CLEANSUBDIRS=src tools
|
||||
|
||||
CC=@CC@
|
||||
diff -urN bahamut-1.8.3/src/Makefile.in bahamut-1.8.3.new/src/Makefile.in
|
||||
--- bahamut-1.8.3/src/Makefile.in 2004-09-24 06:24:10.000000000 +0200
|
||||
+++ bahamut-1.8.3.new/src/Makefile.in 2006-04-02 22:00:34.000000000 +0200
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -6197,8 +6197,7 @@
|
||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&5
|
||||
echo "$as_me: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+See \`config.log' for more details." >&2;} }
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -1,8 +1,8 @@
|
||||
CC=@CC@
|
||||
RM=@RM@
|
||||
@ -51,19 +48,18 @@ diff -urN bahamut-1.8.3/src/Makefile.in bahamut-1.8.3.new/src/Makefile.in
|
||||
+RES_SRC = res_mkquery.c res_init.c res_comp.c
|
||||
|
||||
SOURCES = blalloc.c bsd.c channel.c clientlist.c clones.c confparse.c \
|
||||
fdlist.c fds.c hash.c hide.c inet_addr.c ircd.c ircsprintf.c list.c \
|
||||
fdlist.c fds.c hash.c hide.c inet_addr.c ircd.c ircsprintf.c \
|
||||
@@ -22,7 +22,7 @@
|
||||
modules.c packet.c parse.c pcre.c res.c s_auth.c s_bsd.c s_conf.c \
|
||||
s_debug.c s_err.c s_misc.c s_numeric.c s_serv.c s_user.c sbuf.c \
|
||||
scache.c send.c struct.c support.c throttle.c userban.c whowas.c \
|
||||
- zlink.c \
|
||||
+ zlink.c $(RES_SRC) \
|
||||
m_who.c match.c memcount.c modules.c packet.c parse.c pcre.c \
|
||||
probability.c res.c s_auth.c s_bsd.c s_conf.c s_debug.c s_err.c \
|
||||
s_misc.c s_numeric.c s_serv.c s_user.c sbuf.c scache.c send.c \
|
||||
- struct.c support.c throttle.c userban.c whowas.c zlink.c \
|
||||
+ struct.c support.c throttle.c userban.c whowas.c zlink.c $(RES_SRC) \
|
||||
$(ENGINE) $(CRYPTO)
|
||||
|
||||
OBJECTS = $(SOURCES:.c=.o) version.o
|
||||
diff -urN bahamut-1.8.3/src/res_comp.c bahamut-1.8.3.new/src/res_comp.c
|
||||
--- bahamut-1.8.3/src/res_comp.c 2001-07-07 00:26:33.000000000 +0200
|
||||
+++ bahamut-1.8.3.new/src/res_comp.c 2006-04-02 21:56:10.000000000 +0200
|
||||
--- a/src/res_comp.c
|
||||
+++ b/src/res_comp.c
|
||||
@@ -231,7 +231,7 @@
|
||||
* the first name on the list, not the pointer to the start of the
|
||||
* message.
|
||||
@ -73,12 +69,11 @@ diff -urN bahamut-1.8.3/src/res_comp.c bahamut-1.8.3.new/src/res_comp.c
|
||||
u_char **lastdnptr)
|
||||
{
|
||||
u_char *dn, *cp, **cpp;
|
||||
diff -urN bahamut-1.8.3/zlib/Makefile.in bahamut-1.8.3.new/zlib/Makefile.in
|
||||
--- bahamut-1.8.3/zlib/Makefile.in 2004-08-24 00:57:02.000000000 +0200
|
||||
+++ bahamut-1.8.3.new/zlib/Makefile.in 2006-04-02 19:38:11.000000000 +0200
|
||||
@@ -70,7 +70,7 @@
|
||||
fi
|
||||
--- a/zlib/Makefile.in
|
||||
+++ b/zlib/Makefile.in
|
||||
@@ -69,7 +69,7 @@
|
||||
|
||||
build: libz.a
|
||||
libz.a: $(OBJS) $(OBJA)
|
||||
- $(AR) $@ $(OBJS) $(OBJA)
|
||||
+ $(AR) rcv $@ $(OBJS) $(OBJA)
|
||||
|
Loading…
x
Reference in New Issue
Block a user