[Packages] bmon:

* Fix compilation
 * Cleanup Makefile
 * Refresh patch

git-svn-id: svn://svn.openwrt.org/openwrt/packages@9585 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2007-11-20 16:27:56 +00:00
parent 2cf67dcc6f
commit f39633e5f3
2 changed files with 17 additions and 21 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006 OpenWrt.org
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -10,14 +10,12 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=bmon
PKG_VERSION:=2.1.0
PKG_RELEASE:=0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://people.suug.ch/~tgr/bmon/files/
PKG_MD5SUM:=3111a027907016c0902d67350c619df6
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/bmon
@ -35,18 +33,14 @@ define Package/bmon/description
input methods for different architectures.
endef
define Build/Configure
$(call Build/Configure/Default, \
--disable-cnt-workaround \
--disable-dbi \
--disable-rrd \
--disable-asound \
)
endef
CONFIGURE_ARGS += \
--disable-cnt-workaround \
--disable-dbi \
--disable-rrd \
--disable-asound \
define Build/Compile
$(call Build/Compile/Default,all)
endef
CONFIGURE_VARS += \
ac_cv_lib_nl_nl_connect=no \
define Package/bmon/install
$(INSTALL_DIR) $(1)/usr/sbin

View File

@ -1,6 +1,7 @@
diff -ruN bmon-2.1.0-old/src/out_audio.c bmon-2.1.0-new/src/out_audio.c
--- bmon-2.1.0-old/src/out_audio.c 2005-04-05 17:01:33.000000000 +0200
+++ bmon-2.1.0-new/src/out_audio.c 2006-10-09 23:11:44.000000000 +0200
Index: bmon-2.1.0/src/out_audio.c
===================================================================
--- bmon-2.1.0.orig/src/out_audio.c 2007-11-20 17:25:54.000000000 +0100
+++ bmon-2.1.0/src/out_audio.c 2007-11-20 17:25:54.000000000 +0100
@@ -141,7 +141,7 @@
.om_draw = audio_draw,
.om_set_opts = audio_set_opts,
@ -10,9 +11,10 @@ diff -ruN bmon-2.1.0-old/src/out_audio.c bmon-2.1.0-new/src/out_audio.c
};
static void __init audio_init(void)
diff -ruN bmon-2.1.0-old/src/out_xml_event.c bmon-2.1.0-new/src/out_xml_event.c
--- bmon-2.1.0-old/src/out_xml_event.c 2005-04-05 17:01:33.000000000 +0200
+++ bmon-2.1.0-new/src/out_xml_event.c 2006-10-09 23:11:59.000000000 +0200
Index: bmon-2.1.0/src/out_xml_event.c
===================================================================
--- bmon-2.1.0.orig/src/out_xml_event.c 2007-11-20 17:25:54.000000000 +0100
+++ bmon-2.1.0/src/out_xml_event.c 2007-11-20 17:25:54.000000000 +0100
@@ -127,7 +127,7 @@
.om_draw = xml_event_draw,
.om_set_opts = xml_event_set_opts,