[packages] vsftpd: override LDFLAGS as well to avoid -fpic requirement, refresh patches (#11263)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@31241 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-04-10 14:54:07 +00:00
parent 0dd954b2ce
commit f44fb45149
4 changed files with 7 additions and 6 deletions

View File

@ -34,6 +34,7 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
vsftpd
endef

View File

@ -1,7 +1,7 @@
--- a/Makefile
+++ b/Makefile
@@ -17,6 +17,8 @@ OBJS = main.o utility.o prelogin.o ftpcm
ssl.o sslslave.o ptracesandbox.o ftppolicy.o sysutil.o sysdeputil.o
@@ -22,6 +22,8 @@ OBJS = main.o utility.o prelogin.o ftpcm
seccompsandbox.o
+DESTDIR =
@ -9,8 +9,8 @@
.c.o:
$(CC) -c $*.c $(CFLAGS) $(IFLAGS)
@@ -24,21 +26,20 @@ vsftpd: $(OBJS)
$(CC) -o vsftpd $(OBJS) $(LINK) $(LIBS) $(LDFLAGS)
@@ -29,21 +31,20 @@ vsftpd: $(OBJS)
$(CC) -o vsftpd $(OBJS) $(LINK) $(LDFLAGS) $(LIBS)
install:
- if [ -x /usr/local/sbin ]; then \

View File

@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
@@ -8,8 +8,8 @@
@@ -8,8 +8,8 @@ CFLAGS = -O2 -fPIE -fstack-protector --p
-D_FORTIFY_SOURCE=2 \
#-pedantic -Wconversion

View File

@ -1,6 +1,6 @@
--- a/tunables.c
+++ b/tunables.c
@@ -250,7 +250,7 @@ tunables_load_defaults()
@@ -254,7 +254,7 @@ tunables_load_defaults()
/* -rw------- */
tunable_chown_upload_mode = 0600;