[package] cross-compile qc-set (#4554)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14442 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-02-08 13:03:05 +00:00
parent 1a7f53cddc
commit f5b97f21e5
2 changed files with 14 additions and 1 deletions

View File

@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=qc-usb
PKG_VERSION:=0.6.6
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/qce-ga
@ -73,6 +73,7 @@ endif
define Build/Compile/user
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS)" \
qcset
endef

View File

@ -0,0 +1,12 @@
diff -rupN original/Makefile new/Makefile
--- original/Makefile 2006-10-23 21:06:19.000000000 -0500
+++ new/Makefile 2009-02-03 08:57:20.000000000 -0600
@@ -183,7 +183,7 @@ install: $(MODULE_NAME)
-$(DEPMOD) -a
qcset: qcset.c quickcam.h
- gcc -Wall -O2 -s qcset.c -o qcset -lm
+ $(CC) -Wall -O2 -s qcset.c -o qcset -lm
.PHONY: patch
patch: kernel-patch kernel-files