[packages] iptraf: add patch to make iptraf recognize athX interfaces - thanks Jose Monteiro! (#6248)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18616 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
187a74d337
commit
f6aec9c62c
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=iptraf
|
PKG_NAME:=iptraf
|
||||||
PKG_VERSION:=3.0.1
|
PKG_VERSION:=3.0.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
|
PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
|
||||||
|
40
net/iptraf/patches/005-atheros.patch
Normal file
40
net/iptraf/patches/005-atheros.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
--- a/src/ifaces.c 2009-11-28 18:45:44.000000000 +0000
|
||||||
|
+++ b/src/ifaces.c 2009-11-28 18:47:46.000000000 +0000
|
||||||
|
@@ -32,14 +32,14 @@
|
||||||
|
#include "error.h"
|
||||||
|
|
||||||
|
extern int accept_unsupported_interfaces;
|
||||||
|
-#define NUM_SUPPORTED_IFACES 26
|
||||||
|
+#define NUM_SUPPORTED_IFACES 27
|
||||||
|
|
||||||
|
extern int daemonized;
|
||||||
|
|
||||||
|
char ifaces[][6] =
|
||||||
|
{ "lo", "eth", "sl", "ppp", "ippp", "plip", "isdn", "dvb",
|
||||||
|
"pvc", "hdlc", "ipsec", "sbni", "tr", "wvlan", "wlan", "sm2", "sm3",
|
||||||
|
- "pent", "lec", "brg", "tun", "tap", "cipcb", "tunl", "vlan"
|
||||||
|
+ "pent", "lec", "brg", "tun", "tap", "cipcb", "tunl", "vlan", "ath"
|
||||||
|
};
|
||||||
|
|
||||||
|
char *ltrim(char *buf)
|
||||||
|
--- a/src/packet.c 2009-11-28 18:45:44.000000000 +0000
|
||||||
|
+++ b/src/packet.c 2009-11-28 18:48:06.000000000 +0000
|
||||||
|
@@ -104,6 +104,8 @@
|
||||||
|
result = LINK_ETHERNET;
|
||||||
|
else if (strncmp(ifname, "tap", 3) == 0)
|
||||||
|
result = LINK_ETHERNET;
|
||||||
|
+ else if (strncmp(ifname, "ath", 3) == 0)
|
||||||
|
+ result = LINK_ETHERNET;
|
||||||
|
else if ((strncmp(ifname, "isdn", 4) == 0) && (isdn_fd != -1)) {
|
||||||
|
isdnent = isdn_table_lookup(isdnlist, ifname, isdn_fd);
|
||||||
|
|
||||||
|
--- a/src/promisc.c 2009-11-28 18:45:44.000000000 +0000
|
||||||
|
+++ b/src/promisc.c 2009-11-28 18:48:28.000000000 +0000
|
||||||
|
@@ -82,6 +82,7 @@
|
||||||
|
|
||||||
|
if ((strncmp(buf, "eth", 3) == 0) ||
|
||||||
|
(strncmp(buf, "tr", 2) == 0) ||
|
||||||
|
+ (strncmp(buf, "ath", 3) == 0) ||
|
||||||
|
(strncmp(buf, "vlan", 4) == 0) ||
|
||||||
|
(strncmp(ptmp->params.ifname, "wvlan", 4) == 0) ||
|
||||||
|
(strncmp(ptmp->params.ifname, "lec", 3) == 0) ||
|
Loading…
x
Reference in New Issue
Block a user