[packages] lftp: update to 4.0.7
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21539 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
808bc7393d
commit
f7a1999dd0
@ -1,7 +1,6 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2008-2010 OpenWrt.org
|
# Copyright (C) 2008-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
@ -9,13 +8,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=lftp
|
PKG_NAME:=lftp
|
||||||
PKG_VERSION:=4.0.5
|
PKG_VERSION:=4.0.7
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://lftp.cybermirror.org \
|
PKG_SOURCE_URL:=http://lftp.cybermirror.org \
|
||||||
http://lftp.cybermirror.org/old
|
http://lftp.cybermirror.org/old
|
||||||
PKG_MD5SUM:=5400cad5f91e131ac2ded7c24aea594c
|
PKG_MD5SUM:=a40e4518fc477c82ffcc5b04d9ff64ff
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
@ -58,7 +57,7 @@ MAKE_VARS += \
|
|||||||
define Package/lftp/install
|
define Package/lftp/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lftp $(1)/usr/bin
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lftp $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/lftp/postinst
|
define Package/lftp/postinst
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/lib/gettext.h
|
--- a/lib/gettext.h
|
||||||
+++ b/lib/gettext.h
|
+++ b/lib/gettext.h
|
||||||
@@ -22,7 +22,6 @@
|
@@ -23,7 +23,6 @@
|
||||||
#if ENABLE_NLS
|
#if ENABLE_NLS
|
||||||
|
|
||||||
/* Get declarations of GNU message catalog functions. */
|
/* Get declarations of GNU message catalog functions. */
|
||||||
@ -8,7 +8,7 @@
|
|||||||
|
|
||||||
/* You can set the DEFAULT_TEXT_DOMAIN macro to specify the domain used by
|
/* You can set the DEFAULT_TEXT_DOMAIN macro to specify the domain used by
|
||||||
the gettext() and ngettext() macros. This is an alternative to calling
|
the gettext() and ngettext() macros. This is an alternative to calling
|
||||||
@@ -54,7 +53,6 @@
|
@@ -55,7 +54,6 @@
|
||||||
#if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3)
|
#if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3)
|
||||||
# include <cstdlib>
|
# include <cstdlib>
|
||||||
# if (__GLIBC__ >= 2) || _GLIBCXX_HAVE_LIBINTL_H
|
# if (__GLIBC__ >= 2) || _GLIBCXX_HAVE_LIBINTL_H
|
||||||
|
Loading…
x
Reference in New Issue
Block a user