Port irssi to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4410 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fe3f01e100
commit
f87c83bd09
58
net/irssi/Makefile
Normal file
58
net/irssi/Makefile
Normal file
@ -0,0 +1,58 @@
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=irssi
|
||||
PKG_VERSION:=0.8.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE_URL:=http://irssi.org/files/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
|
||||
PKG_MD5SUM:=38e616bccb6a34ff6d91690317c2fa19
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/irssi
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+glib +libncurses
|
||||
TITLE:=console irc client
|
||||
DESCRIPTION:=IRC client for the text console
|
||||
URL:=http://irssi.org
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--with-perl=no \
|
||||
--with-glib1 \
|
||||
--with-gnu-ld \
|
||||
--with-textui \
|
||||
--without-terminfo \
|
||||
--without-bot \
|
||||
--without-file-offset-size \
|
||||
--without-ssl \
|
||||
--disable-ssl \
|
||||
--disable-ipv6 \
|
||||
--disable-proxy \
|
||||
--with-glib-prefix=$(STAGING_DIR)/usr,ac_cv_c_bigendian=no \
|
||||
ac_cv_sizeof_off_t=8)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC=$(TARGET_CC)
|
||||
endef
|
||||
|
||||
define Package/irssi/install
|
||||
mkdir -p $(1)/usr/bin
|
||||
$(CP) $(PKG_BUILD_DIR)/src/fe-text/$(PKG_NAME) $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,irssi))
|
54
net/irssi/patches/100-cross_compiling_fix.patch
Normal file
54
net/irssi/patches/100-cross_compiling_fix.patch
Normal file
@ -0,0 +1,54 @@
|
||||
diff -ruN irssi-0.8.10.orig/configure irssi-0.8.10/configure
|
||||
--- irssi-0.8.10.orig/configure 2005-12-11 23:46:06.000000000 +0100
|
||||
+++ irssi-0.8.10/configure 2006-02-24 13:19:21.570891250 +0100
|
||||
@@ -21848,13 +21848,6 @@
|
||||
|
||||
echo "$as_me:$LINENO: checking size of off_t" >&5
|
||||
echo $ECHO_N "checking size of off_t... $ECHO_C" >&6
|
||||
-if test "$cross_compiling" = yes; then
|
||||
- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&5
|
||||
-echo "$as_me: error: cannot run test program while cross compiling
|
||||
-See \`config.log' for more details." >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -21872,35 +21865,8 @@
|
||||
}
|
||||
|
||||
_ACEOF
|
||||
-rm -f conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
-
|
||||
- sizeof_off_t=`cat conftestval`
|
||||
- rm -f conftestval
|
||||
-
|
||||
-else
|
||||
- echo "$as_me: program exited with status $ac_status" >&5
|
||||
-echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-( exit $ac_status )
|
||||
-
|
||||
- { { echo "$as_me:$LINENO: error: Unsupported off_t size" >&5
|
||||
-echo "$as_me: error: Unsupported off_t size" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
-
|
||||
-fi
|
||||
+ sizeof_off_t=8
|
||||
rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-fi
|
||||
echo "$as_me:$LINENO: result: $sizeof_off_t" >&5
|
||||
echo "${ECHO_T}$sizeof_off_t" >&6
|
||||
|
Loading…
x
Reference in New Issue
Block a user