update at package

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26384 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2011-03-30 23:09:08 +00:00
parent 1b6d4fd149
commit f92232055d
5 changed files with 24 additions and 94 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2008-2009 OpenWrt.org
# Copyright (C) 2008-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=at
PKG_VERSION:=3.1.10ubuntu4
PKG_RELEASE:=2
PKG_VERSION:=3.1.12
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://archive.ubuntu.com/ubuntu/pool/main/a/at
PKG_MD5SUM:=64eec8c9e5a6e16e775ee9efe31b8508
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/a/at
PKG_MD5SUM:=1e67991776148fb319fd77a2e599a765
include $(INCLUDE_DIR)/package.mk
@ -22,24 +22,24 @@ define Package/at
CATEGORY:=Utilities
DEPENDS:=+libelf
TITLE:=Delayed job execution and batch processing
URL:=http://packages.ubuntu.com/at
URL:=http://packages.debian.org/stable/at
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
endef
define Package/at/description
At and batch read shell commands from standard input
storing them as a job to be scheduled for execution in the
future.
At and batch read shell commands from standard input storing them as a job to
be scheduled for execution in the future.
endef
export SENDMAIL=/bin/true
EXTRA_CFLAGS:=-DNEED_YYWRAP -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include/libelf \
$(TARGET_LDFLAGS)
CONFIGURE_ARGS+=--with-daemon_username=nobody \
CONFIGURE_ARGS+=--prefix=/usr \
--with-daemon_username=nobody \
--with-daemon_groupname=nogroup \
--with-jobdir=/var/spool/cron/atjobs \
--with-atspool=/var/spool/cron/atspool \
--without-pam \
--with-atspool=/var/spool/cron/atspool
define Package/at/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/sbin $(1)/etc/init.d/

View File

@ -1,5 +1,5 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2008 OpenWrt.org
# Copyright (C) 2011 OpenWrt.org
START=50
start() {

View File

@ -1,11 +1,11 @@
--- at-3.1.10ubuntu4/configure 2008-04-21 21:14:40.000000000 +0200
+++ at-3.1.10ubuntu4/configure 2008-04-21 21:18:09.000000000 +0200
@@ -1037,7 +1037,7 @@
echo $ac_n "checking Trying to compile a trivial ANSI C program""... $ac_c" 1>&6
echo "configure:1039: checking Trying to compile a trivial ANSI C program" >&5
if test "$cross_compiling" = yes; then
- { echo "configure: error: Could not compile and run even a trivial ANSI C program - check CC." 1>&2; exit 1; }
+ { echo "configure: error: Could not compile and run even a trivial ANSI C program, ignoring as we're cross compiling." 1>&2 ; }
--- at-3.1.12/configure 2009-11-23 16:11:52.000000000 +0100
+++ at-3.1.12/configure 2011-03-30 13:50:03.725526083 +0200
@@ -3417,7 +3417,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking Trying to compile a trivial ANSI C program" >&5
$as_echo_n "checking Trying to compile a trivial ANSI C program... " >&6; }
if test "$cross_compiling" = yes; then :
- as_fn_error "Could not compile and run even a trivial ANSI C program - check CC." "$LINENO" 5
+ # as_fn_error "Could not compile and run even a trivial ANSI C program - check CC. Ignoring as we're cross compiling." "$LINENO" 5
else
cat > conftest.$ac_ext <<EOF
#line 1044 "configure"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */

View File

@ -1,14 +0,0 @@
--- at-3.1.10ubuntu4/getloadavg.c 2008-04-21 21:54:03.000000000 +0200
+++ at-3.1.10ubuntu4/getloadavg.c 2008-04-21 21:54:21.000000000 +0200
@@ -69,8 +69,9 @@
#include <config.h>
#endif
-#include "lisp.h"
-#include "sysfile.h" /* for encapsulated open, close, read, write */
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <fcntl.h>
#ifndef HAVE_GETLOADAVG

View File

@ -1,56 +0,0 @@
diff -urN at-3.1.10ubuntu4/configure at-3.1.10ubuntu4.new/configure
--- at-3.1.10ubuntu4/configure 2006-06-28 04:21:49.000000000 +0200
+++ at-3.1.10ubuntu4.new/configure 2008-10-20 17:20:27.000000000 +0200
@@ -2687,50 +2687,8 @@
fi
done
-for ac_hdr in security/pam_appl.h
-do
-ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
-echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-echo "configure:2695: checking for $ac_hdr" >&5
-if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- cat > conftest.$ac_ext <<EOF
-#line 2700 "configure"
-#include "confdefs.h"
-#include <$ac_hdr>
-EOF
-ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:2705: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
-ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
-if test -z "$ac_err"; then
- rm -rf conftest*
- eval "ac_cv_header_$ac_safe=yes"
-else
- echo "$ac_err" >&5
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- eval "ac_cv_header_$ac_safe=no"
-fi
-rm -f conftest*
-fi
-if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
- echo "$ac_t""yes" 1>&6
- ac_tr_hdr=HAVE_`echo $ac_hdr | sed 'y%abcdefghijklmnopqrstuvwxyz./-%ABCDEFGHIJKLMNOPQRSTUVWXYZ___%'`
- cat >> confdefs.h <<EOF
-#define $ac_tr_hdr 1
-EOF
- PAMLIB="-lpam"
- cat >> confdefs.h <<\EOF
-#define HAVE_PAM 1
-EOF
-
-else
- echo "$ac_t""no" 1>&6
-fi
-done
-
+# Disable PAM
+echo "$ac_t""no" 1>&6
# Extract the first word of "sendmail", so it can be a program name with args.