[packages] net/iperf: fix a bug in single thread mode
root@OpenWrt:/# iperf -c 192.168.20.100 -i 60 ------------------------------------------------------------ Client connecting to 192.168.20.100, TCP port 5001 TCP window size: 16.0 KByte (default) ------------------------------------------------------------ [ 3] local 192.168.20.1 port 53214 connected with 192.168.20.100 port 5001 [ ID] Interval Transfer Bandwidth [ 3] 0.0--7988.8 sec 0.00 Bytes -0.00 bits/sec [ ID] Interval Transfer Bandwidth [ 3] -7988.8--7928.8 sec 0.00 Bytes 0.00 bits/sec git-svn-id: svn://svn.openwrt.org/openwrt/packages@14776 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8471d730e9
commit
f929c75d1d
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=iperf
|
PKG_NAME:=iperf
|
||||||
PKG_VERSION:=2.0.4
|
PKG_VERSION:=2.0.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||||
|
@ -0,0 +1,14 @@
|
|||||||
|
--- a/src/Reporter.c
|
||||||
|
+++ b/src/Reporter.c
|
||||||
|
@@ -309,6 +309,11 @@ ReportHeader* InitReport( thread_Setting
|
||||||
|
#else
|
||||||
|
// set start time
|
||||||
|
gettimeofday( &(reporthdr->report.startTime), NULL );
|
||||||
|
+
|
||||||
|
+ // set next time
|
||||||
|
+ reporthdr->report.nextTime = reporthdr->report.startTime;
|
||||||
|
+ TimeAdd( reporthdr->report.nextTime, reporthdr->report.intervalTime );
|
||||||
|
+
|
||||||
|
/*
|
||||||
|
* Process the report in this thread
|
||||||
|
*/
|
Loading…
x
Reference in New Issue
Block a user