Add xrandr package.
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13331 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6eb53794b8
commit
fad241e45c
39
Xorg/app/xrandr/Makefile
Normal file
39
Xorg/app/xrandr/Makefile
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2008 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=xrandr
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_VERSION:=1.2.3
|
||||||
|
PKG_SOURCE_URL:=http://xorg.freedesktop.org/releases/X11R7.4/src/app
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_BUILD_DIR=$(BUILD_DIR)/Xorg/$(_CATEGORY)/$(PKG_NAME)-$(PKG_VERSION)/
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
TARGET_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||||
|
|
||||||
|
define Package/xrandr
|
||||||
|
SECTION:=xorg-app
|
||||||
|
CATEGORY:=Xorg
|
||||||
|
SUBMENU:=app
|
||||||
|
DEPENDS:=+libX11 +libXrandr +libXrender +libX11
|
||||||
|
TITLE:=xrandr
|
||||||
|
URL:=http://xorg.freedesktop.org/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xrandr/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/bin/* \
|
||||||
|
$(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,xrandr))
|
@ -0,0 +1,35 @@
|
|||||||
|
--- xrandr-1.2.3/xrandr.c.orig 2007-10-25 17:18:55.001346494 +0200
|
||||||
|
+++ xrandr-1.2.3/xrandr.c 2007-10-25 17:21:07.222276308 +0200
|
||||||
|
@@ -189,7 +189,7 @@
|
||||||
|
|
||||||
|
#if HAS_RANDR_1_2
|
||||||
|
typedef enum _policy {
|
||||||
|
- clone, extend
|
||||||
|
+ p_clone, p_extend
|
||||||
|
} policy_t;
|
||||||
|
|
||||||
|
typedef enum _relation {
|
||||||
|
@@ -1602,7 +1602,7 @@
|
||||||
|
int ret = 0;
|
||||||
|
#if HAS_RANDR_1_2
|
||||||
|
output_t *output = NULL;
|
||||||
|
- policy_t policy = clone;
|
||||||
|
+ policy_t policy = p_clone;
|
||||||
|
Bool setit_1_2 = False;
|
||||||
|
Bool query_1_2 = False;
|
||||||
|
Bool modeit = False;
|
||||||
|
@@ -1863,12 +1863,12 @@
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
if (!strcmp ("--clone", argv[i])) {
|
||||||
|
- policy = clone;
|
||||||
|
+ policy = p_clone;
|
||||||
|
setit_1_2 = True;
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
if (!strcmp ("--extend", argv[i])) {
|
||||||
|
- policy = extend;
|
||||||
|
+ policy = p_extend;
|
||||||
|
setit_1_2 = True;
|
||||||
|
continue;
|
||||||
|
}
|
Loading…
x
Reference in New Issue
Block a user