[packages] bwping: update to 1.3, drop obsolete patch, use PKG_INSTALL
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27119 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
106cfcd372
commit
fb7c41c455
@ -8,14 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=bwping
|
PKG_NAME:=bwping
|
||||||
PKG_VERSION:=1.2
|
PKG_VERSION:=1.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/bwping
|
PKG_SOURCE_URL:=@SF/bwping
|
||||||
PKG_MD5SUM:=4c2215551df7f00de8559fd0cd1ff4db
|
PKG_MD5SUM:=a1207f47ad53b058cf0f3597401469f4
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -27,7 +27,6 @@ define Package/bwping
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/bwping/description
|
define Package/bwping/description
|
||||||
BWPing
|
|
||||||
BWPing is a bandwidth measurement tool based on ICMP echo
|
BWPing is a bandwidth measurement tool based on ICMP echo
|
||||||
request/reply. It is especially well suited for lossy links. BWPing
|
request/reply. It is especially well suited for lossy links. BWPing
|
||||||
does not not require any special software on the remote host (only
|
does not not require any special software on the remote host (only
|
||||||
@ -36,7 +35,7 @@ endef
|
|||||||
|
|
||||||
define Package/bwping/install
|
define Package/bwping/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,bwping))
|
$(eval $(call BuildPackage,bwping))
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -urN bwping-1.2.orig/bwping.c bwping-1.2/bwping.c
|
|
||||||
--- bwping-1.2.orig/bwping.c 2010-01-22 17:49:29.000000000 +0000
|
|
||||||
+++ bwping-1.2/bwping.c 2010-12-07 12:30:26.000000000 +0000
|
|
||||||
@@ -221,7 +221,7 @@
|
|
||||||
unsigned int bufsize, tos, transmitted_number, received_number;
|
|
||||||
unsigned long int kbps, pktsize, volume, rperiod, received_volume;
|
|
||||||
unsigned long long int min_interval, interval, current_interval, integral_error;
|
|
||||||
- char ch;
|
|
||||||
+ int ch;
|
|
||||||
char *ep, *target;
|
|
||||||
fd_set fds;
|
|
||||||
struct sockaddr_in to;
|
|
Loading…
x
Reference in New Issue
Block a user