[packages] collectd: solve "cannot relink convenience library", it was a wrongly applied fixup

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24630 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-12-17 01:42:54 +00:00
parent 081002c1bb
commit fd124fa98b
2 changed files with 0 additions and 23 deletions

View File

@ -16,7 +16,6 @@ PKG_SOURCE_URL:=http://collectd.org/files/
PKG_MD5SUM:=85d9d8d0a1327782661e3c89800aa70e
PKG_FIXUP:=libtool
PKG_LIBTOOL_PATHS:=. libltdl
PKG_REMOVE_FILES:=aclocal.m4 libltdl/aclocal.m4
PKG_INSTALL:=1

View File

@ -1,22 +0,0 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -85,7 +85,7 @@ endif
if BUILD_WITH_OWN_LIBOCONFIG
collectd_LDADD += $(LIBLTDL) liboconfig/liboconfig.la
-collectd_DEPENDENCIES += $(LIBLTDL) liboconfig/liboconfig.la
+collectd_DEPENDENCIES += liboconfig/liboconfig.la
else
collectd_LDADD += -loconfig
endif
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -57,7 +57,7 @@ bin_PROGRAMS = collectd-nagios$(EXEEXT)
@BUILD_WITH_LIBSTATGRAB_TRUE@am__append_13 = $(BUILD_WITH_LIBSTATGRAB_CFLAGS)
@BUILD_WITH_LIBSTATGRAB_TRUE@am__append_14 = $(BUILD_WITH_LIBSTATGRAB_LDFLAGS)
@BUILD_WITH_OWN_LIBOCONFIG_TRUE@am__append_15 = $(LIBLTDL) liboconfig/liboconfig.la
-@BUILD_WITH_OWN_LIBOCONFIG_TRUE@am__append_16 = $(LIBLTDL) liboconfig/liboconfig.la
+@BUILD_WITH_OWN_LIBOCONFIG_TRUE@am__append_16 = liboconfig/liboconfig.la
@BUILD_WITH_OWN_LIBOCONFIG_FALSE@am__append_17 = -loconfig
@BUILD_WITH_LIBSOCKET_TRUE@am__append_18 = -lsocket
@BUILD_AIX_TRUE@am__append_19 = -lm