libs/libpam: update to version 1.1.4
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28316 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d3ddd45994
commit
fd82c2dbfb
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libpam
|
PKG_NAME:=libpam
|
||||||
PKG_VERSION:=1.1.3
|
PKG_VERSION:=1.1.4
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=Linux-PAM-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/libs/pam/library
|
PKG_SOURCE_URL:=http://pkgs.fedoraproject.org/repo/pkgs/pam/Linux-PAM-1.1.4.tar.bz2/e9af5fb27bb22edb55d077e2888b3ebc/
|
||||||
PKG_MD5SUM:=6db7fcb5db6253350e3a4648ceac40e7
|
PKG_MD5SUM:=e9af5fb27bb22edb55d077e2888b3ebc
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
|
|
||||||
|
35
libs/libpam/patches/000-OE-libpam-xtests.patch
Normal file
35
libs/libpam/patches/000-OE-libpam-xtests.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
This patch is used to create a new sub package libpam-xtests to do more checks.
|
||||||
|
|
||||||
|
Upstream-Status: Pending
|
||||||
|
|
||||||
|
Signed-off-by: Kang Kai <kai.kang@windriver.com>
|
||||||
|
--- a/xtests/Makefile.am
|
||||||
|
+++ b/xtests/Makefile.am
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
|
||||||
|
-L$(top_builddir)/libpam_misc -lpam_misc
|
||||||
|
|
||||||
|
-CLEANFILES = *~ $(XTESTS)
|
||||||
|
+CLEANFILES = *~
|
||||||
|
|
||||||
|
EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
|
||||||
|
tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
|
||||||
|
@@ -51,3 +51,18 @@
|
||||||
|
|
||||||
|
xtests: $(XTESTS) run-xtests.sh
|
||||||
|
"$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}
|
||||||
|
+
|
||||||
|
+all: $(XTESTS)
|
||||||
|
+
|
||||||
|
+install: install_xtests
|
||||||
|
+
|
||||||
|
+install_xtests:
|
||||||
|
+ $(INSTALL) -d $(DESTDIR)$(pkgdatadir)/xtests
|
||||||
|
+ for file in $(EXTRA_DIST) ; do \
|
||||||
|
+ $(INSTALL) $$file $(DESTDIR)$(pkgdatadir)/xtests ; \
|
||||||
|
+ done
|
||||||
|
+ for file in $(XTESTS); do \
|
||||||
|
+ $(INSTALL) .libs/$$file $(DESTDIR)$(pkgdatadir)/xtests ; \
|
||||||
|
+ done
|
||||||
|
+
|
||||||
|
+.PHONY: all install_xtests
|
@ -11,28 +11,28 @@
|
|||||||
#ifdef HAVE_LIBAUDIT
|
#ifdef HAVE_LIBAUDIT
|
||||||
--- a/modules/pam_unix/pam_unix_passwd.c
|
--- a/modules/pam_unix/pam_unix_passwd.c
|
||||||
+++ b/modules/pam_unix/pam_unix_passwd.c
|
+++ b/modules/pam_unix/pam_unix_passwd.c
|
||||||
@@ -55,10 +55,10 @@
|
@@ -74,18 +74,18 @@
|
||||||
#include <sys/time.h>
|
#include "passverify.h"
|
||||||
#include <sys/stat.h>
|
#include "bigcrypt.h"
|
||||||
#include <rpc/rpc.h>
|
|
||||||
-#ifdef HAVE_RPCSVC_YP_PROT_H
|
-#if (HAVE_YP_GET_DEFAULT_DOMAIN || HAVE_GETDOMAINNAME) && HAVE_YP_MASTER
|
||||||
+#ifdef HAVE_RPCSVC_YP_PROT_H && USE_NIS
|
+#if (HAVE_YP_GET_DEFAULT_DOMAIN || HAVE_GETDOMAINNAME) && HAVE_YP_MASTER && USE_NIS
|
||||||
#include <rpcsvc/yp_prot.h>
|
# define HAVE_NIS
|
||||||
#endif
|
|
||||||
-#ifdef HAVE_RPCSVC_YPCLNT_H
|
|
||||||
+#ifdef HAVE_RPCSVC_YPCLNT_H && USE_NIS
|
|
||||||
#include <rpcsvc/ypclnt.h>
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@@ -104,7 +104,7 @@ extern int getrpcport(const char *host,
|
#ifdef HAVE_NIS
|
||||||
|
# include <rpc/rpc.h>
|
||||||
|
|
||||||
|
-# if HAVE_RPCSVC_YP_PROT_H
|
||||||
|
+# if HAVE_RPCSVC_YP_PROT_H && USE_NIS
|
||||||
|
# include <rpcsvc/yp_prot.h>
|
||||||
|
# endif
|
||||||
|
|
||||||
|
-# if HAVE_RPCSVC_YPCLNT_H
|
||||||
|
+# if HAVE_RPCSVC_YPCLNT_H && USE_NIS
|
||||||
|
# include <rpcsvc/ypclnt.h>
|
||||||
|
# endif
|
||||||
|
|
||||||
static char *getNISserver(pam_handle_t *pamh, unsigned int ctrl)
|
|
||||||
{
|
|
||||||
-#if (defined(HAVE_YP_GET_DEFAULT_DOMAIN) || defined(HAVE_GETDOMAINNAME)) && defined(HAVE_YP_MASTER)
|
|
||||||
+#if (defined(HAVE_YP_GET_DEFAULT_DOMAIN) || defined(HAVE_GETDOMAINNAME)) && defined(HAVE_YP_MASTER) && defined(USE_NIS)
|
|
||||||
char *master;
|
|
||||||
char *domainname;
|
|
||||||
int port, err;
|
|
||||||
--- a/modules/pam_unix/support.c
|
--- a/modules/pam_unix/support.c
|
||||||
+++ b/modules/pam_unix/support.c
|
+++ b/modules/pam_unix/support.c
|
||||||
@@ -19,7 +19,7 @@
|
@@ -19,7 +19,7 @@
|
||||||
|
16
libs/libpam/patches/005-fix_ruserok.patch
Normal file
16
libs/libpam/patches/005-fix_ruserok.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- a/modules/pam_rhosts/pam_rhosts.c
|
||||||
|
+++ b/modules/pam_rhosts/pam_rhosts.c
|
||||||
|
@@ -111,11 +111,13 @@ int pam_sm_authenticate (pam_handle_t *p
|
||||||
|
as_root = (lpwd->pw_uid == 0);
|
||||||
|
}
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
#ifdef HAVE_RUSEROK_AF
|
||||||
|
retval = ruserok_af (rhost, as_root, ruser, luser, PF_UNSPEC);
|
||||||
|
#else
|
||||||
|
retval = ruserok (rhost, as_root, ruser, luser);
|
||||||
|
#endif
|
||||||
|
+#endif
|
||||||
|
if (retval != 0) {
|
||||||
|
if (!opt_silent || opt_debug)
|
||||||
|
pam_syslog(pamh, LOG_WARNING, "denied access to %s@%s as %s",
|
Loading…
x
Reference in New Issue
Block a user