[package] Upgrade openconnect to v3.15
This fixes a bunch of interoperability issues, and one or two crashes. Signed-off-by: David Woodhouse <dwmw2@infradead.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@31135 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0c0f62de36
commit
ff029ef59c
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openconnect
|
PKG_NAME:=openconnect
|
||||||
PKG_VERSION:=2.25
|
PKG_VERSION:=3.15
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
|
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
|
||||||
PKG_MD5SUM:=796a32b611ee6210a5367eb9684d6778
|
PKG_MD5SUM:=94245f4bac42a288100becab0b4ca29a
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -34,22 +34,12 @@ define Package/openconnect/description
|
|||||||
3800, 7200 Series and Cisco 7301 Routers.
|
3800, 7200 Series and Cisco 7301 Routers.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
CONFIGURE_ARGS+=--disable-shared
|
||||||
$(call Build/Compile/Default, \
|
|
||||||
SSL_CFLAGS="" \
|
|
||||||
OPT_FLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
|
|
||||||
OS="Linux" \
|
|
||||||
STAGING_DIR="$(STAGING_DIR)" \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
PREFIX=/usr \
|
|
||||||
all install \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/openconnect/install
|
define Package/openconnect/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/openconnect \
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/openconnect \
|
||||||
$(1)/usr/bin/
|
$(1)/usr/sbin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,openconnect))
|
$(eval $(call BuildPackage,openconnect))
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -15,7 +15,7 @@ endif
|
|
||||||
# dir; there's no need to install it anywhere (we link it statically).
|
|
||||||
ifdef OPENSSL
|
|
||||||
SSL_CFLAGS += -I$(OPENSSL)/include
|
|
||||||
-SSL_LDFLAGS += $(OPENSSL)/libssl.a $(OPENSSL)/libcrypto.a
|
|
||||||
+SSL_LDFLAGS += $(OPENSSL)/lib/libssl.a $(OPENSSL)/lib/libcrypto.a
|
|
||||||
else
|
|
||||||
ifeq ($(wildcard /usr/include/openssl),)
|
|
||||||
$(error "No OpenSSL in /usr/include/openssl. Cannot continue");
|
|
Loading…
x
Reference in New Issue
Block a user