[package] update mdnsresponder to 214.3.2 (#8083)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23754 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e14a6af15c
commit
ff2ac2bebe
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mDNSResponder
|
PKG_NAME:=mDNSResponder
|
||||||
PKG_VERSION:=107.6
|
PKG_VERSION:=214.3.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.opensource.apple.com/darwinsource/tarballs/other/
|
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
|
||||||
PKG_MD5SUM:=aa4e0e5c57f94489463ea6576591ce9d
|
PKG_MD5SUM:=05d39f40767ccece4b740c5afad14a23
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/mDNSResponder-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/mDNSResponder-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -1,8 +1,7 @@
|
|||||||
Only in mDNSResponder-107.6/Clients: build
|
diff -u --recursive mDNSResponder-214.3.2-vanilla/Clients/Makefile mDNSResponder-214.3.2/Clients/Makefile
|
||||||
diff -u --recursive mDNSResponder-107.6-vanilla/Clients/Makefile mDNSResponder-107.6/Clients/Makefile
|
--- mDNSResponder-214.3.2-vanilla/Clients/Makefile 2010-10-15 08:38:44.817282399 -0500
|
||||||
--- mDNSResponder-107.6-vanilla/Clients/Makefile 2009-10-16 07:06:53.290266578 -0400
|
+++ mDNSResponder-214.3.2/Clients/Makefile 2010-10-15 08:40:09.696672081 -0500
|
||||||
+++ mDNSResponder-107.6/Clients/Makefile 2009-10-17 04:28:28.447826030 -0400
|
@@ -62,6 +62,8 @@
|
||||||
@@ -49,6 +49,8 @@
|
|
||||||
|
|
||||||
#############################################################################
|
#############################################################################
|
||||||
|
|
||||||
@ -11,68 +10,57 @@ diff -u --recursive mDNSResponder-107.6-vanilla/Clients/Makefile mDNSResponder-1
|
|||||||
# On OS X the dns_sd library functions are included in libSystem, which is implicitly linked with every executable
|
# On OS X the dns_sd library functions are included in libSystem, which is implicitly linked with every executable
|
||||||
# If /usr/lib/libSystem.dylib exists, then we're on OS X, so we don't need also to link the "dns_sd" shared library
|
# If /usr/lib/libSystem.dylib exists, then we're on OS X, so we don't need also to link the "dns_sd" shared library
|
||||||
ifneq "$(wildcard /usr/lib/libSystem.dylib)" ""
|
ifneq "$(wildcard /usr/lib/libSystem.dylib)" ""
|
||||||
@@ -66,4 +68,4 @@
|
@@ -81,10 +83,10 @@
|
||||||
mkdir build
|
mkdir build
|
||||||
|
|
||||||
build/dns-sd: build dns-sd.c
|
build/dns-sd: build dns-sd.c ClientCommon.c
|
||||||
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -o $@
|
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||||
+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -o $@
|
+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||||
diff -u --recursive mDNSResponder-107.6-vanilla/mDNSPosix/Makefile mDNSResponder-107.6/mDNSPosix/Makefile
|
|
||||||
--- mDNSResponder-107.6-vanilla/mDNSPosix/Makefile 2009-10-16 07:06:53.303266301 -0400
|
build/dns-sd64: build dns-sd.c ClientCommon.c
|
||||||
+++ mDNSResponder-107.6/mDNSPosix/Makefile 2009-10-17 06:36:22.154299346 -0400
|
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||||
@@ -267,8 +267,9 @@
|
+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||||
SHAREDDIR = ../mDNSShared
|
|
||||||
|
# Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
|
||||||
|
# don't, because we don't want or need a 'fat' version of dns-sd, because it will
|
||||||
|
diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSResponder-214.3.2/mDNSPosix/Makefile
|
||||||
|
--- mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile 2010-10-15 08:38:44.798283212 -0500
|
||||||
|
+++ mDNSResponder-214.3.2/mDNSPosix/Makefile 2010-10-15 08:46:28.739548087 -0500
|
||||||
|
@@ -316,10 +316,11 @@
|
||||||
|
SHAREDDIR ?= ../mDNSShared
|
||||||
JDK = /usr/jdk
|
JDK = /usr/jdk
|
||||||
|
|
||||||
-CC = @cc
|
-CC = @cc
|
||||||
-LD = ld -shared
|
|
||||||
+CC = @gcc
|
+CC = @gcc
|
||||||
|
BISON = @bison
|
||||||
|
FLEX = @flex
|
||||||
|
-LD = ld -shared
|
||||||
+LD = @ld
|
+LD = @ld
|
||||||
+SOOPTS = -shared
|
+SOOPTS = -shared
|
||||||
CP = cp
|
CP = cp
|
||||||
RM = rm
|
RM = rm
|
||||||
LN = ln -s -f
|
LN = ln -s -f
|
||||||
@@ -293,7 +294,7 @@
|
@@ -344,7 +345,7 @@
|
||||||
CFLAGS_DEBUG = -Os -DMDNS_DEBUGMSGS=0
|
CFLAGS_DEBUG = -Os -DMDNS_DEBUGMSGS=0
|
||||||
OBJDIR = objects/prod
|
OBJDIR ?= objects/prod
|
||||||
BUILDDIR = build/prod
|
BUILDDIR ?= build/prod
|
||||||
-STRIP = strip -S
|
-STRIP = strip -S
|
||||||
+STRIP = @strip -S
|
+STRIP = @strip -S
|
||||||
endif
|
endif
|
||||||
|
|
||||||
# Configure per-OS peculiarities
|
# Configure per-OS peculiarities
|
||||||
@@ -301,7 +302,7 @@
|
@@ -353,7 +354,7 @@
|
||||||
CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -DNOT_HAVE_SOCKLEN_T -DNOT_HAVE_IF_NAMETOINDEX \
|
CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -DNOT_HAVE_SOCKLEN_T -DNOT_HAVE_IF_NAMETOINDEX \
|
||||||
-DLOG_PERROR=0 -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME
|
-DLOG_PERROR=0 -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME -DTARGET_OS_SOLARIS
|
||||||
CC = gcc
|
CC = gcc
|
||||||
-LD = gcc -shared
|
-LD = gcc -shared
|
||||||
+LD = gcc
|
+LD = gcc
|
||||||
LINKOPTS = -lsocket -lnsl -lresolv
|
LINKOPTS = -lsocket -lnsl -lresolv
|
||||||
JAVACFLAGS_OS += -I$(JDK)/include/solaris
|
JAVACFLAGS_OS += -I$(JDK)/include/solaris
|
||||||
ifneq ($(DEBUG),1)
|
ifneq ($(DEBUG),1)
|
||||||
@@ -347,7 +348,8 @@
|
@@ -404,7 +405,8 @@
|
||||||
|
CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp -Werror -Wdeclaration-after-statement \
|
||||||
ifeq ($(os),jaguar)
|
-D__MAC_OS_X_VERSION_MIN_REQUIRED=__MAC_OS_X_VERSION_10_4 #-Wunreachable-code
|
||||||
CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp -Werror -DNOT_HAVE_SOCKLEN_T
|
|
||||||
-LD = libtool -dynamic
|
|
||||||
+LD = libtool
|
|
||||||
+SOOPTS = -dynamic
|
|
||||||
LINKOPTS = -lSystem
|
|
||||||
LDSUFFIX = dylib
|
|
||||||
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
|
||||||
@@ -356,7 +358,8 @@
|
|
||||||
|
|
||||||
ifeq ($(os),panther)
|
|
||||||
CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp -Werror
|
|
||||||
-LD = libtool -dynamic
|
|
||||||
+LD = libtool
|
|
||||||
+SOOPTS = -dynamic
|
|
||||||
LINKOPTS = -lSystem
|
|
||||||
LDSUFFIX = dylib
|
|
||||||
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
|
||||||
@@ -366,7 +369,8 @@
|
|
||||||
ifeq ($(os),tiger)
|
|
||||||
CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp -Werror -Wdeclaration-after-statement #-Wunreachable-code
|
|
||||||
CC = @gcc-4.0
|
CC = @gcc-4.0
|
||||||
-LD = $(CC) -dynamiclib
|
-LD = $(CC) -dynamiclib
|
||||||
+LD = $(CC)
|
+LD = $(CC)
|
||||||
@ -80,18 +68,18 @@ diff -u --recursive mDNSResponder-107.6-vanilla/mDNSPosix/Makefile mDNSResponder
|
|||||||
LINKOPTS = -lSystem
|
LINKOPTS = -lSystem
|
||||||
LDSUFFIX = dylib
|
LDSUFFIX = dylib
|
||||||
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
||||||
@@ -390,8 +394,9 @@
|
@@ -426,8 +428,9 @@
|
||||||
NSSLINKNAME := $(NSSLIBNAME).so.2
|
NSSLINKNAME := $(NSSLIBNAME).so.2
|
||||||
NSSINSTPATH := /lib
|
NSSINSTPATH := /lib
|
||||||
|
|
||||||
-# If not otherwise defined, we install into /usr/lib and /usr/include
|
-# If not otherwise defined, we install into /usr/lib and /usr/include
|
||||||
+# If not otherwise defined, we install into /usr/lib, /usr/include & /etc
|
+# If not otherwise defined, we install into /usr/lib, /usr/include and /etc
|
||||||
# and our startup script is called mdns (e.g. /etc/init.d/mdns)
|
# and our startup script is called mdns (e.g. /etc/init.d/mdns)
|
||||||
+ETCBASE?=/etc
|
+ETCBASE?=/etc
|
||||||
INSTBASE?=/usr
|
INSTBASE?=/usr
|
||||||
STARTUPSCRIPTNAME?=mdns
|
STARTUPSCRIPTNAME?=mdns
|
||||||
|
|
||||||
@@ -473,7 +478,7 @@
|
@@ -511,7 +514,7 @@
|
||||||
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
|
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
|
||||||
|
|
||||||
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
|
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
|
||||||
@ -100,7 +88,7 @@ diff -u --recursive mDNSResponder-107.6-vanilla/mDNSPosix/Makefile mDNSResponder
|
|||||||
@$(STRIP) $@
|
@$(STRIP) $@
|
||||||
|
|
||||||
Clients: setup libdns_sd ../Clients/build/dns-sd
|
Clients: setup libdns_sd ../Clients/build/dns-sd
|
||||||
@@ -508,7 +513,7 @@
|
@@ -546,7 +549,7 @@
|
||||||
InstalledClients: $(INSTBASE)/bin/dns-sd
|
InstalledClients: $(INSTBASE)/bin/dns-sd
|
||||||
@echo $+ " installed"
|
@echo $+ " installed"
|
||||||
|
|
||||||
@ -109,7 +97,7 @@ diff -u --recursive mDNSResponder-107.6-vanilla/mDNSPosix/Makefile mDNSResponder
|
|||||||
@echo $+ " installed"
|
@echo $+ " installed"
|
||||||
|
|
||||||
# Note: If daemon already installed, we make sure it's stopped before overwriting it
|
# Note: If daemon already installed, we make sure it's stopped before overwriting it
|
||||||
@@ -563,19 +568,21 @@
|
@@ -601,19 +604,21 @@
|
||||||
|
|
||||||
$(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
|
$(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
|
||||||
$(LN) $< $@
|
$(LN) $< $@
|
||||||
|
@ -1,14 +1,15 @@
|
|||||||
diff -u --recursive mDNSResponder-107.6-vanilla/mDNSPosix/Makefile mDNSResponder-107.6/mDNSPosix/Makefile
|
diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSResponder-214.3.2/mDNSPosix/Makefile
|
||||||
--- mDNSResponder-107.6-vanilla/mDNSPosix/Makefile 1970-01-01 08:24:35.000000000 -0500
|
--- mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile 2010-10-15 08:38:44.798283212 -0500
|
||||||
+++ mDNSResponder-107.6/mDNSPosix/Makefile 1970-01-01 08:32:57.000000000 -0500
|
+++ mDNSResponder-214.3.2/mDNSPosix/Makefile 2010-10-15 08:48:27.334503432 -0500
|
||||||
@@ -309,11 +309,15 @@
|
@@ -361,12 +361,16 @@
|
||||||
endif
|
endif
|
||||||
else
|
else
|
||||||
|
|
||||||
-ifeq ($(os),linux)
|
-ifeq ($(os),linux)
|
||||||
+# Any variant containing linux:
|
+# Any variant containing linux:
|
||||||
+ifeq ($(findstring linux,$(os)),linux)
|
+ifeq ($(findstring linux,$(os)),linux)
|
||||||
CFLAGS_OS = -DNOT_HAVE_SA_LEN -DUSES_NETLINK -DHAVE_LINUX
|
CFLAGS_OS = -DNOT_HAVE_SA_LEN -DUSES_NETLINK -DHAVE_LINUX -DTARGET_OS_LINUX
|
||||||
|
FLEXFLAGS_OS = -l
|
||||||
JAVACFLAGS_OS += -I$(JDK)/include/linux
|
JAVACFLAGS_OS += -I$(JDK)/include/linux
|
||||||
+# uClibc does not provide NSS, do not compile nss_mdns:
|
+# uClibc does not provide NSS, do not compile nss_mdns:
|
||||||
+ifneq ($(os),linux-uclibc)
|
+ifneq ($(os),linux-uclibc)
|
||||||
|
Loading…
x
Reference in New Issue
Block a user